PDA

View Full Version : Troubles with Opera.



SeriousMan
26th September 2005, 09:13 PM
I installed opera and it works fine, but there is one thing i don't like about it. A new "Internet" menu appeared at the top of the "settings" menu. Any ideas on how to remove it?

imdeemvp
27th September 2005, 09:35 AM
Can you post part of the screenshot where the menu appears because I dont see it in mine.

SeriousMan
27th September 2005, 02:22 PM
http://selecter.vnet.ee/~seriousman/screenshot.png

Finalzone
27th September 2005, 05:44 PM
Do

yum install smeg
This application will allow you to customize the menu. Hope it helps.

O(V)eGA_l2el)
27th September 2005, 06:35 PM
Do

yum install smeg
This application will allow you to customize the menu. Hope it helps.

Excellent, after you mentioned this editor, I was manually editing menus. :)

SeriousMan
28th September 2005, 03:54 PM
As far as i know, smeg doesn't see the menu entries in "System", only "Applications". So this doesn't help. Thank you for trying anyway.

imdeemvp
28th September 2005, 07:04 PM
I believe that opera just creates a new dictory for itself after installing. Smeg is menu editor but will not see it..

Raafi
30th October 2005, 12:30 PM
I LOST MY OPERA

I have uninstalled it, reinstalled it, I even went as far as deleting everything in my computer named "opera", and still when I try to open it from the icon, NOTHING

from the command line, i get this
# opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
NPP_GetValue()
NPP_GetValue()
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
Segmentation fault

Last I can remember, opera worked fine until i opened Konqueror

I dont know if there is a relationship, but thats the best I can think of, other than normal "yum -y update" i dont really do anything with my computer to have caused this malfunction.

Does anyone know what may be wrong, or how to correct this?

liquidBass
1st November 2005, 11:02 AM
Those look like java libraries that it can't load. Don't know why though. :(

ArthurK
1st November 2005, 08:35 PM
For the menu entry probem:

When Opera is installed it creates 3 seperate menus entry locations:
/usr/share/applnk/Internet/opera.desktop
/etc/X11/applnk/Internet/opera.desktop
/usr/share/gnome/apps/Internet/opera.desktop

To remove the redundant two entry type the following in a terminal shell:

su -
rm /etc/X11/applnk/Internet/opera.desktop
rm /usr/share/gnome/apps/Internet/opera.desktop
exit

ArthurK
1st November 2005, 08:40 PM
@Raafi

Try to move the Opera profile folder located in your home directory and see if recreating the profile helps.

mv .opera .operaBAK

Raafi
2nd November 2005, 03:22 AM
[root@nj ~]# rm /etc/X11/applnk/Internet/opera.desktop
rm: remove regular file `/etc/X11/applnk/Internet/opera.desktop'? y
[root@nj ~]# rm /usr/share/gnome/apps/Internet/opera.desktop
rm: cannot lstat `/usr/share/gnome/apps/Internet/opera.desktop': No such file or directory
[root@nj ~]# mv .opera .operaBAK
[root@nj ~]# opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
NPP_GetValue()
NPP_GetValue()
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
Segmentation fault
[root@nj ~]# whereis opera
opera: /usr/bin/opera /usr/lib/opera /usr/X11R6/bin/opera /usr/bin/X11/opera /usr/share/opera /usr/share/man/man1/opera.1
[root@nj ~]# rm /usr/bin/opera /usr/lib/opera
rm: remove regular file `/usr/bin/opera'? y
rm: cannot remove directory `/usr/lib/opera': Is a directory
[root@nj ~]# rm /usr/X11R6/bin/opera
rm: remove symbolic link `/usr/X11R6/bin/opera'? y
[root@nj ~]# rm /usr/bin/X11/opera
rm: cannot lstat `/usr/bin/X11/opera': No such file or directory
[root@nj ~]# rm /usr/share/opera
rm: cannot remove directory `/usr/share/opera': Is a directory
[root@nj ~]# rm /usr/share/man/man1/opera.1
rm: remove regular file `/usr/share/man/man1/opera.1'? y
[root@nj ~]# opera
-bash: /usr/bin/opera: No such file or directory

after all of this, i go to reinstall opera, and it says, it is already installed

ArthurK
2nd November 2005, 04:52 AM
It sounds like this is a bug with opera. Check out the following link:
http://my.opera.com/community/forums/topic.dml?id=108820
It sounds like a plugin problem with opera. Which plugins do you have installed for opera?

Also, when you delete those files manually, the rpm database does not know about it so it says that it is still installed. To uninstall it use the normal rpm command:
rpm -e opera
The rpm program will then be updated. Then reinstall opera to track down the problem. The link above did have a suggested procedure to try to correct this problem.

Raafi
7th November 2005, 07:14 PM
Thanks Arthur

I am at work now. But looking thru that, it looks like it might help. But for some reason, the past two days Opera has been working fine (i made it my default browser). I have no idea if that did the trick.

Again, thanks for the link

Raafi
15th May 2006, 09:34 AM
This worked

[root@localhost ~]# rpm -e mozilla-vlc-0.8.4-0.lvn.10.a.4.i386
[root@localhost ~]# opera
NPP_GetValue()
NPP_GetValue()
[root@localhost ~]#