PDA

View Full Version : Samba not promptign for password



mbrice81
26th September 2005, 07:51 PM
So i have a working Samba server here. The problem is that after a few days, it starts giving me access denied errors. I think it has to do with me only being asked, when i first reboot the server, to supply a username and password. For some reason, i cannot restart the service and get it to ask me again. i have to reboot the whole server in order to get a username password prompt.

Is there some samba setting that will make me enter a username and password each time? is there anything i can do about the fact that the record of my authentication goes "Stale" as it were and while i can view all the files, i cannot write to them or delete or change them. Windows 2k just says "access denied"

sure i can reboot the server and re get the prompt but thats kind of insane.

any help appreicated

SlowJet
26th September 2005, 08:36 PM
FC3 or FC4?
If FC4 go get the 4 rpm's from www.sama.org for sama-3.0.20 (download to Desktop and (rpm -U packagename12 3 4)
turn off the seleinux for smbd and nmbd by clicking check boxes on in the Security / Fire wall gui.
(This version will be out for FC4 soon and you can update it to use SElinux and relabel then but the older version of Samba are just too buggy to deal with.)

After updating go to www.samba.org and read How-to-install Samba-3.020 article on the front page (This is also in the How-to forum.)

Remeber W2K use classic security model by default, and XP uses (guest, restircted, everybody) type model.
Meaning you need to set the security (users and rights) on W2K shares to something Linux can deal with.

SJ

mbrice81
27th September 2005, 07:18 PM
Fixed the problem.

On windows type 'net use' to get a list of the shares.

then type ' net use //SERVER/SHARE /delete '


and it will re prompt you to login when you browse to the path.

mighty_falcon
25th December 2005, 03:22 AM
thank you so much! saved me from loosing my hair

you really gotta hate win!