PDA

View Full Version : mount permitions



jsvoyager
26th September 2005, 05:18 AM
I've read as much as I can bear on the subject of the fstab, but I just can't seem to get what I need done.

I'm trying to mount a vfat partiton in such a way that it and all of its sub directories have 777 (everyone do everything) permissions and, if possible, I, not root, own it. Here's what I've got:

<code>/dev/sda6 /media/d_win vfat auto,user,exec,rw,sync,mode=777 0 0</code>

I know this subject has been brought up hundereds of times but I really can't seem to get it. Thanks

Spoon!
26th September 2005, 10:04 AM
I think instead of "mode=777" you want "umask=000"

steve1961
26th September 2005, 07:16 PM
This is the entry I have for a shared vfat partition between FC4 and windows:

/dev/sda5 /media/shared vfat umask=000 0 0

sda5 is obviously the vfat partition, and I've created the /media/shared directory to mount it. This gives all users read/write access.

jsvoyager
27th September 2005, 04:33 AM
Thanks all for the input. I set umask to 000 and as far as I can tell everyone has 777 permisions. However, when I'm in azureus, I get the following error when trying to saive to a file to that mount:

Error: Operation not permitted, setLength fails (allocateFiles new:/media/d_win/downloads/file.name)

However when saiving the same torrent to my home, it works. I'm assuming this has something to do with the way the drive is mounted, but I may be worng. Thoughts?

Thanks

steve1961
27th September 2005, 08:32 PM
I tried modifying my fstab entry to:

/dev/sda5 /media/shared vfat rw,users,umask=000 0 0

This seems to work even better. My shared partition now appears in the places menu and although I used to get occasional errors when using k3b to burn files from this partition everything now seems to be fine.

jsvoyager
27th September 2005, 10:27 PM
Thanks for the suggestion, but same error

schlongsalami
4th October 2005, 10:26 PM
Thanks for the suggestion, but same errorI had the same error, and it disappeared when I re-downloaded the .torrent file. Hope it works for you too. :)

Moha
8th October 2005, 06:13 PM
i have the same problem with azureus and can't find a way to fix it. can anybody shed a light on this?
(i can rwx on my partitions, but strangely enough azureus gives me problems :S)

ubunturefugee
17th October 2005, 07:31 PM
If you're trying to write the torrent to a FAT32 partition, you're having the same problem I was. In Azureus, go to Options > Files and make sure 'enable incremental file creation' is checked.

unwill
18th January 2006, 01:36 PM
And if you don't see the;
Tools -> Options -> Files -> "Enable incremental file creation." option,

then go to Tools -> Option -> Mode and change to Intermediate or advanced.