View Full Version : 2002 "Dual USB" iBook FC4

21st September 2005, 09:41 PM
Hello everyone. I thought I would share this post to document my woes and successes with my personal iBook (which is beginning to feel a bit ancient). Let me first mention that I've run YDL 3.0 on this iBook and it worked perfectly without any hitches or any gotchas.

Before YDL, I've also run the freebsd PPC port and the openBSD PPC port, so I've got a little bit of experience working with running strange installations on my iBook.

Ironically though, I've never run a dual-boot situation. Every single time I've wanted to reload the little baby iBook I've done so knowing full and well I was going to destroy all of my data. So I have virtually zero advice to offer any dual-booters out there who insist they keep Mac OS X (although I had little reason to given how slow it runs on my iBook).

Anywho where do I start. First off I think that FC4 is certainly the smoothest running alternative OS that runs on my iBook. Whether or not this is because of the 2.6 kernel or not I'm not sure. Perhaps YDL 4, which I believe runs a 2.6 kernel as well, would run smoothly as well-- but it certainly outperforms YDL 3 as far as the feel and the way things operate goes.

So, without further ado let me walk you guys through what I did to install FC4 on my baby iBook:

I burned all five isos to seperate CD's and was able to boot up into linux without any issues by holding down the c button after a power-on which tells the iBook to boot from the CD.

The first issue I ran into, is for some unknown reason, even though the installer booted from the CD without any problems (albeit almost painfully slow) it refused to acknowledge the actual installation files on the CD. I had to get around this by making identical copies of the iso files onto my iPod. When I booted the installer again with the iPod connected via USB, I told Fedora to use a hard drive as the source and pointed it to sda2 in the / directory. I was pleasantly surprised to see that Fedora had no issues automounting the iPod and grabbing the isos painlessly. The installation would have proceeded fine from this point except I ran into the error thats been mentioned quite a bit about the partition size being out of range.

The partition error (I forgot what exactly it was) would pop up over and over again irregardless of what I did or what I wiped out. Since I had no qualms about trashing the drive I assumed I would fix it once and for all and switched to another console while it was in the GUI portion of the install and happily (maniacally even) destroyed the partition on the hard drive by doing a dd if=/dev/zero of=/dev/hda bs=1024k count=5

After, I did that, and subsequently reboot, the installer and I agreed a lot better and the errors about partition sizes were gone completely.

I read in another forum that you weren't supposed to use the "Automatic partitioning" because it didn't set up Yaboot correctly, so I proceeded to use Disk Druid and setup my first partition as a 1 MB Apple Bootstrap partition, then set up my swap partition, and then set up my final partition to fill the rest of the drive.

When I was done Disk Druid resorted them to:

/dev/hda1 = Apple Boot strap (1 mb)
/dev/hda2 = / (8.7 gigs or so)
/dev/hda3 = swap (700 megs)

The installation from there proceeded without problems, however it was slooow over that horrible 12 mbps USB-- took about an hour and a half. After that linux rebooted with nothing but a few issues with fstab.

For some reason the labels in fstab became corrupt and it added in garbled characters to the label that fstab refused to acknowledge. This only appeared to happen to the swap partition. I was able to fix it by changing it from LABEL=(garbled characters) to just /dev/hda4

Now why would I specify /dev/hda4? I'm not sure, for whatever reason that was what showed up as the swap. Somehow or another, even though I trashed the partitions and set them up with my own eyes with only three partitions with Disk Druid, the installation of yaboot (I'm assuming) somehow invalidated my partition setup.

Linux didn't really seem to mind, but fdisk sure does. Running an fdisk -l reports that there are no valid partitions on the disk -- even though linux happily sees them and everything just appears to be moved upwards in designation by one. (/ is now mounted on /dev/hda3, swap is on /dev/hda4) so I really didn't care-- Fedora worked!

Now for what doesn't work:

** The software modem in my iBook is broken, until somebody can figure out a reliable way to get hcfusbmodem proprietary drivers from linuxant.com to work in FC4. I've seen references to it working just fine in FC3 but apparently I was to have no such luck in this regard. Unfortunately I'm stuck in the stone age with internet access and until I can resolve or find someone who can resolve this issue, I'm not able to use my modem (bummer).

** The audio in the iBook doesn't appear to work at all. The hardware is detected just fine and even the modules are loaded, but the audio no-worky.

In the old YDL 2.0 there was an easy fix for this, by just telling artsd inside of KDE to only use 8 bit audio to output sound (apparently this is a limitation of these ancient 2002 iBooks) but that doesn't appear to fix the problem here. YDL 3.0 successfully would catch the fact that you were using an old iBook and appropriately set it up for you.

I saw some references to adding in modules for OSS inside of FC3 to fix it, but I haven't been able to successfully make those same changes in FC4 to fix it so I'm afraid I'm lost on this one as well. I hope somebody will be able to help.