PDA

View Full Version : Installing Superkaramba



ksuil
16th September 2005, 11:36 PM
Hey, get this error when trying to install superkaramba. I am very new to linux, running FC4. Tried installing an rpm I found for qt 3.3.14 (I think) and it came back saying that a newer version was in place.

any suggestions?

checking for Qt... configure: error: Qt (>= Qt 3.3) (headers and libraries) not found. Please check your installation!

Clunixchit
16th September 2005, 11:47 PM
C++ preprocessor error
Problem: configure: error: C++ preprocessor "/lib/cpp" fails sanity check
Solution: # yum install gcc-c++

KDE: QT error
Problem: configure: error: Qt (>= Qt 3.2)
Solution: # yum install qt-devel

KDE: missing headers
Problem:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
Solution: #yum install kdelibs-devel

ksuil
17th September 2005, 12:09 AM
Thanks for the swift reply, I appreciate that. unfortutely, none of that worked

yum install gcc-c++
results in

[root@localhost superkaramba-0.37-RC1]# yum install gcc-c++
Setting up Install Process
Setting up repositories
updates-released 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 300 kB 00:01
updates-re: ################################################## 931/931
Added 0 new packages, deleted 18 old in 0.96 seconds
Parsing package install arguments
Nothing to do



yum install qt-devel
results in

[root@localhost superkaramba-0.37-RC1]# yum install qt-devel
Setting up Install Process
Setting up repositories
updates-released 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 298 kB 00:02
updates-re: ################################################## 925/925
Added 4 new packages, deleted 10 old in 0.82 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package qt-devel.i386 1:3.3.4-15.1 set to be updated
--> Running transaction check
--> Processing Dependency: qt = 1:3.3.4-15.1 for package: qt-devel
--> Finished Dependency Resolution
Error: Missing Dependency: qt = 1:3.3.4-15.1 is needed by package qt-devel

and

Solution: #yum install kdelibs-devel
results in

[root@localhost superkaramba-0.37-RC1]# yum install kdelibs-devel
Setting up Install Process
Setting up repositories
updates-released 100% |=========================| 95
1 B 00:00
extras 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 734 kB 00:01
extras : ################################################## 2077/2077
Added 0 new packages, deleted 23 old in 1.41 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kdelibs-devel to pack into transaction set.
kdelibs-devel-3.4.2-0.fc4 100% |=========================| 860 kB 00:01
---> Package kdelibs-devel.i386 6:3.4.2-0.fc4.1 set to be updated
--> Running transaction check
--> Processing Dependency: pcre-devel for package: kdelibs-devel
--> Processing Dependency: qt-devel >= 1:3.3.4 for package: kdelibs-devel
--> Processing Dependency: arts-devel for package: kdelibs-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for pcre-devel to pack into transaction set.
pcre-devel-5.0-4.1.fc4.i3 100% |=========================| 7.3 kB 00:00
---> Package pcre-devel.i386 0:5.0-4.1.fc4 set to be updated
---> Downloading header for arts-devel to pack into transaction set.
arts-devel-1.4.2-0.fc4.1. 100% |=========================| 20 kB 00:00
---> Package arts-devel.i386 8:1.4.2-0.fc4.1 set to be updated
---> Package qt-devel.i386 1:3.3.4-15.1 set to be updated
--> Running transaction check
--> Processing Dependency: qt = 1:3.3.4-15.1 for package: qt-devel
--> Finished Dependency Resolution
Error: Missing Dependency: qt = 1:3.3.4-15.1 is needed by package qt-devel

Clunixchit
17th September 2005, 12:37 PM
so you are missing qt

yum install qt qt-devel

ksuil
17th September 2005, 03:53 PM
thanks, I finally got it working last night. turned out I was missing Coin2. as well as a few other dependencies. Appreciate the assistance.

Clunixchit
17th September 2005, 04:03 PM
good job :)

dox22
10th October 2005, 12:53 AM
Hi, How you could install the Superkaramba?

I have the same error in ./configure


checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


I run this instructions, and my system download the packages, but superkaramba send the same error.

# yum install gcc-c++
# yum install qt-devel
#yum install qt qt-devel

I have FC4 x64
2.6.11-1.1369_FC4

Clunixchit
10th October 2005, 02:05 AM
depending on your qt version, mine 3.3 try these lines as root:

ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so
ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so.3
ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so.3.3

then compile the sources

ybnorml
10th October 2005, 03:22 AM
I'm getting the same Perl error, don't know which to install.

Clunixchit
10th October 2005, 06:37 AM
I'm getting the same Perl error, don't know which to install.

make sure you try all the three of them:

# yum install gcc-c++
# yum install qt-devel
#yum install qt qt-devel

dox22
10th October 2005, 01:04 PM
Ok Dancer ET, your lines work fine!, thanks a lot.

ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so
ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so.3
ln -sf /usr/lib/qt-3.3/lib/libqt-mt.so /usr/lib/qt-3.3/lib/libqt.so.3.3


Now i have a second error :


checking for Qt... libraries /usr/lib64/qt-3.3/lib, headers /usr/lib64/qt-3.3/include using -mt
checking for moc... /usr/lib64/qt-3.3/bin/moc
checking for uic... /usr/lib64/qt-3.3/bin/uic
checking whether uic supports -L ... yes
checking whether uic supports -nounload ... yes
checking if Qt needs -ljpeg... no
checking for rpath... yes
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
[root@R4000 superkaramba-0.36]#

Clunixchit
10th October 2005, 03:36 PM
verify with
rpm-qa | grep kde whether ou have these

kdesdk-devel-3.4.2-0.fc4.1
kdelibs-3.4.2-0.fc4.1
kdeutils-devel-3.4.2-0.fc4.1
kdesdk-3.4.2-0.fc4.1
kdelibs-devel-3.4.2-0.fc4.1
kdebase-devel-3.4.2-0.fc4.1

ybnorml
11th October 2005, 12:51 AM
I didn't get a KDE error right off. What I got was something saying that qt wasn't installed or it couldn't find the src files or something. I checked my app listing in Yum and Apt and they both said it was installed. I'll download it again and try again.

dox22
11th October 2005, 02:59 AM
Dancer ET, I follow your instructions, this are the result:


[root@R4000 superkaramba-0.36]# rpm -qa | grep kde
kdelibs-3.4.0-6
kdemultimedia-3.4.0-2
lockdev-1.0.1-7
kdebase-3.4.0-5
kdenetwork-3.4.0-3
lockdev-1.0.1-7
kdebase-3.4.0-5
lockdev-devel-1.0.1-7
kdeaddons-3.4.0-2
kdemultimedia-3.4.0-2
kdegraphics-3.4.0-2
kdeutils-3.4.0-1
unixODBC-kde-2.2.11-1
kdepim-3.4.0-4
kdeartwork-3.4.0-1
kde-i18n-Spanish-3.4.0-1
kdelibs-3.4.0-6


Any help?, mi system send the same error:


checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

My best regards!

Clunixchit
11th October 2005, 08:47 AM
you didnt install the development packages


yum install kdesdk-devel kdelibs kdeutils-devel kdesdk kdelibs-devel kdebase-devel

dox22
12th October 2005, 04:14 AM
:( Dancer ET, Superkaramba is a crazy and terrible software!!!!!, now I have the next error when I try to make

[root@R4000 superkaramba-0.36]# make
make all-recursive
make[1]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36'
Making all in doc
make[2]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc'
Making all in .
make[3]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc'
Making all in en
make[3]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc/en'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc/en'
make[2]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/doc'
Making all in po
make[2]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/po'
Making all in src
make[2]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/src'
make[3]: Entering directory `/home/dox22/Downloads/Temp/superkaramba-0.36/src'
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/kde -I/usr/lib64/qt-3.3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -MT bar_python.o -MD -MP -MF ".deps/bar_python.Tpo" -c -o bar_python.o bar_python.cpp; \
then mv -f ".deps/bar_python.Tpo" ".deps/bar_python.Po"; else rm -f ".deps/bar_python.Tpo"; exit 1; fi
bar_python.cpp:27:20: error: Python.h: No such file or directory
meter_python.h:22: error: ‘PyObject’ was not declared in this scope
meter_python.h:22: error: ‘text’ was not declared in this scope
meter_python.h:23: error: expected constructor, destructor, or type conversion before ‘*’ token
.
etc
.
bar_python.cpp:160: error: expected constructor, destructor, or type conversion before ‘*’ token
make[3]: *** Error 1
make[3]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dox22/Downloads/Temp/superkaramba-0.36'
make: *** [all] Error 2

Thanks a lot for all your help [B]Clunixchit!

Clunixchit
12th October 2005, 08:33 AM
you just need some dependencies:


sudo yum install python python-devel

another way instead of compiling from sources, could be installing its rpm:
For FC4 (http://rpm.pbone.net/index.php3/stat/4/idpl/2037482/com/superkaramba-0.36-0.0.fc4.kde.i386.rpm.html)
for fc3 (http://rpm.pbone.net/index.php3/stat/4/idpl/2037465/com/superkaramba-0.36-0.0.fc3.kde.i386.rpm.html)

while using those rpms, you will get a clear view of what your FC is missing :)

ybnorml
13th October 2005, 01:11 AM
I'm still getting:

checking for Qt... configure: error: Qt (>= Qt 3.3) (headers and libraries) not found. Please check your installation!

Even after doing the qt and qt-devel install. gcc and c are installed as well as the kde files right up there ^. I don't know what else to do.

dox22
13th October 2005, 02:19 AM
Dancer ET, thanks for all your help!!!, but I desist to install 'Superkaramba", this ****ing software only send errors!!!!, probably are incompatibility with FC4 x64, maybe I try to install a 32bit version of FC4.

My best regards man, God bless you, person like you make the reputation of Linux, persons like me make the reputation of the facility of Windows ;)

Clunixchit
13th October 2005, 12:03 PM
Try the links i gave in post #8
then compile superkaramba again

dox22
14th October 2005, 03:06 PM
I try that (post #8), but don't work. I try to install the rpm, but he need a kdelibs, and other think (I don't remember, and in my job only use Windows), I download these things, but when I try to install the system send an error about incompatibility software.

Maybe I spend my time try to fix another things in Linux, for example: How I run codes like root when the system start?, I need run codes (script) for configure my wireless card, this happen ever when I reboot my system.

ybnorml
15th October 2005, 03:21 PM
Ideas, anyone?


I'm still getting:

checking for Qt... configure: error: Qt (>= Qt 3.3) (headers and libraries) not found. Please check your installation!

Even after doing the qt and qt-devel install. gcc and c are installed as well as the kde files right up there ^. I don't know what else to do.

b4gi
22nd October 2005, 05:41 AM
./configure --prefix=/usr --with-qt-dir=/usr/lib/qt-3.3/