PDA

View Full Version : Eclipse can't create project



XenoTron
3rd September 2005, 08:49 PM
I installed eclipse by using "yum install eclipse" and it installed fine, but when I try creating a new project it gives me the helpful error "An error occured while creating project." It says to see the erorr log for more details, but I can't find where the erorr log is. I tried opening the view "PDE Runtime -> error log" but nothing comes up. I also tried removing the eclipse through yum and installed it myself from eclipse.org. When I tried doing that I got the same erorrs, although it created the project anyway. When I tried saving a file though it gave me a class not found error for UniversalUniqueIdentifier, so it refused to save anything. I'm not sure which install of eclipse is less buggy, how did you guys setup eclipse? I have FC4 on a AMD64 if that means anything regarding this problem.

Jman
4th September 2005, 04:45 AM
Install it with
yum groupinstall "Java Development" There's more packages than just the eclipse one.

How is Java set up on this system? gcj from Fedora or Sun Java?

gavinw6662
4th September 2005, 05:44 AM
wow, I think I installed eclipse from the cd's, but I can't figure out how to run it... =(

Jman
4th September 2005, 09:12 PM
Running it's easy, it's in the Development section of the apps menu.

XenoTron
4th September 2005, 09:14 PM
yum groupinstall "Java Development" didn't help me. It tried installing some ant packages I didn't have and also tried updating my kernel, nothing related to java or eclipse though. It's using gcj from Fedora as the java version, but as far as I can tell java works fine and my problem is just with eclipse.

EDIT: I was looking closer at the stacktraces I'm getting everytime I try starting a new project or creating a new class. It looks like I'm having some issues with /usr/lib64/libgcj.so.6.0.0, is there anyway I can re-install this or update it or just see if it's corrupt? Or would it be a bad idea to mess with that file?

john.ennew
5th September 2005, 10:50 AM
I am getting the same problem. When I try and save inside a java project I get an error:

Save Failed:null

Then every subsequent save comes up with the error:

Save Failed: org.eclipse.core.internal.utils.UniversalUniqueIde ntifier

No changes are actually saved. I am running FC4 and I have all the "Java Development" and "Eclipse" packages installed.

Cheers,
John