View Full Version : Debugging Anaconda

Alex Lang
2nd September 2005, 04:20 PM
I have an AMD-64 ASUS A8V system that I have progressively installed Fedora Core 1, 2 and 3 on. I tried to upgrade to Core 4 last night, but after the media check, Anaconda dies, simply stating that "anaconda exited abnormally" with no indication of the problem.

How does one begin to try and figure out why? Does Anaconda attempt to leave log files somewhere? Can a verbose mode be enabled to get more extensive error reporting?

I do have a somewhat unusal settup in that I run with SCSI disks, but have an ATA disk for achival storage and have a DVD CDROM attached that from which I boot the Core 4 Disk 1.

Thanks for the help,

Alex Lang
3rd September 2005, 10:10 PM
Went back and tried again; Anaconda from Fedora Core 3 inits fine. Looks like something has changed from 3 to 4. Can anyone give me a hint on how to figure out what broke it?

Alex Lang
6th September 2005, 03:18 PM
OK, one more bump to the top and then I'll admit defeat. There must be a way to get better error reporting from Anaconda when it sees something that it doesn't like!

7th September 2005, 03:30 AM
anaconda does log a bunch of stuf in /root of the newly formatted system, I believe it's /root/install.log.syslog, but that won't help much.

Sometimes I get python exceptions from anaconda which would let me save a stack trace or go into some kind of debug mode. I don't think you're far enough for that either.

Maybe the best you can do is to file a bug at bugzilla.redhat.com against anaconda with details about any interesting hardware you have.

7th September 2005, 01:00 PM
No help I'm afraid but will be watching the thread for I have the exact same problem, IBM & never any worries with FC 3 but alas can't even get installer to run, tried different monitor(s), & every suggested form of nofb etc etc etc but always get to the same spot as you & anaconda gives that msg.

Frustrating but ........ I gues I'm stuck on FC 3 a little longer, assuming there is a fix in FC5:-)

Thanks to all for any help


7th September 2005, 05:07 PM
We do have a list of the install options you have. If you wanted to try again and disable some hardware probing you could.

Alex Lang
7th September 2005, 06:14 PM
Jman: So you are suggesting use of the "noprobe" option?

11th September 2005, 10:33 AM
Yes tried all the options suggested, tried different img sources tried every suggestion given over literally dozens of attemps over months; & no joy.

I started with RH5 & this is the first time I can't even get started:-) so looks like I'm the perfect crash test dummy:-) This is akin to the sound in FC2

Clearly it's not a common problem because we are not seeing endless posts etc so I guess I will just wait a bit.

Thanks again for your time.