PDA

View Full Version : Fedora Core 4 - Boot up problems



Myztek
30th August 2005, 03:57 AM
Okay, I downloaded Fedora Core 4 two days ago and in that short amount of time I've already REinstalled it TEN times.

The main problem is my Radeon 9600 drivers, which have failed to work for me, and when I try to update/install or anything and then reboot it either stops and freezes while starting up or gives me the following error:

"An error occurrred during the file system check. Dropping you to a shell: the system will reboot when you leave the shell. Warning -- SELinux is active. Disabling security enforcement for system recovery. Run 'setenforce 1' to reenable. Give root password for maintenance(or type Control-D to continue):"

And when I reboot, 75% of the time I have to turn my computer off with the power button and try again for it to boot up all the way.

Please help me v______v

Knudson
30th August 2005, 10:04 AM
Hi

are you using ReiserFS or JFS ? SElinux won't work with those file systems !

by using yum (check the faqs) you won't have any problem to install the ATi drivers!

let me know!

Myztek
30th August 2005, 01:42 PM
So, I shouldn't be using SELinux?

And, I tried installing the ATI drivers, but everytime I reboot it wont start again and I need to reformat! ;_;

Please help. I want to use Linux o.o

Maners
30th August 2005, 02:15 PM
So, I shouldn't be using SELinux?

Yes, especially if you use filesysytems other than ext3. Furthermore, you won't benefit too much from SELinux if you use your sysyem for desktop type of work or just playing with Linux.


And, I tried installing the ATI drivers, but everytime I reboot it wont start again and I need to reformat! ;_;

http://www.fedorafaq.org/#radeon - thry these instructions first. If this doesn't work try to use original ATI drivers installer from here: https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27

Also, please try to be more specicfic when you describe your problems.

Myztek
30th August 2005, 02:29 PM
I'll try those.

I've been installing with the ext2 format. Should I use ext3 this time?

What do you need me to be more specific with?

-=EDIT=-

Also, I don't know if this is relevant or not, but I've been choosing "Everything" under package installation as well.

Knudson
30th August 2005, 03:00 PM
actually, if you ARE using ReiserFS or JFS , no, you must turn off SElinux. That's bad i know, i had to switch to ext3, but it wasn't THAT painful.

with ext2 you shouldn't had those problem, anyway...try with ext3 and let us know.

Or before formatting, try disabling SElinux and see what happens!

knudson

Myztek
30th August 2005, 03:14 PM
I couldn't get on to disable it if I wanted to.

I'm reformatting for the 11th time right now. This time using ext3 with SELinux DISABLED. I'll let you know what happens.

Myztek
30th August 2005, 04:42 PM
Yesssssssss!!! I got it to work. This is what I did:

Reinstalled Linux with ext3 and SELinux disabled.

As soon as I booted up I ran "up2date"

I then rebooted and ran the following commands:
cd /etc
rm -f yum.conf
wget http://www.fedorafaq.org/samples/yum.conf
rpm -Uvh http://www.fedorafaq.org/yum
yum install ati-fglrx kernel-module-fglrx-$(uname -r)

Then rebooted again.


Now I'm getting 5,000+ FPS! :D :D