PDA

View Full Version : Amarok Update Problem from yum -y update



Raafi
23rd August 2005, 11:47 AM
I did my yum -y update for the morning and this is what came up


[root@localhost ~]# yum -y update Setting up Update Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 340 kB 00:03
updates-re: ################################################## 930/930
Added 0 new packages, deleted 16 old in 18.12 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package amarok.i386 0:1.3-4.fc4 set to be updated
---> Package amarok-visualisation.i386 0:1.3-4.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: amarok = 1.2.4 for package: amarok-arts
--> Processing Dependency: amarok = 1.2.4 for package: amarok-akode
--> Finished Dependency Resolution
Error: Missing Dependency: amarok = 1.2.4 is needed by package amarok-arts
Error: Missing Dependency: amarok = 1.2.4 is needed by package amarok-akode
[root@localhost ~]#

Not a big problem, I just figured I would alert whoever may be handling this issue. My yum.conf is soley the one listed in the UnOfficial Fedora FAQ section

marcos
23rd August 2005, 09:44 PM
There is nothing wrong with your yum.conf. The reason for this is that some dependencies for amaroK are not yet prepared for its new release, 1.3. To solve your problem just uninstall the dependencies:
"yum remove amarok-arts amarok-akode"

Then run "yum update" again. Without those dependencies (uninstalled in the previous step), amaroK will reconfigure itself to use the gstream engine. If you really want to use those others engines, wait until someone create new version for them.

Iram Hernandez
26th August 2005, 07:33 AM
I just did a yum update and it pretty much hosed my amarok. I tried the amarok related stuff that wasn't 1.3 but that didn't fix anything. Amarok now complains that there is no plugins available and refuses to run. It's damned silly of the fedora packagers to put 1.3 out there without any of the plugins to actually mae the program usable. I now get:


amaroK could not find any sound-engine plugins. amaroK is now updating the KDE configuration database. Please wait a couple of minutes, then restart amaroK.
If this does not help, it is likely that amaroK is installed under the wrong prefix, please fix your installation using:
$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ ./configure --prefix=`kde-config --prefix` && su -c "make install"
$ kbuildsycoca
$ amarok
More information can be found in the README file. For further assistance join us at #amarok on irc.freenode.net.

Raafi
26th August 2005, 12:25 PM
Marcos

Sorry for the delay, thanks for the info, it worked. I dont really use amarok, but it was this error I was getting, while updating, that was driving me crazy

marcos
26th August 2005, 01:33 PM
I just did a yum update and it pretty much hosed my amarok. I tried the amarok related stuff that wasn't 1.3 but that didn't fix anything. Amarok now complains that there is no plugins available and refuses to run. It's damned silly of the fedora packagers to put 1.3 out there without any of the plugins to actually mae the program usable.

I'm afraid I can't help you out, but I'm wandering if you have tried to install the amarok-xine engine 1.3. I've installed a test version (because there is not a stable one yet) built for FC4. You can search it at rpm.pbone.net.

Iram Hernandez
26th August 2005, 08:15 PM
Still not working... I guess I should go to the previous version and just not run yum update for a while. This package should never had made it into the extras repository.


[iram@pheonix Milk]$ sudo yum --enablerepo=kde-redhat-testing install amarok-xine
Setting up Install Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
nr-mono 100% |=========================| 1.0 kB 00:00
updates 100% |=========================| 951 B 00:00
kde-redhat-testing 100% |=========================| 951 B 00:00
gstreamer 100% |=========================| 951 B 00:00
extras 100% |=========================| 951 B 00:00
release 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package amarok-xine.i386 0:1.3-5.fc4.kde set to be updated
--> Running transaction check
--> Processing Dependency: libxine.so.1 for package: amarok-xine
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xine-lib.i386 0:1.1.0-0.lvn.3.4 set to be updated
--> Running transaction check
--> Processing Dependency: libfusion-0.9.so.22 for package: xine-lib
--> Processing Dependency: libmodplug.so.0 for package: xine-lib
--> Processing Dependency: libdirect-0.9.so.22 for package: xine-lib
--> Processing Dependency: libdirectfb-0.9.so.22 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package directfb.i386 0:0.9.22-2.fc4 set to be updated
---> Package libmodplug.i386 1:0.7-3.fc4 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
amarok-xine i386 1.3-5.fc4.kde kde-redhat-testing 53 k
Installing for dependencies:
directfb i386 0.9.22-2.fc4 extras 1.9 M
libmodplug i386 1:0.7-3.fc4 extras 114 k
xine-lib i386 1.1.0-0.lvn.3.4 livna 3.3 M

Transaction Summary
================================================== ===========================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 5.3 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
warning: amarok-xine-1.3-5.fc4.kde: Header V3 DSA signature: NOKEY, key ID ff6382fa
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: libmodplug ######################### [1/4]
Installing: directfb ######################### [2/4]
Installing: xine-lib ######################### [3/4]
Installing: amarok-xine ######################### [4/4]

Installed: amarok-xine.i386 0:1.3-5.fc4.kde
Dependency Installed: directfb.i386 0:0.9.22-2.fc4 libmodplug.i386 1:0.7-3.fc4 xine-lib.i386 0:1.1.0-0.lvn.3.4
Complete!
[iram@pheonix Milk]$

Flyboy917
26th August 2005, 11:23 PM
I upgraded last night using Yum. The only problem I'm having is that when I add it the the launcer panel, it can't find the correct icon. Musicbrainz doesn't work either...but then again it never did.
Other than that it works like a champ. I love the improved layout and the VERY cool new features!