PDA

View Full Version : yum problem



iamroot
20th August 2005, 03:34 AM
I'm trying to use yum to install a clamtk package that I downloading manually off the net. Everything works fine until it gets to the install part.

Transaction Summary
================================================== ===========================
Install 8 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 979 k
Is this ok [y/N]: y
Downloading Packages:
unsigned package clamtk-2.04-1.fc4.i386.rpm
[root@cm14 dangel]#

How do I install this "unsigned package"?

jgutty
20th August 2005, 04:33 AM
You can try to set the gpgcheck=0 in /etc/yum.conf I've never tried it myself

iamroot
20th August 2005, 08:49 AM
But this package is an external packge I downloaded from rpmfind. It's not from the repos. I used the yum localinstall option.

macgregor
20th August 2005, 09:27 AM
But this package is an external packge I downloaded from rpmfind. It's not from the repos. I used the yum localinstall option.
Yes, but the default yum.conf has this line:

gpgcheck=1

That tells yum to check keys on all packages regardless of which repos are used.

You have two options.
1) Open that rpm in file-roller and look for an "AUTHORS" file or "README" file and obtain the author URL or email and get the proper key.

OR

2) If you set the gpgcheck line in /etc/yum.conf to gpgcheck=0 then yum won't complain about the missing key.

imdeemvp
20th August 2005, 09:40 AM
I am having same issue. I just ran yum updates and got this:
Install 20 Package(s)
Update 76 Package(s)
Remove 0 Package(s)
Total download size: 206 M
Is this ok [y/N]: y
Downloading Packages:


Package libgnomeui-2.10.1-1.1.fc4.nr.i386.rpm is not signed
[root@laptopFC4 imdeemvp]#

Never had this problem and it must be do to repo error....

UPDATE: I EDITED THE YUM.CONF AND DISABLED GPGCHK= 0 and installed updates!