PDA

View Full Version : Original yum.conf?


haymann
17th August 2005, 03:24 PM
I hope this isn't already posted somewhere... I saw a few online, but I am not sure any of them are for the ppc platform...

I seem to have hosed my yum.conf file, it was working fine after the install, but something I did seemed to mess it up. If someone would be willing to post a working yum.conf for ppc I would greatly appreciate it!

haymann
17th August 2005, 03:25 PM
I suppose that I should add that I am using Fedora Core 4...

tejas
17th August 2005, 03:26 PM
I think you can use regular yum.confs

as it uses variables.

Particularly


$basever (not server, it is base - version.)

It will be i386 or x86_64 or ppc accordingly

bitrain
17th August 2005, 03:33 PM
from www.fedorafaq.org

haymann
17th August 2005, 03:46 PM
I have tired following the directions found at http://www.fedorafaq.org/#yumconf, but I get this error:
Setting up repositories
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.

sayeeth
17th August 2005, 03:53 PM
I have tired following the directions found at http://www.fedorafaq.org/#yumconf, but I get this error:
Setting up repositories
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.

Try doing this,
rpm -ivh http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.2.4.noarch.rpm

It will automatically add livna into your repositories for you.

haymann
17th August 2005, 03:59 PM
Retrieving http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.2.4.noarch.rpm
warning: /var/tmp/rpm-xfer.jqPfBO: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing... ########################################### [100%]
file /etc/yum.repos.d/livna.repo from install of livna-release-4-0.lvn.2.4 conflicts with file from package yum-fedorafaq-4-2005.07.25a

Should I "clear everything out" and try this again?

sayeeth
17th August 2005, 04:02 PM
Retrieving http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.2.4.noarch.rpm
warning: /var/tmp/rpm-xfer.jqPfBO: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing... ########################################### [100%]
file /etc/yum.repos.d/livna.repo from install of livna-release-4-0.lvn.2.4 conflicts with file from package yum-fedorafaq-4-2005.07.25a

Should I "clear everything out" and try this again?

Geez, okay ignore the livna rpm stuff. Just try yum update again.

haymann
17th August 2005, 04:05 PM
Forgive me for sounding dense, but what exactly do you mean by "try yum update again"? I should have probably mentioned, if it wasn't already obvoius, that I am fairly new to Linux (as well as Mac...).
Thanks!

sayeeth
17th August 2005, 04:10 PM
I have tired following the directions found at http://www.fedorafaq.org/#yumconf, but I get this error:
Setting up repositories
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.

Hmm okay, how did you get to see this screen? You opened up a terminal as root and typed yum update, right?

haymann
17th August 2005, 04:13 PM
Correct. This was after I tried the steps listed on the fedorafaq page. Before that I was getting a different error, but I didn't write that one down...

sayeeth
17th August 2005, 04:15 PM
Correct. This was after I tried the steps listed on the fedorafaq page. Before that I was getting a different error, but I didn't write that one down...

Okay, now I want you to try yum update again. See if the same error appears.

haymann
17th August 2005, 04:23 PM
OK, yum update yields
yum update
Setting up Update Process
Setting up repositories
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.

sayeeth
17th August 2005, 04:31 PM
Hmmmm ... perhaps you could post the output of your yum.conf here?
From terminal, cat /etc/yum.conf. Once the information is displayed, just copy and paste the output here.

haymann
17th August 2005, 04:36 PM
# Note: This file is no longer the entire yum configuration
# for fedorafaq.org. See http://www.fedorafaq.org/#yumconf
# for details on how to set up your system with the new
# yum configuration.

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
# We don't want to gpg-check local, unsigned packages
#gpgcheck=1
# Changed this because some mirrors go down and then
# re-trying takes forever.
retries=1
timeout=10

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d


Doesn't look right to me, but according to the fedorafaq site it was updated in late July...

sayeeth
17th August 2005, 04:42 PM
Gee, I'm quite perplexed myself. Can someone else assist?

haymann
17th August 2005, 04:51 PM
Thanks for your help so far. I guess I should have just left things alone... After spending a week getting FC4 to display correctly on my PowerBook G3, I thought this would be an easy one!

tejas
17th August 2005, 04:55 PM
Have you tried following the faq

rpm -Uvh http://www.fedorafaq.org/yum

and also, try to install that livna yum (if the above fails)
using --force
and even --nodeps if absolutely necessary

sayeeth
17th August 2005, 04:57 PM
Thanks for your help so far. I guess I should have just left things alone... After spending a week getting FC4 to display correctly on my PowerBook G3, I thought this would be an easy one!

Okay, I need you to compare my livna repository with yours. Do the following:-
[root@flirt sayeeth]# cat /etc/yum.repos.d/livna.repo
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn/
#baseurl=http://livna.cat.pdx.edu/fedora/$releasever/$basearch/RPMS.lvn/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

axel
17th August 2005, 04:58 PM
Follow these instructions and you should be ok.
http://stanton-finley.net/fedora_core_4_installation_notes.html#Yum

haymann
17th August 2005, 05:08 PM
Okay, I need you to compare my livna repository with yours. Do the following:-
[root@flirt sayeeth]# cat /etc/yum.repos.d/livna.repo
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn/
#baseurl=http://livna.cat.pdx.edu/fedora/$releasever/$basearch/RPMS.lvn/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna


[root@FD4-PPC etc]# cat /etc/yum.repos.d/livna.repo[/B]
cat: /etc/yum.repos.d/livna.repo[/B]: No such file or directory
[root@FD4-PPC etc]#


Maybe this is causing all the trouble?

sayeeth
17th August 2005, 05:12 PM
[root@FD4-PPC etc]# cat /etc/yum.repos.d/livna.repo[/B]
cat: /etc/yum.repos.d/livna.repo[/B]: No such file or directory
[root@FD4-PPC etc]#


Maybe this is causing all the trouble?

Hehe, you made a slight hiccup there. It should only be cat /etc/yum.repos.d/livna.repo . You accidentally copied the [/B]. I put the command in bold only to differentiate them. :)

bitrain
17th August 2005, 05:28 PM
Note that livna and rpmforge (dag, freshrpms, ...) are NOT compatible!!

haymann
17th August 2005, 06:44 PM
Hehe, you made a slight hiccup there. It should only be cat /etc/yum.repos.d/livna.repo . You accidentally copied the [/B]. I put the command in bold only to differentiate them. :)
Ahhh... insert sheepish grin here...

[root@FD4-PPC etc]# cat /etc/yum.repos.d/livna.repo
[livna]
name=Livna.org - Fedora Compatible Packages (stable)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
enabled=1


[livna-testing]
name=Livna.org - Fedora Compatible Packages (testing)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn-testing
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
enabled=0

haymann
17th August 2005, 06:49 PM
Note that livna and rpmforge (dag, freshrpms, ...) are NOT compatible!!
I am actually not sure where this livna stuff came from... I think it might be because I was trying (and still am) to install Video Lan Client. All this work because I was trying to play a DVD!!
I just want a setup that works as far as yum is concerned...

haymann
17th August 2005, 10:17 PM
Follow these instructions and you should be ok.
http://stanton-finley.net/fedora_core_4_installation_notes.html#Yum
Followed the directions and now I get

[root@FD4-PPC etc]# yum update
Setting up Update Process
Setting up repositories
Cannot open/read repomd.xml file for repository: dries
failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.


Is there some way that I can just clean everything out and start over? All I want to do is get a DVD to play...

Finalzone
17th August 2005, 10:25 PM
That means server from dries are down. Try to update again. Alternatively, switch to freshrpms repository.

axel
17th August 2005, 11:10 PM
Open yum.conf with an editor and put enabled=0 to the dries section and enabled=1 to some other freshrpms for example. Save and try again.

haymann
18th August 2005, 12:43 AM
Open yum.conf with an editor and put enabled=0 to the dries section and enabled=1 to some other freshrpms for example. Save and try again.
This is my yum.conf, I don't see how to do what you are suggesting... I am sure I am missing something obvious.
# Note: This file is no longer the entire yum configuration
# for fedorafaq.org. See http://www.fedorafaq.org/#yumconf
# for details on how to set up your system with the new
# yum configuration.

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
# We don't want to gpg-check local, unsigned packages
#gpgcheck=1
# Changed this because some mirrors go down and then
# re-trying takes forever.
retries=1
timeout=10

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

axel
18th August 2005, 12:47 AM
Sorry, i metioned yum.conf because i have in there all my repos info. I assume you should open /etc/yum.repos.d/dries.repo and then change enabled=1 to enabled=0. Play with your repos until you find a working server.

haymann
18th August 2005, 02:10 AM
Sorry, i metioned yum.conf because i have in there all my repos info. I assume you should open /etc/yum.repos.d/dries.repo and then change enabled=1 to enabled=0. Play with your repos until you find a working server.
Ahhh... I couldn't figure out why yum.conf looked so empty, now I get it. Thanks!
I had to disable dag, dries, and livna and now yum seems to be working!!

Thank you all for your help and patience, I feel a little wiser than when I started.

Finalzone
18th August 2005, 02:27 AM
Xine is one of a good DVD player.

haymann
18th August 2005, 03:44 AM
Xine is one of a good DVD player.
Thanks, I'll try that. I was able to install Videolan-client, but the video is very choppy. Probably an easy fix, but it escapes me...

axel
18th August 2005, 09:07 AM
yum install xine xine-lib xine-skins

haymann
22nd August 2005, 12:48 AM
yum install xine xine-lib xine-skins
I tried that, but kept getting a graphic window that would come up and say that the was no mlr. When I would run xine-check I was missing about 4 things and it told me to reload xine-lib. Reloading xine-lib didn't change anything...
I reinstalled VideoLan-client and the video seemed a little better than it was the first time. It was good enough that my 2 year old could watch Sesame Street in the car...

haymann
22nd August 2005, 01:43 AM
yum install xine xine-lib xine-skins
I tried that, but kept getting a graphic window that would come up and say that the was no mlr. When I would run xine-check I was missing about 4 things and it told me to reload xine-lib. Reloading xine-lib didn't change anything...
I reinstalled VideoLan-client and the video seemed a little better than it was the first time. It was good enough that my 2 year old could watch Sesame Street in the car...