View Full Version : Why /dev/dsp disapears upon restart ?

16th August 2005, 10:11 AM
I've a Fedora Core 3 install and 2 sound cards.
Sound-slot 0 is a Via chipset AC97 and sound-slot 1 is a Creative Soundblaster with an Ensonic 1371 chip.
A each restart, udev cleans up the /dev/dsp and /dev/dsp1 device files, preventing Mozilla and others apps to use sound.
How could I have this behavior fixed ?

16th August 2005, 05:35 PM
If udev doesn't create the files, how did you create the /dev/dsp file? Do the devices show up in hal-device-manager?

16th August 2005, 08:08 PM
I do create files using mknod as root.
I do not know how they show in hal, as I do not run hal.
My hardware is totally static, so I wonder why I will ever need udev or HAL.
The previous situation I got using a static /dev was fine to me. (udev and hal did not solve the SCSI disk and cdrom naming problem by the way...)
If you've some clue to turn /dev/dsp* files permanent, I'm your man !

17th August 2005, 06:13 PM
I suppose you could put a script in /etc/rc.d/rc.local that does the mknod. That seems like a kludge, but I don't know how to configure udev to do the mknod. The problem is: if HAL is turned off, what would be notifying udev of the devices?

17th August 2005, 06:57 PM
Maybe /etc/modprobe.conf ?
Or a list of modules loaded...
How does udev do for the DLT I own or the CDRW or the SCSI DVD reader ???? It guess the device files to create ? Or it has a cristall ball buit in to discover the devices and peripherals ? What about the hardware database Kudzu maintains???
If one does some job, I suppose it will do it fully.
Why replace a faulty system (but well known) by a faulty system, more complex and with unknown bugs.
You know, this was the way Microsoft delivered software for years...

17th August 2005, 07:17 PM
I had a similar problem with a device used by my VPN client. The solution was to (once the /dev file was already created) copy it to the /etc/udev/devices directory. Though udev should know about the dsp files, it seems it doesn't for "custom" device files (in my case, this was a new device file required for the VPN client). In any case, after you manually create them, 'cp -p' them to /etc/udev/devices and see if that helps. This is documented somewhere in the udev docs but I'm not at my Linux box at the moment. Hope this helps!