PDA

View Full Version : Installing older radeon drivers?



Hogmeister
12th August 2005, 05:21 PM
ok well i know this sounds insane and quite honestly assinine but i followed the help with

http://www.fedoraforum.org/forum/showthread.php?t=63910&highlight=9800+PRO+SUPER

and it worked great, but as you may notice it installs the latest and greatest drivers ;) i am wanting to install the ati 8.8.25 drivers they have released because i've heard numerous people have had better success with various things with the older ones and the new ati drivers seem to be running kind of sluggish for me.

i got the 8.8.25 rpm package from ati's site, but it doesn't include the kernel module for fglrx and thats what i'm needing help with, is there anywhere that somebody ahs made a kernel module for the older 8.8.25 drivers for the 2.6.12 kernel?

yum -y install kernel-module-fglrx-`(uname -r)`

tried doin that thinkin genius me can sneak through the system (lmfao) but all the does is go "HEY! depencies yada yada" and installs the newest ati fglrx package as well, so its kind of defeating the purpose..

HELPpppppppppp i want to use the 8.8.25 drivers with the newest kernel

Twey
12th August 2005, 05:25 PM
AFAIK., the install er package will build you a kernel module against your running kernel.

Hogmeister
12th August 2005, 05:42 PM
hmmm are you sure? when i uninstalled the newest drivers (lololol you CAN do it IN x then press ctrl+alt+backspace and go bac kt o the login screen but it'll be all dorked up.. thought i screwed something up BAD but then i just reset the comp totally and it was fine) then when back in x i installed the RPM but when i typed fglrxinfo i got the mesa 3d drivers shown up.

any further ideas?

Hogmeister
12th August 2005, 06:57 PM
well i've gotten a LITTLE further..

i've cleared everythign out, uninstalled al lthe rpm's (using yum since its pretty easy to just type fgl and check the ones i want to remove..

so now i have nothing installed...

go into the terminal and type rpm -Uvh --force fglrx_6_8_0-8.8.25-1.i386.rpm (i have to do this because without the --force it gives me a conflict (which i think is the root of the problem to be honest...see below for the error1)) and it starts to install... says as of now i'll only be able to run 2d and go to /lib/modules/fglrx/build_mod and do a ./make.sh ... thats when i get an error saying permission denied on the ./make.sh (any idea why that is?) so i open up the file explorer and right click change the permissions and i'm now able to do a ./make.sh

heres where it gets hairy i now get an error almost imediately after it starts up (its ERROR2 down below). SOoooo i see it says file already exists.. so me liking to mess things up i go and delete it...and to my surprise it gets a little further

on to the next error. well its relaly like one big ass error, its not just one error its a couple in one ;) now that there is no longer that specified file i do a ./make.sh once again to get ERROR3.... and thats as far as i feel comfortable going :) now i know you smart ones are probly laughing so hard right now (because i kind of am as well) since i'm clearly doing something wrong, but i have no idea how to make it work.. please help

ERROR1:

rpm -Uvh fglrx_6_8_0-8.8.25-1.i386.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx_6_8_0-8.8.25-1 conflicts with file from package xorg-x11-Mesa-libGL-6.8.2-37

ERROR2:

patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
ln: `./libfglrx_ip.a.GCC4': File exists
make: *** [libfglrx_ip.a.GCC4] Error 1
build failed with return value 2

ERROR3:

patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.12-1.1398_FC4/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/kernels/2.6.12-1.1398_FC4-i686'
CC [M] /lib/modules/fglrx/build_mod/2.6.x/nvidia-agp.o
/lib/modules/fglrx/build_mod/2.6.x/nvidia-agp.c:57: error: static declaration of ‘__fgl_agp_try_unsupported’ follows non-static declaration
/lib/modules/fglrx/build_mod/2.6.x/agp_backend.h:92: error: previous declaration of ‘__fgl_agp_try_unsupported’ was here
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/nvidia-agp.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.12-1.1398_FC4-i686'
make: *** [kmod_build] Error 2
build failed with return value 2