View Full Version : Boot Loader not loading

11th August 2005, 01:12 PM

I have just installed Fedora Core 4 from downloaded CD-ROM images (check sum ok; media check ok). I selected to install the Boot Loader to the Master Boot Record. At the end of the installation (default desktop variant) a message that the Boot loader is being installed appeared, but when I reboot the system Windows starts up as per usual.

My system has a master single-partition hard disk with Windows XP SE [C:] and a slave with a Windows partition [F:] and the rest (about 40 GB) initially unallocated. After the Fedora installation the unallocated space has been replaced by one (active) partition of 102 MB and a second partition with the remaining 37 GB. My motherboard is a ASUS P4PE. The only BIOS option that seems relevant is "Boot Virus detection", which is disabled.

If I choose "Rescue" when booting from CD-ROM #1, I do get a Shell prompt (but don't yet know what to do next, for example to start the Setup Agent). Actually I wouldn't mind always booting this way, as Windows remains my primary operating system and (for the moment at any rate) I only want to "play" with Linux.

Many thanks for any suggestons.

Peter Davis
The Netherlands.

11th August 2005, 10:18 PM
Did you switch the boot order when you were doing the install and did you set that when you were doing the install? Which drive did you install grub to the MBR of?

If you can change the boot order of your hard drives you can leave XP alone and install grub to the MBR of your second hard drive. When you boot from the rescue CD and it searchs and finds your install, type the "chroot /mnt/sysimage". Then type "cd /boot/grub", this is where your grub files are. Now type "grub" and you will be at the "grub>" prompt

Now type "cat (hd1,1)/grub/grub.conf". This means the second hard drive (numbered 0, 1, 2...) and the second partition.

if you get an error that means that we aren't refering to the proper drive or partition. Try changing the numbers till you find it and let us know the result.

12th August 2005, 12:02 PM
Hello Dave,

Than you for this. I installed the boot loader to "/dev/hda Master Boot Record", and not to "/dev/hdb2 first sector of boot record"; I left the default drive order: first /dev/hda then /dev/hdb. Are you saying that I should have reversed the drive order and installed the boot loader to /dev/hdb?

The structure of my hard disks, as revealed during the instalation is:

LVM Volume Groups
VolGroup00 size=39840
LogVol01 type=swap size=1984
LogVol00 mount=/ type = ext3 size=37856
Hard Drives
/dev/hda1 type=ntfs size=114471 start=1 end=14593
/dev/hdb2 mount=/boot type=ext3 size=102 start=1 end=13
/dev/hdb3 mount=VolGroup00 type=LVM PV size=39896 start=14 end=5099
/dev/hdb1 type=nfts size=36319 start=5100 end=9729

(Since my first message, I have moved the Windows partition to the back of the second disk as I though that Linux might need to be at the front, but that didn't make any difference).

"Cat (hd1,1)/grub/grub.conf" yields the following:

First some "#" lines (comments I assume) then...
title Fedora Core (2.6.11-1.1369_FC4)
root (hd1,1)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb
initrd /initrd-2.6.11-1.1369_FC4.img
title Windows
rootnoverify (hd0,0)
chainloader +1

Other "Cat (hd?,?)/grub/grub.conf" all yield "Error 17"

When I deleted the partitions and did everything again, this was the same, but the value of default is now 0.

A funny thing is, if I rerun the installation CD and select "Update" I get a message "The installer is unable to detect the boot loader currently in use on your system. What would you like to do?". I then select "Create new boot loader". At the end of the "installation" (during which, of course, nothing new is actually installed), after a mesage "Installing bootloader", the following message appears: "No kernel packages were installed on your system. Your boot loader configuration will not be changed".

Thanks in advance for any further light you can shine on this.

13th August 2005, 10:31 AM
Sorry to tak so long getting back to you.

If youwant to use grub only to boot linux and Windows then we need to install grub to the MBR of the /dev/hda or hd0, your first hard drvie.

Warning, you may have difficulties booting windows once the followwing is performed, though with your windows CD you can redo the MBR if needed

Bott with the rescue CD / DVD using the "linux rescue" command and mount your install. chroot /mnt/sysimage. (for more information on grub, at the command prompt type "info grub") Now, "cd /boot/grub" and type "grub". You should now be at the "grub> " prompt again like before.

Since your grub install is on (hd1,0) from what I understand you've said above you want to tell grub where it's root device is installed to:
grub> root (hd1,0)

Now to install grub to the MBR use the command: "setup (hd0)" and issue the "quit" command to get out of grub.

13th August 2005, 01:54 PM
Hello Dave

Thank you one again. It so happens that I intend to reinstall my Windows at the end of next week, so I shall wait until then (when all my backups are 100%) before trying this. I shall report on the result in due course.

Best wishes,

Peter Davis
The Netherlands

13th August 2005, 01:58 PM
...woops pressed the wrong button...

...all my backups are 100%) before trying this. I shall report on the result in due course.

Best wishes,

Peter Davis
The Netherlands

16th August 2005, 08:34 PM
When I tried Dave's suggestion the command

grub> root (hd1,0)

gave the message: "filesystem type unknown, partition type 0x7" (the file type is actually NTFS).

Actually I would be quite happy to just boot via the rescue disk (at this stage I only want to play with Linux now and then). Can I not start the GUI (Gnome?) via this route? I found suggestions that "startx" would do the trick, but this doesn't work.

Best wishes,

Peter Davis
The Netherlands

17th August 2005, 03:29 PM
Since writing my last message I have had a good look at the previous posts here (which I perhaps should have done earlier). I have found and then tried the procedure described at http://www.geocities.com/epark/linux/grub-w2k-HOWTO.html and http://shams2.bravehost.com/page3.html . This worked first time, and in fact I think this should be the procedure of preference for people wanting to make a Windows XP NTFS - Linux dual boot system.

Best wishes,

Peter Davis
The Netherlands