PDA

View Full Version : Problems with sound



Lord Moneky
11th August 2005, 12:54 AM
I have Dell Inspiron XPS Gen1. It is useing the snd-intel8x0 drivers.

When I play sound it only plays out of the head phone jack. Sound will not play from the laptop speakers.

When I installed Transgaming and P2P it does a test of my ALSA this failed. Being new I am not sure what to try first. The sound drivers that are loaded are the only ones I can find that seem to be close to right,

Any ideas??

Gallan
11th August 2005, 02:23 AM
If I remember right you can choose which out put you are using. use alsa mixer to change that to speakers. I'm not sure was it to speakers or mics but I saw that kind of thing in alsa. I hope I remember right...someone can fix if I'm wrong :)

nexusalt
11th August 2005, 12:49 PM
I'm having the exact same problem on an HP nx7010. I've tried fiddling with alsamixer to no avail. Quite irritating. :(

nexusalt
11th August 2005, 01:09 PM
w00t. Got it working. Just mute both the "Headphone Jack Sense" and "Line Jack Sense" sliders under alsamixer or the volume control. I'm assuming it incorrectly detects there are device connected to the headphone and line out jacks. Hopefully that'll solve your problem as well.

aj7360
9th October 2005, 12:47 PM
I was having a similar problem with my XPS Gen2 and finally found the correct control to make the "external" speaker work.

Open the Volume Control (by right clicking the little speaker in the task bar). Go File>Change Device and select the correct device (Intel ICH6 (Alsa Mixer)) Then go to Preferences>Edit and scroll to the bottom and make sure "External Amplifier" is selected. Then back on the Volume Control GUI select the "Switches" tab and make sure "External Amplifier" is selected (which mine wasn't).

Then test the sound again.

Hope this helps someone else.

AJ

aduanero
6th November 2005, 06:24 PM
Thanks aj7360!! It worked!!! :-D

makarand
7th November 2005, 11:48 PM
I am having the same issue
I have FC4 running on a Compaq presario m 2007us laptop

I have external speaker enabled as aj suggested and tested the sound card. The application just hangs and I dont get any sound. is there anything else that i need to check ?