PDA

View Full Version : FC boots into terminal, can't get out, very annoying.



dumbgwailo
5th August 2005, 01:15 PM
Ok, here's the story. I boot up fedora this afternoon and install jre, j2re, limewire, gtk-gnutella and amule. Limewire complains about my firewall so I install firestarter, disable the default firewall and SELinux, reboot, and I'm in a terminal! :eek: (The same sort of terminal you get if you press ctrl+alt+f1.) I don't even get the progress meter telling me that it's doing things like "setting up red hat network support" or anything. I boot up, go through GRUB, get to the place where it says "Initialising hardware... Storage Network Audio Done" or words to that effect, and then my screen goes black for around a minute and I find myself in a terminal asking me to log in.

I can log into the terminal, but then it asks me for commands. How do I get into a nice fuzzy GUI so I can undo all the stuff I did? I'm booted into a live CD now...HELP!

mpolo
5th August 2005, 01:33 PM
Try the command


startx

This should get you back into a GUI. You seem to have somehow ended up in "runlevel" 3 (Terminal), rather than 5 (GUI). Once back into the GUI, you will want to change the runlevel back to 5. I don't remember the exact GUI command for this -- the terminal command "chkconfig" may help you.

jeffk42
5th August 2005, 01:57 PM
If you are in runlevel 3, just open any text editor (as root) and open /etc/inittab. Change default runlevel to 5 and save. After reboot, you should automatically return to the GUI.

Ihsahn
5th August 2005, 02:46 PM
Have a look at /var/log/Xorg.0.log and search for lines beginning with '(EE)' (Error lines...).
It might help you understand the cause of the problem.

dumbgwailo
5th August 2005, 03:23 PM
I tried startx, but all I got was some text going up the screen REALLY quickly and then my black screen again. I left it on for ages, (through dinner,) but no change there. I'll try the other advice as well, thanks!

dumbgwailo
5th August 2005, 04:17 PM
YAY, I fixed it!!! I went to /var/log/Xorg.0.log , and right at the very end it had this "fatal error" thing where it mentioned Xorg.conf, so I opened up my Xorg config, and right at the end under the "screen resolution" bit it had loads of screen resolutions that I don't think my monitor supports and that didn't show up in the "screen resolution" bit of my preferences, so I deleted them. The hardest bit was figuring out how to save the file in runlevel 3...Wow, learned lots about runlevels today!