PDA

View Full Version : YUM Blah



Chas.H
4th August 2005, 12:53 AM
I do not see why everyone says yum this and yum that. From where I sit it is absolutely useless. I've done everything it says in fedoraFaq; I have the latest yum.conf from 25 July and 15 repos in /etc/yum.repos.d/

Every single yum attempt fails 100% of the time!

After 243 posts this is the first time I've used the anger emoticon.

I'm now trying to install MP3 support for amarok. I tried:

yum install gstreamer-plugins-mp3
and

yum install kdemultimedia-extras

This is what I get each time:

Setting up Install Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 64 kB 00:34
Error: failure: repodata/primary.xml.gz from livna: [Errno 256] No more mirrors to try.

From fc2 to fc4 in the last year I have never had a successful install using yum, not one.

XMMS plays mp3 files but quits after the first song in a playlist.

What gives?

As if that weren't enough, I just got stung by a wasp.

Chas.H
4th August 2005, 01:57 AM
Is it because yum hates dial-up?
Where I live I have no reasonable choice.

shams
4th August 2005, 02:06 AM
plz try whato you read about yum here (http://shams2.bravehost.com/faq.html), my be this work.

Chas.H
4th August 2005, 02:32 PM
shams,
Your link lead me to this thread (http://forums.fedoraforum.org/forum/showthread.php?t=59904).
After reading it over I think I will give it a try when I get home to my FC4 box. I will let you know what success I have.

sailor
4th August 2005, 02:41 PM
Look over the yum fix on the fedorafaq
http://www.fedorafaq.org/#installsoftware

Gallan
4th August 2005, 03:09 PM
your are not alone! I had fc4 installed and I was using yum but there was always something wrong and depencies problems were one thing...I didn't mix repos livna and fresh ;) I tried to use yumex but it was slow, crapy and it was hanging and crashing very often...so I moved back to fc3 and synaptic and I have to say now it is easy and fast to update and install packages. and those who are saying that yum is beeting apt I don't understand!!! but this is what I think but if you have some reason to use fc4 so use it but I noticed that it was slower than fc3.

I hope you get it working!!!!

Chas.H
4th August 2005, 10:01 PM
Look over the yum fix on the fedorafaq
http://www.fedorafaq.org/#installsoftware

Hey sailor,
Long time no hear from... *new* old saying

I tried exactly what you suggest as shown in this thread (http://www.fedoraforum.org/forum/showthread.php?t=66746) and I had no luck.

I got around that problem by downloading the RPMs and dealing with dependencies as they turned up, once I learnt how. ;) But because of the fact that the RPM I need to get MP3s to play in amaroK is not in Extras, I need to find it elseware which should be where yum comes in, but the bloody thing doesn't work for me. Hence my quandry.

:rolleyes: Also, I like to know where things are coming from which seems not to be the case even if my yum were working properly.

kvorion
5th August 2005, 08:31 AM
one real novice question.......wen u want to install some package.......then can u use yum to install it if u already have the necessary rpms on ur comp? or is it necessary that yum has to download everything from the repos and then only install them?

suppose that I have downloaded the necessary packages but there are many dependencies existing....so can I use yum to resolve them?

Chas.H
5th August 2005, 02:18 PM
Good question.
I wish I could at least have enough success with yum to run an experiment.

mpolo
5th August 2005, 02:33 PM
Your results with yum are basically what I have had since mid-FC3. It worked just fine in FC2 and "out of the box" in FC3, but now I can't get it to work for anything. I think my problem is connected with a proxy that I am using. I don't think I've yet seen a python program that properly handles my proxy. The mirror files are out of the question, because they simply fail, and the direct addresses act like they want to work, and then fail on me as well.

My solution was to switch to apt-get, which we are told is deprecated, but I don't see much other option. You might look into it... The repository ayo.freshrpms.net mirrors core updates and extras in an apt-friendly fashion.

foolish
6th August 2005, 11:54 AM
Post your yum.conf and the livna.org repo configuration file please.

Alerander
6th August 2005, 01:21 PM
Hi,all
I have never tried to install something by yum, somehow it give me a sense of astaticism.

blackant
6th August 2005, 02:40 PM
I am trying to install gnomebaker but couldn't do it. :(

I followed some instructions here, download the latest rpm from nrpms.net.
The file is gnomebaker-0.4-1.1.fc4.nr.src.rpm

Then I use rpm ivh, and followed by yum install gnomebaker.
It just show 'No Match for argument: gnomebaker'

Anyone can help me?

Chas.H
6th August 2005, 04:51 PM
Post your yum.conf and the livna.org repo configuration file please.

Thanks, foolish. My modem stopped working last night so, I will need to put those files on a flash key and take them to work to post them. Then I'll have to fix or replace my modem. :rolleyes:

I'll do it as quickly as I can. I hope you see something I don't see.

By the way, have you seen the solution posted by tejas in this thread (http://forums.fedoraforum.org/forum/showthread.php?t=59904)? I was wondering what you thought of it and whether it is worth a try.

Many thanks.

Chas.H
6th August 2005, 07:26 PM
foolish.

Here are the files you want to see...

Many Thanks