PDA

View Full Version : First linux install ever



blueflowers
3rd August 2005, 10:00 PM
Hello. This is my first time away from windows :eek: And I am very new at this. I have installed the 64 bit version of fedora on my 64 bit amd system. My first question is, and I know its very "noobish", how do I install something from a CD. When I try to do this, from root or from my regular account, it gives me an error. Thank you

dxturner
3rd August 2005, 10:02 PM
What are you trying to install?

blueflowers
3rd August 2005, 10:03 PM
Return to castle wolfenstein and battlefield 2 for now.

dxturner
3rd August 2005, 10:15 PM
What is the error(s)?

What specifically are you doing when you try to install?

This is Linux software, right?

blueflowers
3rd August 2005, 10:23 PM
"Couldn't display "/media/cdrecorder/Setup.exe"."

That is the error I get. It is both windows and linux. I am opening the cd and then trying to run setup.exe

dxturner
3rd August 2005, 10:44 PM
open a terminal window (Applications -> System Tools -> Terminal)
if the CD is in the drive, at the prompt do:

cd /media/cdrecorder
file Setup.exe
(post the output to the forum)
ls -l
(post the output to the forum)

Setup.exe is generally a windows executable, and you won't be able to run it unless you have some windows emulation ( wine, crossover). You say it is windows & linux ... if so, there should be some sort of README or other instruction on how to install in Linux.

have you looked at: http://zerowing.idsoftware.com/linux/wolf/INSTALL ???

blueflowers
3rd August 2005, 10:54 PM
bash: cd/media/cdrecorder: No such file or directory
[root@localhost ~]# cd /media/cdrecorder
[root@localhost cdrecorder]# file Setup.exe
Setup.exe: MS-DOS executable (EXE), OS/2 or MS Windows
[root@localhost cdrecorder]# ls -l
total 1956
-r-xr-xr-x 1 root root 146 Apr 9 2002 autorun.inf
dr-xr-xr-x 1 root root 2048 Jun 2 2002 Bonus
dr-xr-xr-x 1 root root 2048 Jun 2 2002 DirectX
dr-xr-xr-x 1 root root 2048 Jun 2 2002 Docs
dr-xr-xr-x 1 root root 2048 Jun 2 2002 Extra
-r-xr-xr-x 1 root root 135168 Oct 17 2001 KeyCheckDLL.dll
-r-xr-xr-x 1 root root 313 Nov 5 2001 KeyCheck.txt
-r-xr-xr-x 1 root root 77824 Aug 24 2000 Launch.exe
-r-xr-xr-x 1 root root 381 Apr 9 2002 Launch.ini
dr-xr-xr-x 1 root root 2048 Jun 2 2002 Setup
-r-xr-xr-x 1 root root 1777481 Jun 2 2002 Setup.exe
[root@localhost cdrecorder]#
[root@localhost cdrecorder]#


I have not read that, I do not know how to install the flash plugin for mozilla. Like I said, I am very new at this. All I have really done so far is installed fedora and then set it up, got in, and used gaim and mozilla.

sueltraz
3rd August 2005, 10:56 PM
.exe's will not run on Linux natively...those are windows/DOS executables (unless someone were to compile an binary for Linux and for some reason, lable it an exe). As for RTCW, here's the instructions for getting it running on linux:http://zerowing.idsoftware.com/linux/wolf/

Any of the games that id ports to Linux, usually has pretty good documentation provided by id at the same site: http://zerowing.idsoftware.com/

id is generally pretty good with their ports in that they provide instructions and if you own the Windows version, all you have to do is download and install the actual game binary which they provide on the site I listed above.

blueflowers
3rd August 2005, 11:05 PM
I appreciate all the help. This will sound dumb, but how do I copy the files over that it is telling me to copy?

markkuk
3rd August 2005, 11:11 PM
Drag and drop the files in the file manager or use the "cp" command from the command line.
http://tldp.org/LDP/intro-linux/html/sect_03_03.html

blueflowers
3rd August 2005, 11:14 PM
So, If I understand this right, all I do is drag and drop stuff from the cd, to a location on my hard drive. Then it is installed? I do not have to go through a installer like I did with Windows?

markkuk
3rd August 2005, 11:18 PM
No, after copying the .pk3 files you must run the Linux installer program (the file with the .x86.run suffix).

blueflowers
3rd August 2005, 11:23 PM
Thank you. I have copied the files, and I am downloading the .run. Another question, How do I install the flash plugin for mozilla? It says it can not find it when I try to do it in Mozilla.

blueflowers
3rd August 2005, 11:27 PM
"gedit was not able to automatically detect the character coding. Please, check that you are not trying to open a binary file and try again selecting a character coding in the 'Open File...' (or 'Open Location') dialog"

I tried running it from the desktop. What does this mean?

blueflowers
3rd August 2005, 11:51 PM
I tried typing exec'ing the file name in terminal. It did some stuff real fast then closed terminal, So I dont know what it did. But, Its not installed yet. Did I run this the wrong way?

blueflowers
4th August 2005, 01:41 AM
Got it working woohoo! thanks all for help

sueltraz
10th August 2005, 09:23 PM
EDIT: You know, I honestly didn't see the second page so...nevermind...