View Full Version : vsftpd log file unreadable

1st August 2005, 02:08 PM
ok, here's my problem. I configured vsftpd.conf, added all user I needed with appropriate quotas, chkconfig vsftpd so that it would start at boot, everything was fine. Tested it with at least two users ... downloaded, uploaded some test files ... :)

then I rebooted, ran service --status-all, saw vsftpd was running ... but when I tried to connect it failed. Managed to find the problem after an hour or so of googling and file browsing ... seems like vsftpd is unable to read the log file: :mad:
500 OOPS: failed to open xferlog log file:/var/log/xferlog
Then I did :
chmod 644 /var/log/xferlog
just in case. Then I noticed a file /var/log/xferlog.1 which had logged my test session quite well ...

Anyone ever got this problem. My vsftpd is working but I had to comment the line #xferlog_file=/var/log/vsftpd.log
in the vsftpd.conf file. I can't have my ftp deamon not logging the uploads/downloads ... :(


1st August 2005, 02:34 PM
ok, it's worse than I imagined ... I can acces it locally (got tired of connecting from another PC ;) )

but I'm sure it worked at least once. The log file prove it and I have the test files on the users accounts.

when I run vsftpd here's what I get :
500 OOPS: could not bind listening IPv4 socket

I was very proud when I got it working, but I am now clueless ...

I'll also post my vsftpd.conf file, because I guess that's about the only thing that could help you.
I've made many changes but here it is :
# Example config file /etc/vsftpd/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
# You may fully customise the login banner string:
#ftpd_banner=pas de banner pour le moment !!!
#You may specify a file of disallowed anonymous e-mail addresses. Apparently
#useful for combatting certain DoS attacks.
#(default follows)
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.

#enable for standalone mode

11th August 2005, 09:51 PM
OK, this is my first attempt helping anybody here at fedoraforum.org :)

I had the same problem recently, I also got the message:
500 OOPS: failed to open xferlog log file:/var/log/xferlog

This is what I did:

Open a terminal
Switch to root using su -
service vsftpd stop
Wait for the message: Shutting down vsftpd: [ OK ]
After this I removed the log file
rm /var/log/vsftpd.log
Type "y" for the question: rm: remove regular file `/var/log/vsftpd.log'?
service vsftpd start

After I did this everything worked OK.
vsftpd created a new log file in /var/log/ and it logged every upload/download.
I hope this have helped you.

8th September 2005, 05:14 PM

I also had this problem. FIrst I tried 'touch'ing the log file /var/ftp/vsftpd.log since it wasn't created yet, but that didn't make any difference.
And another thing I was wondering about: Why does it complain about the file /var/log/xferlog, when the default log file is /var/log/vsftpd.log ?

Anyway, it seems like is was a SELinux related problem, because after I ran system-config-securitylevel and temporarily disabled SELinux protection of ftp deamons the problem went away.

Sour Kraut
8th September 2005, 11:22 PM
I thought the default log path was /var/log/xferlog ?

How do you turn off SELinux protection of vsftpd from BASH? I dont have that option. Is that because I selected to disable SELinux at install?


11th September 2005, 02:40 AM
Maybe I'm misinterpreting the comment in the config file, but I assumed that /var/log/vsftpd.log is the default path for logging since this line appears in the default vsftpd config file (/etc/vsftpd/vsftpd.conf):

# You may override where the log file goes if you like. The default is shown
# below.

As a sidenote: I see that the log appears in the file /var/log/xferlog as Sour Kraut points out, but there is no information about that in the config file. Why? :)

So far I haven't done system-config-securitylevel in text-mode (it pops up in GUI when I execute it in a windowed shell obviously), so I don't know how to enable/disable it in BASH. But if you are sure you didn't enable SELinux at all at install I guess SELinux is not the problem in your case :)

Some (obvious maybe?) things to check:
- does the command "ls -Z /var/log/xferlog" output something like (with the colon-separated stuff in the middle as the interesting part):
-rw------- root root system_u:object_r:xferlog_t /var/log/xferlog

- What user are you running vsftpd under
- Did you check the file permissions for /var/log/xferlog