PDA

View Full Version : Error, version `GLIBC_2.3.3' not found



andersgd
30th July 2005, 09:27 AM
Hi,

I compiled the latest CVS snapshot of Licq yesterday. When I try to start the app I get the error message /usr/local/licq-20050730/bin/licq: /lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /usr/local/licq-20050730/bin/licq)

I also noticed that when I try to start Open Office I get the same type of error messages:
/usr/lib/openoffice.org2.0/program/javaldx: /lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /usr/lib/openoffice.org2.0/program/libuno_sal.so.3)
/usr/lib/openoffice.org2.0/program/soffice.bin: /lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /usr/lib/openoffice.org2.0/program/libuno_sal.so.3)

I've got the following RPM's installed:

$ rpm -qa |grep -i openoffice
openoffice.org-calc-1.9.117-3.1.0.fc4
openoffice.org-core-1.9.117-3.1.0.fc4
openoffice.org-draw-1.9.117-3.1.0.fc4
openoffice.org-writer-1.9.117-3.1.0.fc4
openoffice.org-langpack-sv-1.9.117-3.1.0.fc4
openoffice.org-math-1.9.117-3.1.0.fc4
openoffice.org-impress-1.9.117-3.1.0.fc4
$ rpm -qa |grep -i glib
glibc-devel-2.3.5-10
taglib-1.3.1-2
glibc-common-2.3.5-10
dbus-glib-0.33-3
glib-devel-1.2.10-16
glib2-2.6.4-1
glibc-kernheaders-2.4-9.1.94
glibc-headers-2.3.5-10
glib-1.2.10-16
glibc-2.3.5-10
glib2-devel-2.6.4-1

Anyone got an idea how to solve it?

Thanks
/Anders

andersgd
31st July 2005, 10:25 PM
It's solved.
I found out that I for some (old) reason had LD_ASSUME_KERNEL=2.2.5 set in the environment. Removing it removed the problem.

/Anders