View Full Version : changed CD drive, now FC hangs loading Gnome desktop

29th December 2003, 03:55 PM
I have a machine with FC1 which has been working fine. I decided to replace the CD-ROM drive with a CD-R/W drive today, and now I can't get into the Gnome desktop. I get the normal FC login window, I enter my login and password, then FC hangs when it gets to the point it is loading the CD Device Handler. It requires a hard reset or power off, even the mouse pointer is frozen. CTRL+ALT+backspace has no effect. It appears it is not just X which is hung, but the entire machine.

I can get in using a KDE session or the failsafe console, but not Gnome.

Edit: At least I got in using KDE once. The second time it also locked up like Gnome.

I have all updates installed, as of yesterday night, including the latest kernel. The machine has a full install of FC1 (everything). Here is the hardware:

AOpen AX34-U motherboard (VIA 694T chipset)
30GB Maxtor, primary/master
HP CD-Writer 8200+ secondary/master (replaced Lite-On 52x CD-ROM)
3.5 floppy
ATi Radeon 8500 64MB (ATi 3.2.8 driver)
Ensonic ES-1371 AudioPCI soundcard
3Com 3C905B-TX nic

The HP burner has previously been used under every major RH version starting with 6.2, with no problems. I am sure it's not a hardware problem, but rather a configuration in FC1 which does not like the previous CD drive replaced with this CD-RW drive.

The machine has been rock-solid stable since installing FC1 a few weeks ago, including occasionally leaving it running for a few days. I haven't yet tried to put the original CD-ROM drive back in the system.

How can I fix this?

10th January 2004, 06:44 AM
You'll want to look around in /var/log/messages -- somewhere in there will be some errors from your hardware, probably near the bottom. You can use the failsafe terminal as root to read it.


28th January 2004, 09:21 PM
Hmmm... finally got around to cheking the messages log. No help there. The drive seems to be detected properly (shows proper id string), and no errors that I can see related to the drive itself or IDE in general.

I figured something was just pooched in the OS, so I will just re-install (clean, no important data on this box yet). So I boot from the CD, and it hangs running /sbin/loader off the HP CD-RW drive. Tried warm boot, cold boot, disconnect and reconnect drive cables, still hangs in the same place booting from the CD. So, I put the original CD-ROM drive back in, removed the HP CD-RW. Everything works. Now, I try putting the HP drive in as secondary slave (same channel as CD-ROM). Back to the same, hangs at login at the CD device handler icon.

Not sure if it's a pure compat problem between Fedora and this partular drive, or if something has just gone bad in the drive since last time I used it. It was used most recently in a RH 9.0 system, where it was fine. I'll have to drop the drive in another box and check it with another OS to see if it's hardware.

1st February 2004, 05:23 AM
Try booting with the nodma argument.

18th May 2004, 06:18 PM

I am having the same problem

has anyone found a remedy?

I've tried the "nodma" argument and this doesn't seem to work


edit: upon further investigation it appears to be an usb 2.0 issue

when disabled it continues as it should