PDA

View Full Version : Running... Mostly


ndcent
9th July 2005, 04:54 AM
I'm not new to Linux in general, but I never put it on my iBook (933 MHz G4, 640 MB, 60 GB, AirPort Extreme) before. Now, with the release of FC4 PPC, I decided it was time. So I repartitioned, and installed... and it MOSTLY works.

Here are the remaining problems I'm having. Please help with any of them you can.

1) Can't get 2nd and 3rd mouse button emulation to work. /proc/sys/dev/mac_hid/mouse_button_emulation is one (as per `cat`) and /proc/sys/dev/mac_hid/mouse_button2_keycode is set correctly, but it just won't work. I'd also like to dissable 'taps' because I'm going crazy.

2) When I boot, I get a message saying something to the order of Signatures don't match, refering to my graphics card. It will only go past that point if I am on AC Power. Once Gnome is up and running, I can unplug, but not until then.

3) My time is REALLY FUBAR. As of this writing (actual time around 10:40 pm) it says it is 3:37 am. The date is correct (if it's not I'm going to feel really stupid), but the time is wrong. The time also seems to be running slowly, but I haven't timed it exactly.

4) When I click on the Email button (I use Thunderbird as my default email client) it shows a "Starting Email" bar and then it closes with no Thunderbird. It does the same if I go to it directly ("Applications->Internet->Thunderbird Email').

Those are the "basic' problems I've been having. Now for the challenge ones. These will be worth bonus points which can be redemed with the god of your choice once you are dead. Actually, I'm not authorized to make those promises, but you never know...

5) I am fortunate enough to have an extra 17" LCD monitor laying around. So I decided to hook it up to the external connector on my iBook. I then configured my desktop to be tiled to it and it MOSTLY works. The problem is that the collor is REALLY distorted on both my laptop display and the LCD. It is mostly yellow and behaves as though the cable is loose, but only on parts of the screen that are active. I the screens are all good. It seems as though the Red channel is being erased in the video memory. Being that OS X only supports cloning on my model iBook, is it possible that the hardware is simply incompatable with this or is it possible just a driver issue. (Graphics card is detected properly as "ATI Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)]" in the Hardware Browser.

6) While running with my other display attached, I am experiencing minor other problems, such as my battery meter won't stay running. I also can't see any of my active windows in the task bar on the second display.


Thanks,

Neal

jonest
9th July 2005, 08:16 AM
3. You may want to check your timezones and the whole GMT thing.

I have the same model as you (933) and I have not been having the problems you have been experiencing. I've tried yellowdog, FC3, gentoo, and debian. I had nagging problems like you have been. I've been running Ubuntu 5.0.4 for a couple days and it appears to be working okay, but I haven't tried all functions at this point, but number 2, 3, and 5 are not problems. I don't use Thunderbird, but can give it a try. I haven't tried to get the mouse emulation going yet.

websavages
9th July 2005, 09:18 AM
the date is an issue i had to deal with aswel, this is how i solved it

1. set the date using the date command
2. ensure UTC is set to false and your time zone is correct in /etc/sysconfig/clock
3. sync the system clock with the hardware clock hwclock --systohc
4. install ntpd and let that keep the time in check (my clock is on average just under three seconds out) n.b. ensure that you use the burst and iburst options for the ntp servers

Cheers ws

p.s. time for a beer i think!

ndcent
9th July 2005, 08:27 PM
So you've had dual displays working properly? I must now hunt you down and steal your notebook... :)