PDA

View Full Version : wxPythonGTK.rpm ????



dreamminder
13th December 2003, 01:22 AM
[This post has been edited and replaced by a moderator because it was inflammatory. The content is basically still the same.]

I can't find wxPythonGTK as an RPM. Any help?

decker
13th December 2003, 08:13 PM
[Flame replaced by basic content.]

STFW (http://www.acronymfinder.com/af-query.asp?String=exact&Acronym=STFW&Find=Find)

decker
13th December 2003, 09:26 PM
[Flame edited by moderator.]

The first link that comes up when you search for wxpython is the wxpython site. Click on that, click on downloads, save the rpm. What's the problem?

Alternative you could bother to spend 5 seconds to actually read the nice little faq that they've put on this site. That way you'd have yum set up, and you could just type yum install bittorrent.

But you'll probably just complain again that I didn't give you the exact link...

Avatraxiom
23rd December 2003, 07:23 AM
I would suggest that you read the FAQ, and then do "yum install bittorrent." Also, look for either "wxGTK" or "wxGTK2." I understand that it's hard to figure out how to get wxPython to work on Fedora -- it took me a while to do it. :-)

-M

xaero
28th December 2003, 09:16 PM
Yeah. Don't be stupid :o

Turambar
30th December 2003, 10:54 AM
OK - for the sake of providing something useful in this thread, I'll bite.

Update:
I found the FAQ mentioned earlier, but it's neither of the FAQ links you see on this page. Weird. If you look here: http://fedora.artoo.net/faq/, then you'll get to the real FAQ. On that page, you'll find a link to a new yum.conf which contains several new sources for packages. BitTorrent is on one of these.

I guess the earliest comments weren't trolls. They were just cleverly disguised as trolls due to the lack of meaningful information.

Here's where you get wxPythonGTK-py2.2-2.4.2.4-1.i386.rpm: http://wxpython.org/download.php#binaries. Installation is easy.

The page for downloading BitTorrent is http://bitconjurer.org/BitTorrent/download.html, where they suggest you look at RPMfind.net for actual RPMs (http://rpmfind.net/linux/rpm2html/search.php?query=BitTorrent). Following the link gives some non-redhat choices, but I haven't tried them. Instead, I tried the helpfull yum install bittorrent suggestions. Here is what I saw:

[code:1][root@host rpms]# yum install bittorrent
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Server: Fedora Core 1 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Cannot find a package matching bittorrent
No actions to take
[/code:1]

My machine is a clean Fedora Core 1 install, instead of an upgraded RHx system. For those who got yum install bittorrent to work, are you on a clean install or an upgrade? Any suggestions on how to teach yum about this package? And no, yum --help. man yum, and info yum were not helpful. And no, uncommenting the updates-testing sections of /etc/sysconfig/rhn/sources and /etc/yum.conf didn't help either.

After a bit more Googling, I found this link: http://torrent.dulug.duke.edu/, which contains an RPM meant for Fedora. It installs nicely.

I know I'm joining late and that the flaming text has already been moderated, but I think more help and less flamage would be better for these forums. If anyone cares. :|

-Turambar

zjimward
17th May 2004, 06:28 PM
I noticed no one suggested using www.fedora.us and then adding the proper data to the apt or yum configuration files.