PDA

View Full Version : Amule fc4, anyone got it working?



Saint Mike
5th July 2005, 02:49 PM
Hey

Iv read around the forum but still cant get anything working. I used Yum which installed the follwoing


amule i386 2.0.1-1.2.fc4 freshrpms 2.2 M
wxGTK2 i386 2.4.2-12 extras 1.5 M

When i run it though i get the following error


FATAL ERROR! You have attempted to use a version of wxGTK older than
the 2.5.1 release, compiled against GTK2! This combination is not
supported by aMule due to many known problems. If you wish to use
wxGTK compiled against GTK2, please upgrade to a more recent version
of wxGTK.

More information can be found at:
- http://www.amule.org
- http://wiki.amule.org

Current version is: aMule 2.0.1 using wxGTK2 v2.4.2


I dont need to get it working with GTK2 and make it lookall pretty, i just want something to work.

Anyone know how i can get it to run on FC4, im still rather new to this and would greatly appreciate any help.

Kind regards

ulasergin
5th July 2005, 08:05 PM
I don't whether this is your problem but http://stanton-finley.net/fedora_core_4_installation_notes.html
says mixing freshrpms and extras can cause problems

Saint Mike
6th July 2005, 06:06 AM
Yup thanks ulasergin that was the problem i was wrong :)

Thanks smfinley for the detailed solution

smfinley
6th July 2005, 06:44 AM
Get dries and extras configured in your /etc/yum.repos.d/ per Fedora Core 4 Installation Notes (http://stanton-finley.net/fedora_core_4_installation_notes.html) and then do a "yum install amule" as root. You will see:

Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package amule.i386 0:2.0.1-1.2.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libwx_gtk2-2.4.so.0(WXGTK2_2.4) for package: amule
--> Processing Dependency: libwx_gtk2-2.4.so.0 for package: amule
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package wxGTK2.i386 0:2.4.2-12 set to be updated
--> Running transaction check
--> Processing Dependency: wxGTK-common = 2.4.2-12 for package: wxGTK2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package wxGTK-common.i386 0:2.4.2-12 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
amule i386 2.0.1-1.2.fc4.rf dries 2.2 M
Installing for dependencies:
wxGTK-common i386 2.4.2-12 extras 515 k
wxGTK2 i386 2.4.2-12 extras 1.5 M

Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 4.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): wxGTK-common-2.4.2 100% |=========================| 515 kB 00:00
(2/3): amule-2.0.1-1.2.fc 100% |=========================| 2.2 MB 00:04
(3/3): wxGTK2-2.4.2-12.i3 100% |=========================| 1.5 MB 00:02
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: wxGTK-common ######################### [1/3]
Installing: wxGTK2 ######################### [2/3]
Installing: amule ######################### [3/3]

Installed: amule.i386 0:2.0.1-1.2.fc4.rf
Dependency Installed: wxGTK-common.i386 0:2.4.2-12 wxGTK2.i386 0:2.4.2-12
Complete!

locke
11th July 2005, 10:11 AM
Ok ... I am really sorry but this is confusing the heck out of me ...

I disabled the extra repos and I am still can't get amule to work ... continues to say that it needs wxGTK2 2.6 not 2.4 ... anyone have any ideas for a newbie like me?

imdeemvp
11th July 2005, 10:53 AM
I personally think amule is really slow I prefer the alternatives. (http://www.fedoraforum.org/forum/showthread.php?t=30867)