PDA

View Full Version : AC97 detected but no sound



MarkAshley
5th July 2005, 07:23 AM
Hi guys and gals

I've checked google and the fed forums but I can't find a solution to my problem. My sound card is detected as the following:


00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller

Everything is turned up in both Volume Control and also alsamixer, but I just can't hear anything. Not sure if this is relevant but here's my modprobe.conf:


alias eth0 8139too
alias snd-card-0 snd-atiixp
options snd-card-0 index=0
options snd-atiixp index=0
remove snd-atiixp { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-atiixp
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
alias ath0 ath_pci

Hope somebody can help. Once I get this and ACPI working my Fedora setup is complete :D

Thanks
Mark

psb154
5th July 2005, 08:17 AM
MarkAshley

When I have had audio problems this normally fixes it:
- Go to: http://www.alsa-project.org/alsa-doc/
- go to the bottom of this page.
- choose your manufacturer.
- download the drivers and follow the documentation.

bitrain
5th July 2005, 09:03 AM
Sometimes you have to enable or disable some switches in kmix, it's on the 3th tab.

MarkAshley
5th July 2005, 07:57 PM
MarkAshley

When I have had audio problems this normally fixes it:
- Go to: http://www.alsa-project.org/alsa-doc/
- go to the bottom of this page.
- choose your manufacturer.
- download the drivers and follow the documentation.
Thanks for that. I followed the instructions to the letter but I still can't hear anthing :(

MarkAshley
5th July 2005, 07:58 PM
Sometimes you have to enable or disable some switches in kmix, it's on the 3th tab.
I don't have kmix installed. In fact, I don't have an of KDE installed. Is there anywhere else I can adjust these switches?

proffit
5th July 2005, 08:04 PM
when my soundcard installed I had to turn on the external amplifier settings, I am not sure why that was but once I did (just used the sound applet in gnome) it worked fine.

proffit
5th July 2005, 08:08 PM
in gnome just double click the speaker icon in upper right hand corner, go to preferences and then click on external amplifier, then make sure that it is turned on.

92b16vx
5th July 2005, 09:25 PM
try

alsamixer
That should bring up Alsa, make sure everything is enabled (no muted). Use the arrow keys to select what you want to go to, then M to unmute.

MarkAshley
6th July 2005, 07:04 AM
in gnome just double click the speaker icon in upper right hand corner, go to preferences and then click on external amplifier, then make sure that it is turned on.
Hey thanks profitt, it's working now :)

Cheers
Mark