View Full Version : Why is it that

2nd July 2005, 05:54 PM
Ever time I reboot my comuter, my sound goes away? I have to go into alsamixer and turn it back up, or redect it. What can I do to keep this annoyance at bay?

2nd July 2005, 05:58 PM
i have to do the same thing, and its been like that as far as i can remember even from the first time i installed Fedora back in the FC1 days. I just add the sound mixer applet to my KDE taskbar and turn it back up after i reboot which is pretty rare anyway. but a solution would be nice if anyone has one :)

2nd July 2005, 06:30 PM
Ok, I'm glad it isn't just something that is just me :)

Only thing that sucks is that I have to "system restore" Windows to because the driver doesn't get recognized when I boot into it anymore.

ben s
2nd July 2005, 08:23 PM
I wrote a wrapper script for alsamixer (actually, gnome-alsamixer) to save the settings for me:

/usr/sbin/alsactl restore
/usr/sbin/alsactl store

...you have to chmod +s /usr/bin/alsactl (as root) before this will work from your user account. All it does is pull in the saved settings, run the mixer, then store the settings when you quit the mixer. This is supposed to happen automatically when you shutdown (see /etc/modprobe.conf) but it doesn't appear to do so in some cases.

BTW, Gnome-mixer isn't included with FC*, I had to compile it myself.

2nd July 2005, 09:00 PM
What I noticed it has happened to people using nvidia drives and nforce sound and if you do your updates via yum using also atrpms repo.

Nice little script I wish I knew it before I had to reinstall....