PDA

View Full Version : Installing FC4 on an ibook2 g3



e_e
2nd July 2005, 03:57 PM
I own a 2 1/2 year old ibook with 800 mhz and a radeon 7500....

when i heard of the ppc port of fedora core 4 i downloaded the first three isos and made a first try!

i got into yaboot, pressed enter.... everything worked... but when it came to the media check graphic problems occured...

the screen was split horizontaly in the middle by a strange line and text was only printed in a box in the left top corner.... this box was mirrored to the bottom left corner....

by pressing enter i finally got into anaconda, which had the same display problems...
it's not possible to install fedora this way...


i tried the yaboot parameters "linux resolution=1024x768" and "linux vsync=60" but none of them worked...

:(

anybody heard about this problem? i really want linux on my mac...

ty

theholynig
2nd July 2005, 04:02 PM
Sounds like you need to do a text install and then run from the console and edit your xorg.config file.

e_e
2nd July 2005, 04:20 PM
who can i do a text install...?

SlowJet
2nd July 2005, 07:12 PM
My flat screnn Envision 7100 is still doing that on boot up.
It ran ok for a while and started in late FC3, some in FC4T3, corrected and started again in FC5 dev testing.
Now with a new install of FC4, it has started again.
I have set the frequencies to the exact MGF specs and the screen size, both were off a bit after the install.
(The vert refressh was 83 during install but s/b 80
screen dimentions were off on width )

But all that I have tried doesn't stop it, it either goes away after an update or it doen't.

Currently, I log into root first, then log out, the second login to user, straightens it out?

It has caused no system problem and is only a display proble.
I have a Nvidia mx 2 with default driver FC4 driver.
SJ

JLF_65
3rd July 2005, 09:45 PM
who can i do a text install...?

At the first prompt, type "linux text". You might try "linux nofb resolution=1024x768" first. I have to do that on my laptop (not a Mac, but similar problem).