PDA

View Full Version : Can't install Intel 536ep pci modem on FC4, but FC2 can



jasonfireup
30th June 2005, 04:04 AM
Please help me ..I had already installed FC4 , I happen install problem about intel modem driver ,
My Hardware configure :
P4 Cereron 2.4GHz
512MB DDR 333 RAM
Intel 845 Main board
built in VGA , LAN
Intel 536ep internal PCI modem

I download intel modem driver for linux at intel web site, I can install and use successfully when using Fedora core 2 linux , but I format my pc and , then install New Fedora Core 4 , I can't install it , and happen problem at the install step "make 536" , I show the error output as the following ..

---------------------------------------------------------------------------------
Module precompile check
Current running kernel is: 2.6.11-1.1369_FC4
/lib/modules... autoconf.h exists
autoconf.h matches running kernel
version.h matches running kernel
uname -r|grep "2.6" && \
cd coredrv && make 536core_26 && \
cp Intel536.ko .. && cd .. && \
strip --strip-debug Intel536.ko && \
exit; \
ls Intel536.ko >/dev/null 2>&1 || uname -r | grep "2.6" && echo "Failed to build driver" && exit; \
if [ ]; then \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_SOURCE_PATH= "PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
else \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_INCLUDES=/lib/modules/`uname -r`/build/include \
"PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
fi ; \
cp Intel536.o .. ; \
if [ -a /boot/vmlinuz.version.h ]; then \
cp /boot/vmlinuz.version.h /lib/modules/`uname -r`/build/include/linux/version.h;\
fi
2.6.11-1.1369_FC4
make[1]: Entering directory `/usr/local/src/intel-536EP-2.56.76.0/coredrv'
make -C /lib/modules/2.6.11-1.1369_FC4/build SUBDIRS=/usr/local/src/intel-536EP-2.56.76.0/coredrv modules
make[2]: Entering directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
CC [M] /usr/local/src/intel-536EP-2.56.76.0/coredrv/coredrv.o
make[2]: Leaving directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
make[1]: Leaving directory `/usr/local/src/intel-536EP-2.56.76.0/coredrv'
2.6.11-1.1369_FC4
Failed to build driver
---------------------------------------------------------------------------------
Please help me , how to install this driver ?

hlfmanhlfamzng
30th June 2005, 04:15 AM
These drivers are picky from what I've seen.

What driver version are you using from intel's website?(only 4.69 supports 2.6 kernels)
Which driver compile are you using from their website?(the offer pre-compiles for various systems and an uncompiled version)

Lastly......(yes, I have to ask this, PLEASE don't take it personally)

You sure it's a 536EP modem?

hlfmanhlfamzng
30th June 2005, 04:28 AM
Just a reference point

http://downloadfinder.intel.com/scripts-df-external/filter_results.aspx?strTypes=all&ProductID=977&OSFullName=Linux*&lang=eng&strOSs=39&submit=Go%21

jasonfireup
30th June 2005, 05:25 AM
Thanks for your response.
I download from the intel website , Modem Chipset Driver (Uncompiled) - [INTEL-536EP-4.69.1.TGZ]
These driver support 2.6.x kernel


These drivers are picky from what I've seen.

What driver version are you using from intel's website?(only 4.69 supports 2.6 kernels)
Which driver compile are you using from their website?(the offer pre-compiles for various systems and an uncompiled version)

Lastly......(yes, I have to ask this, PLEASE don't take it personally)

You sure it's a 536EP modem?

hlfmanhlfamzng
1st July 2005, 02:11 AM
Have you tried one of the pre-compiles?(maybe you'll get lucky)

Is this a fresh off of the disks FC4 install, or have you run up2date?(hopefully you can take this to work or something and connect to broadband and update it if you haven't) That might fix it... might very well be your best bet.

Honestly, being as intel's modem driver is partially closed source I'm not sure if there's anybody here on this forum that can help.(hopefully I'll be proven wrong) You'll probably have to get in touch with intel and/or file a bug report with redhat's bugzilla on this.

After having compile problems once with this modem I ordered a hardware modem off of ebay for my grandma's comp.

hlfmanhlfamzng
1st July 2005, 02:19 AM
This website might also help you......(it wouldn't hurt to contact them and see if they've heard anythign about FC4/536EP)

http://linmodems.technion.ac.il/

They have a full directory of drivers here....

http://linmodems.technion.ac.il/packages/Intel/536/

This driver

http://linmodems.technion.ac.il/packages/Intel/536/intel-536EP-2.56.76.0.tgz

Is listed as for 2.6 kernel only.

I found this here.

http://forums.fedoraforum.org/showthread.php?t=44947&highlight=536ep

Try searching fedoraforum for "536ep" and see what comes up. It may give you more definite answers than I can provide.

jasonfireup
6th July 2005, 04:37 AM
That driver , I had alreay try , still can't work , but thank you very much !

jasonfireup
11th July 2005, 02:18 AM
Anyone Help me ?

jasonfireup
13th July 2005, 05:29 AM
Need Help , please !!

Vouters
5th November 2005, 10:32 PM
Hi,

I have a working 536EP driver that I use for efax and tested with a kppp connection.
Send me mail at Philippe.Vouters@laposte.net and I'll send you my modified code in a .tgz attachment
Philippe

jasonfireup
6th November 2005, 04:39 PM
Thank you very much

DismalShadow
21st December 2005, 01:44 AM
Vouters, I myself have an Intel 537EP modem, as both the 536 and 537 drivers seem to have the same compile problems. I downloaded the Intel-537ep-2.70.95.0.tgz driver and got the same error as above when I did 'make 537'. Also attached is the 'mylog.txt' output from this. More info here http://forums.fedoraforum.org/showthread.php?t=73560. Anyway, can you tell me how you compiled the 536EP driver, or where you got it? I would appreciate it.

Vouters
22nd December 2005, 08:51 AM
I got the 536ep source driver from the corresponding Intel's site. As it failed to:
1/ build
2/ execute
I considerably made changes to it. You might wish to bring my changes back to the 537ep source code driver to let it build correctly. My changes are numerous and therefore I send them in a .tgz attachment to an email address. I think I left mine in a previous reply. Therefore providing you wish to get this .tgz to adapt to the 537ep source tree, just send me mail.

On FC4, PCLOS (aka Mandrake), Suse, people just do the following from a root account:
$ tar -zxvf <my attachment>
$ cd <created directory>
$ make 536
$ make install

Waiting for you to send me mail, along with the city/country where you're mailing from and the intent use you wish to have with this driver.
Yours truly,
Philippe

malikaujee
3rd August 2006, 05:53 AM
These drivers are picky from what I've seen.

What driver version are you using from intel's website?(only 4.69 supports 2.6 kernels)
Which driver compile are you using from their website?(the offer pre-compiles for various systems and an uncompiled version)

Lastly......(yes, I have to ask this, PLEASE don't take it personally)

You sure it's a 536EP modem?

Hey , wht about the 4.70 drivers for FC3 -> Intel-536EP-4.70-FC3-up.tgz
do they work with 2.6 kernels? I dont know what was the default kernel version for
FC3 . me using FC5

malikaujee
3rd August 2006, 06:02 AM
is kernel source required for the compilation of making and installing drivers on FC5?
i am using the default kernel for FC5 (no upgrades) . can anyone tell me the rpm package name for my kernel source? :D i am confused whether *kernel-devel* package is really the complete source or not

Vouters
3rd August 2006, 08:44 AM
is kernel source required for the compilation of making and installing drivers on FC5?
i am using the default kernel for FC5 (no upgrades) . can anyone tell me the rpm package name for my kernel source? :D i am confused whether *kernel-devel* package is really the complete source or not
Hi,
Please download the driver from http://linmodems.technion.ac.il/packages/intel/Philippe.Vouters/. You must install the kernel-devel for compiling the driver. Download as well and read carefully the Intel-Readme.txt.
Philippe

malikaujee
5th August 2006, 06:59 AM
gee tnx for saving me time Vouters. The one i had from the INtel site failed to build but this driver from ur link got installed fine.

mhenness
21st August 2006, 02:46 PM
Hi,
Please download the driver from http://linmodems.technion.ac.il/packages/intel/Philippe.Vouters/. You must install the kernel-devel for compiling the driver. Download as well and read carefully the Intel-Readme.txt.
Philippe

Hi Philippe,

I'm also hoping you can help me. I have an Intel 536ep modem and use Linux build 2.6.12-1.1381_FC3. I tried to install the driver from the Intel website (Intel-536EP-4.70-FC3-up.tgz). Although there are some warnings when I complied the driver code the Intel536.ko file is created successfully. The next thing I try to do is install the driver doing 'sudo make install'. I get the following output:

rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.12-1.1381_FC3
installing hamregistry, used for persistant storage
installing Intel536 driver
redhat hamboot rc2.d and rc3.d scripts
starting module and utilities
error loading Intel536
ERROR: Module Intel536 does not exist in /proc/modules
done

I then run 'dmesg' and get the following output:

Intel536: no version magic, tainting kernel.
Intel536: Unknown symbol pm_access

I also tried the driver version you supplied and got a different set of warnings and errors. Calling "sudo make install" after compiling your driver code I got the following output:

rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.12-1.1381_FC3
installing hamregistry, used for persistant storage
installing Intel536 driver
redhat hamboot rc2.d and rc3.d scripts
starting module and utilities
FATAL: Error inserting Intel536 (/lib/modules/2.6.12-1.1381_FC3/kernel/drivers/char/Intel536.ko): No such device
insmod: can't read 'Intel536': No such file or directory
error loading Intel536
ERROR: Module Intel536 does not exist in /proc/modules
done

The output from 'dmesg' was:

Intel536: no version magic, tainting kernel.
Intel536: Unknown symbol atomic_add_unless

If you could help me to sort this problem out I would appreciate it.

Thanks,
Mark.

Vouters
21st August 2006, 09:14 PM
Hello,

Download the 12/06/2006 driver. atomic_add_unless is for FC5 kernel not for FC3.
Philippe

mhenness
22nd August 2006, 09:52 PM
Hello,

Download the 12/06/2006 driver. atomic_add_unless is for FC5 kernel not for FC3.
Philippe

Hi Philippe,

Thanks for your input. I installed FC5 and used the driver you suggested and got the following output while compiling:

[mhenness@titanium intel-536EP-2.56.76.0]$ make 536
Module precompile check
Current running kernel is: 2.6.15-1.2054_FC5
/lib/modules... autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: No such file or directory
autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: No such file or directory
version.h matches running kernel
uname -r|grep "2.6" && \
cd coredrv && make 536core_26 && \
cp Intel536.ko .. && cd .. && \
strip --strip-debug Intel536.ko && \
exit; \
ls Intel536.ko >/dev/null 2>&1 || uname -r | grep "2.6" && echo "Failed to build driver" && exit; \
if [ /usr/src/kernels/2.6.15-1.2054_FC5-i586/ ]; then \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_SOURCE_PATH=/usr/src/kernels/2.6.15-1.2054_FC5-i586/ "PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
else \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_INCLUDES=/lib/modules/`uname -r`/build/include \
"PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
fi ; \
cp Intel536.o .. ; \
if [ -a /boot/vmlinuz.version.h ]; then \
cp /boot/vmlinuz.version.h /lib/modules/`uname -r`/build/include/linux/version.h;\
fi
2.6.15-1.2054_FC5
make[1]: Entering directory `/home/mhenness/intel-536EP-2.56.76.0/coredrv'
make -C /lib/modules/2.6.15-1.2054_FC5/build SUBDIRS=/home/mhenness/intel-536EP-2.56.76.0/coredrv modules
make[2]: Entering directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/coredrv.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/clmmain.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/rts.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/task.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/uart.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/wwh_dflt.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/locks.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/softserial_io.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/softserial_ioctl.o
CC [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/softserial.o
LD [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/Intel536.o
Building modules, stage 2.
MODPOST
Warning: could not find /home/mhenness/intel-536EP-2.56.76.0/coredrv/.536core.lib.cmd for /home/mhenness/intel-536EP-2.56.76.0/coredrv/536core.lib
CC /home/mhenness/intel-536EP-2.56.76.0/coredrv/Intel536.mod.o
LD [M] /home/mhenness/intel-536EP-2.56.76.0/coredrv/Intel536.ko
make[2]: Leaving directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
make[1]: Leaving directory `/home/mhenness/intel-536EP-2.56.76.0/coredrv'

Not sure if the warnings are important here but when I try to 'sudo make install' I get:

[mhenness@titanium intel-536EP-2.56.76.0]$ sudo make install
Password:
rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.15-1.2054_FC5
installing hamregistry, used for persistant storage
installing Intel536 driver
redhat hamboot rc2.d and rc3.d scripts
starting module and utilities
FATAL: Error inserting Intel536 (/lib/modules/2.6.15-1.2054_FC5/kernel/drivers/char/Intel536.ko): No such device
insmod: can't read 'Intel536': No such file or directory
error loading Intel536
ERROR: Module Intel536 does not exist in /proc/modules
done

Any input is welcome.

Best,
Mark.

Vouters
23rd August 2006, 02:50 PM
Hello Mark,

Check whether you have a /lib/modules/2.6.15-1.2054_FC5/kernel/drivers/char directory. If not, then replace in Intel536_inst
case $KERNVER in
2.4*)
CharModDir=/lib/modules/${KERNVER}/kernel/drivers/char
;;
2.6*)
CharModDir=/lib/modules/${KERNVER}/kernel/drivers/char
;;
*)
echo "unsupported kernel version. 2.4.x and 2.6.x are supported"
exit 1
;;
esac
fi
by
case $KERNVER in
2.4*)
CharModDir=/lib/modules/${KERNVER}/kernel/drivers/char
;;
2.6*)
CharModDir=/lib/modules/${KERNVER}/kernel/drivers/serial
;;
*)
echo "unsupported kernel version. 2.4.x and 2.6.x are supported"
exit 1
;;
esac
fi
I think you ought to have a /lib/modules/2.6.15-1.2054_FC5/kernel/drivers/serial.
Philippe

DCOH
29th August 2006, 10:52 PM
I just downloaded the intel 537ep driver from Vouters website now can you please tell me how to get Fc5 to install it. Yes I'm new to Fedora and I'm trying to get it setup for use without bugging everyone.
Thanks for your help.

Vouters
29th August 2006, 11:24 PM
Hello,

Is it you who has the following dialup ISP :
[whois.arin.net]

OrgName: Level 3 Communications, Inc.
OrgID: LVLT
Address: 1025 Eldorado Blvd.
City: Broomfield
StateProv: CO
PostalCode: 80021
Country: US
???

Apart from this, providing your $ /sbin/lspci shows Intel 537xx Communication Controller, you may directly do the following:
$ tar -zxvf <the tgz>
$ cd <driver's root directory>
$ make 537

If /sbin/lspci is not clear enough, you must prior to $ make 537, $ export MODEM_TYPE=<your Intel's 537 family modem chipset type>, then $ make 537.
Finally:
$ sudo make install

Providing you are not quite sure about which modem type you do own, it would be better you download the scanmodem script from http://linmodems.technion.ac.il/#scanmodem . This would make sure you do own a Intel's 537 family chipset in which case the driver you downloaded from my computer is actually suited.

Please read the filme readme.txt in the created driver's root directory. Also read http://linmodems.technion.ac.il/packages/intel/Philippe.Vouters/Intel-Readme.txt to make sure you have a correct driver's installation. Please do follow each step.

Please send your feedback to mailto:Philippe.Vouters@laposte.net

Philippe

DCOH
30th August 2006, 02:36 AM
Hi
No I'm new to the forum. My problem is that I have to download everything in Windoze than transfer it to a cd than restart in Fedora and try and get it installed. According to my windoze device manager I have an Intel 537ep modem on pci slot 3 with the installed intel driver 2.48.64.0 with a hardware Id. PCI\ven_8086&dev.1080&subsys_10098086&Rev 4. I downloaded the driver from Intel for the 537ep modem and tried to load it as per there instructions logged in as root and could not get the make clean part to work. I moved the file from my cd to my home folder on the desktop and tried to install from there. In windoze I have a tmp folder on the root that I download to and than install from it, but I'm not sure where to put it in Fedora.

Vouters
30th August 2006, 11:53 AM
Hello DCOH,

See http://www.techonthenet.com/linux/mount.php on how to Linux mount a Windows partition. This shouid avoid you to burn CD's to copy files from Windows to Linux.

With the tgz you copied,
just
$ tar -zxvf <the tar>
$ cd intel-537EP_secure-2.60.80.1
$ export MODEM_TYPE=537EP
$ make 537
$ sudo make install
Philippe

DCOH
31st August 2006, 12:47 AM
Hello Vouters
Thank you for your help, that and the "OReilly pocket guide to Linux" that I received this moring should get things running. I don't really want to access my Xp fat32 partition just yet that could get me in trouble, but Thanks again for the help so far I like what I see in Fedora 5 but I do need to update.

DCOH
1st September 2006, 03:00 AM
Still having trouble, did a complete install of fc5 today of every piece of software the installer would let me load, but when I try to install the modem I get the following:
[Dan@localhost intel-537EP_secure-2.60.80.1] $make537
module precompile check
current running Kernel is:2.6.15-1.2054_FC5
/lib/modules... autoconf.h does not exist
Please install kernel source
make:*** [check] error 1

kernel-devel is not installed and I'm trying to get yum to install it, but that is another story.
Any help would be great before I see how far I can throw the FC5 DVD. I have just about had all I can, this is nuts.

DCOH
1st September 2006, 08:31 PM
Got kernel-devel installed but when I try to install modem I get the following message:

[root@localhost intel-537EP_secure-2.60.80.1]#make install
rm -f /etc/hamregistry.bin
bash 537_inst
537_inst: line 180: unexpected EOF while looking for matching'''
537_inst: line 204: syntax error: unexpected end of file
make:*** [install] error 2
[root@localhost intel-537EP_secure-2.60.80.1]

So what is going on? I'd sure like to get this modem installed so I could start enjoying FC5.

Vouters
3rd September 2006, 06:07 PM
Got kernel-devel installed but when I try to install modem I get the following message:

[root@localhost intel-537EP_secure-2.60.80.1]#make install
rm -f /etc/hamregistry.bin
bash 537_inst
537_inst: line 180: unexpected EOF while looking for matching'''
537_inst: line 204: syntax error: unexpected end of file
make:*** [install] error 2
[root@localhost intel-537EP_secure-2.60.80.1]

So what is going on? I'd sure like to get this modem installed so I could start enjoying FC5.

Download 537_inst from <link removed>
This should do the trick.
Philippe

DCOH
4th September 2006, 06:47 AM
Vouters,
Thank you for your reply. I download 537_inst from your web site it doesn't seem to be a program just direction to build my on program is that correct. This is done in the bash shell correct. Again Thank you for your help it's hard being one of the new kids on the block.

Vouters
4th September 2006, 12:21 PM
DCOH,

Copy 537_inst to your intel's driver directory and redo $ make install from a root account.
Tell me whether this works fine for you.
Regards,
Philippe

Vouters
4th September 2006, 02:56 PM
The 537_inst file you downloaded from my Web site has to be copied in the driver's root directory. The from a root account do $ make install. Post here the result.
Philippe

DCOH
4th September 2006, 06:34 PM
I'll give it a try and let you know what happens. Thanks

DCOH
5th September 2006, 01:08 AM
Everything went fine until I did make install than I got the following message:
[root@localhost intel-537EP_secure-2.60.80.1]#make install
rm -f /etc/hamregistry.bin
bash 537_inst
running kernel 2.6.15-1.2054_FC5
installing hamregistry, for persistant storage
installing usrsound, a soft buzzer
installing 537 module
install Redht 537 boot script and links
starting module and utilities
Fatal:module Intel537 not found
insmod: can't read 'Intel537':no such file or directory
error loading Intel537
Error:module Intel 537 does not exist in /proc/modules
done
[root@localhost intel-537EP_secure-2.60.80.1]# :(

Vouters
5th September 2006, 08:23 AM
DCOH,

Edit 537_inst and replace Intel536.${KMS} by Intel537.${KMS} in

echo "installing 537 module"
install -o root -g root -m 764 Intel537.${KMS} ${CharModDir}/Intel537.${KMS} || exit 1

Sorry about this mistake which was left.
Philippe

DCOH
6th September 2006, 02:58 AM
Thank you Philippe, I'll make the changes and let you know how it worked. Sorry to have been such a bother with this problem.

Dan

DCOH
6th September 2006, 06:28 AM
Vouters
made the changes and the driver compiled and installed with no problems, but when I did a dmesg got the following results:

#dmesg
Intel 537EP card found
This Intel(R) 537 modem driver won't install on Intel 537EP card, please download the right driver
sound disabled
Intel 537EP card found

Kppp configured and initializes the modem but it does not dail out. So what now? :confused:

Vouters
6th September 2006, 10:03 AM
Can you read the Intel-Readme.txt and try the efax command to check whether the modem answers ? Then try with wvdial and finally with kppp. Post here the full efax dialog.
Thanks
Philippe

DCOH
6th September 2006, 06:48 PM
I tried the Intel work around steps but when I do the insmod -f I get the following results:

#insmod -f Intel537.ko
insmod: can't read 'Intel 537.ko": no such file or directory

So did I do something wrong which would not be anything new.

Vouters
6th September 2006, 07:01 PM
DCOH,

Did you cd to the Intel's directory where you built the driver ???
Philippe

DCOH
6th September 2006, 07:04 PM
forgot to I'll give it another try

DCOH
6th September 2006, 07:33 PM
Tried it again with the following:

[root@localhost intel-537EP_secure-2.60.80.1]#insmod -f Intel537.ko
insmod: error inserting Intel 537.ko: -1 file exists

Vouters
6th September 2006, 07:52 PM
DCOH,

This means you already install Intel537.ko via a $ make install.
You should:
[root@localhost intel-537EP_secure-2.60.80.1] make uninstall
then
[root@localhost intel-537EP_secure-2.60.80.1] make install
Can you post the efax command output with the options as suggested in the Intel-Readme.txt on my site ?
Philippe

DCOH
8th September 2006, 02:55 AM
Philippe,
I believe my problem is the Intel directry is not on the root but buried in my home file. I'm going to make some changes and let you know what happened.

Dan

DCOH
8th September 2006, 06:06 AM
Here is the results of efax:
[root@localhost]#efax -v ewinchmart
efax: Wed Sep 6 20:37:23 efax v 0.9 copyright 1999 ed class
efax: Wed Sep 6 20:37:23 efaxv 0.9 copyright 1999 ed class
efax: 37:23 compiled Feb 11 2006 10:40:17
efax: 37:23 argv [0]=efax
efax: 37:23 argv [1]=v
efax: 37:23 argv [2]= ewinchmart
efax; 37:25 opened /dev/modem
efax: 37:25 command "qov1'
efax: 37:25 waiting 2.0 s
efax: 37:27 waiting 2.0 s
efax: 37:29 command "qov1"
efax: 37:29 waiting 2.0 s
efax: 37:31 sync: dropping DTR
efax: 37:36 waiting 2.0 s
efax: 37:38 command "qov1"
efax: 37:38 waiting 2.0 s
efax: 37:40 sync: sending escapes
efax: 37:42 waiting 2.0 s
efax: 37:44 command "qov1"
efax: 37:44 waiting 2.0 s
efax: 37:46 error: sync: modem not responding
efax: 37:46 done, returning 4 (no response from modem)
[root@localhost]#

maybe you can figure out what is going on. Nothing that I've tried seems to help.

RichardJJC
24th September 2006, 06:48 PM
first from reading the books or web pages that i have looked at from FC4 the Kernal SRC
dose not come with FC After FC3. The Kernel Devel is just for development puporses
below is a link to the kernel SRC for kernel-2.6.15-1.2054_FC5 Size (41.9?MB)
ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/kernel-2.6.15-1.2054_FC5.src.rpm

also you can look at what else is there

ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/

i haven't tried vouters drivers yet

i am a windows user that is watching the progress of linux and it is still hard to install
a few times over the last 4 or 5 years i come close to braking any and all discs that even had the word Linux on them and this annoyance came from trying to install drivers over days and getting nowere i am no stranger to installing software Linux or otherwise, sometimes there is just not enought infomation

i am going to repeat this again you need the kernel SRC installed don't ask me why because i dont know

RichardJJC
24th September 2006, 06:52 PM
first from reading the books or web pages that i have looked at from FC4 the Kernal SRC
dose not come with FC After FC3. The Kernel Devel is just for development puporses
below is a link to the kernel SRC for kernel-2.6.15-1.2054_FC5 Size (41.9?MB)
ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/kernel-2.6.15-1.2054_FC5.src.rpm

also you can look at what else is there

ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/

i haven't tried vouters drivers yet

i am a windows user that is watching the progress of linux and it is still hard to install
a few times over the last 4 or 5 years i come close to braking any and all discs that even had the word Linux on them and this annoyance came from trying to install drivers over days and getting nowere i am no stranger to installing software Linux or otherwise, sometimes there is just not enought infomation

i am going to repeat this again you need the kernel SRC installed don't ask me why because i dont know

RichardJJC
24th September 2006, 06:52 PM
first from reading the books or web pages that i have looked at from FC4 the Kernal SRC
dose not come with FC After FC3. The Kernel Devel is just for development puporses
below is a link to the kernel SRC for kernel-2.6.15-1.2054_FC5 Size (41.9?MB)
ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/kernel-2.6.15-1.2054_FC5.src.rpm

also you can look at what else is there

ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/

i haven't tried vouters drivers yet

i am a windows user that is watching the progress of linux and it is still hard to install
a few times over the last 4 or 5 years i come close to braking any and all discs that even had the word Linux on them and this annoyance came from trying to install drivers over days and getting nowere i am no stranger to installing software Linux or otherwise, sometimes there is just not enought infomation

i am going to repeat this again you need the kernel SRC installed don't ask me why because i dont know

RichardJJC
24th September 2006, 06:53 PM
first from reading the books or web pages that i have looked at from FC4 the Kernal SRC
dose not come with FC After FC3. The Kernel Devel is just for development puporses
below is a link to the kernel SRC for kernel-2.6.15-1.2054_FC5 Size (41.9?MB)
ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/kernel-2.6.15-1.2054_FC5.src.rpm

also you can look at what else is there

ftp://rpmfind.net/linux/sourceforge/l/li/linux-ntfs/

i haven't tried vouters drivers yet

i am a windows user that is watching the progress of linux and it is still hard to install
a few times over the last 4 or 5 years i come close to braking any and all discs that even had the word Linux on them and this annoyance came from trying to install drivers over days and getting nowere i am no stranger to installing software Linux or otherwise, sometimes there is just not enought infomation

i am going to repeat this again you need the kernel SRC installed don't ask me why because i dont know

RichardJJC
24th September 2006, 06:53 PM
one other thing
http://rpmfind.net/linux/RPM/index.html

this web site holds a lot of linux software

RichardJJC
24th September 2006, 06:58 PM
who ever runs this forum should add a text preview window i would consider what has happend here a bit of a bug a preview window would have pevented this

RichardJJC
24th September 2006, 09:53 PM
hello i am now connected using Linux Fedora core 5
in some distros you need the source in FC5 you don't just install the other pakage that matches your kernel mine was /usr/src/kernels/2.6.15-1.2054_FC5-i686 <--- this open the rpm and you should after doing alittle bit of clicking find this directory structure ---> /usr/src/kernels/2.6.15-1.2054_FC5-i686 if the numvers match your kernel version numbers then this is what you shoul install what you have to do now is build the kernel headers the files that where made by the latest scanmodem helped me do this(/Modem/DriverCompiling.txt) i hope this help's [this is the driver sorce i used intel-536EP-2.56.76.0_21_09_2006.tgz Vouters driver]

DCOH
25th September 2006, 06:45 AM
Hi Philippe,
I'm still trying to get this modem to work. Any ideas?

Vouters
25th September 2006, 07:00 AM
DCOH,

Send the output to Philippe.Vouters@laposte.net of
$ /sbin/lspci -vv
$ export MODEM_TYPE=<your export>
$ make 537
$ make uninstall
$ make install
$ dmesg
$ efax -v ewinchmart
$ dmesg

Without these informations, I really can't help
Philippe

Vouters
25th September 2006, 07:08 AM
DCOH,

Typical 537 family modem installation:
[root@victor ~]# cd ~philippe/intel-536EP-2.56.76.0/
[root@victor intel-536EP-2.56.76.0]# make uninstall
echo Uninstalling on system V boot like only.
Uninstalling on system V boot like only.
rm -f /etc/init.d/536ep_boot
rm -f /etc/hamregistry.bin
rm -f /etc/init.d/Intel536_boot
rmmod Intel536
[root@victor intel-536EP-2.56.76.0]# cd ~philippe/intel-537EP_secure-2.60.80.1/
[root@victor intel-537EP_secure-2.60.80.1]# export MODEM_TYPE=537SP
[root@victor intel-537EP_secure-2.60.80.1]# make 537
Module precompile check
Current running kernel is: 2.6.17-1.2187_FC5smp
/lib/modules... autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: Aucun fichier ou répertoire de ce type
autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: Aucun fichier ou répertoire de ce type
version.h matches running kernel
2.6.17-1.2187_FC5smp
make[1]: Entering directory `/home/philippe/intel-537EP_secure-2.60.80.1/coredrv'
make -C /lib/modules/2.6.17-1.2187_FC5smp/build SUBDIRS=/home/philippe/intel-537EP_secure-2.60.80.1/coredrv modules
make[2]: Entering directory `/usr/src/kernels/2.6.17-1.2187_FC5-smp-i686'
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/coredrv.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/clmmain.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/rts.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/task.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/uart.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/wwh_dflt.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/locks.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/softserial_io.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/softserial_ioctl.o CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/softserial.o
CC [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/afedsp_int.o
LD [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/Intel537.o
Building modules, stage 2.
MODPOST
WARNING: could not find /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/.537core.lib.cmd for /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/537core.lib CC /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/Intel537.mod.o
LD [M] /home/philippe/intel-537EP_secure-2.60.80.1/coredrv/Intel537.ko
make[2]: Leaving directory `/usr/src/kernels/2.6.17-1.2187_FC5-smp-i686'
make[1]: Leaving directory `/home/philippe/intel-537EP_secure-2.60.80.1/coredrv'[root@victor intel-537EP_secure-2.60.80.1]# make install
rm -f /etc/hamregistry.bin
bash 537_inst
running kernel 2.6.17-1.2187_FC5smp
installing hamregistry, used for persistant storage
installing usrsound, a soft buzzer
installing 537 module
install REDHAT 537 boot script and links
starting module and utilities
done
[root@victor intel-537EP_secure-2.60.80.1]# dmesg
Linux version 2.6.17-1.2187_FC5smp (brewbuilder@hs20-bc2-2.build.redhat.com) (gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) #1 SMP Mon Sep 11 01:32:34 EDT 2006
...
sound disabled
Intel 537SP card found
[root@victor intel-537EP_secure-2.60.80.1]# make uninstall
Uninstalling on system V boot like only.


usrsound: aucun processus tué

Uninstalling done.

Vouters
25th September 2006, 07:44 PM
Alll everyone,

You can get the Intel 536EP and 537 family modem updated drivers from the following URL: http://linmodems.technion.ac.il/packages/intel/Philippe.Vouters/
You should search http://linmodems/technion.ac.il/ for the scanmodem utility which will guide you on the best suited driver for your distribution. <link removed> site will stop. Do not rely on it any longer.
Philippe

RichardJJC
28th September 2006, 07:40 PM
when compiling the headers i just ignored the errors and the installed the modem driver

RichardJJC
28th September 2006, 07:42 PM
it worked for me

omidkamangar
23rd November 2006, 01:49 PM
Hi Vouters
I have an intel536ep modem and FC5 on my system I downloaded the drivers from http://linmodems.technion.ac.il/packages/intel/Philippe.Vouters/ but failed to install the driver and get this message :

[root@localhost intel-536EP-2.56.76.0]# make install
rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.15-1.2054_FC5
installing hamregistry, used for persistant storage
installing Intel536 driver
install REDHAT Intel536 boot script and links
starting module and utilities
FATAL: Error inserting Intel536 (/lib/modules/2.6.15-1.2054_FC5/kernel/drivers/char/Intel536.ko): Invalid module format
insmod: can't read 'Intel536': No such file or directory
error loading Intel536
ERROR: Module Intel536 does not exist in /proc/modules
done
Please help me :(

Vouters
23rd November 2006, 09:22 PM
Hi,

If you are really unable to help yourself, open up a call at your local Hewlett-Packard office. Tell the people there, your call has to be directed to philippe_vouters (France) call queue. Note that you will be charged for the time I'll spend helping you. I do promise you I shall do my best to really find a solution for you. Be aware that not EVERYTHING is at no cost.

Vouters
23rd November 2006, 09:35 PM
Hi,

If you are really unable to sort out your own problem on your own computer, do call your local Hewlett-Packard support center and tell them to assign your problem to philippe_vouters (France) call queue. As this is totally a non Hewlett-Packard product, the time I shall spend to help shall be charged to you. Be aware that not EVERYTHING must given for free. The least is that any work deserves a salary.

Philippe Vouters

omidkamangar
23rd November 2006, 10:20 PM
There is no local Hewlett-Packard office in my area. What should I do ?

DCOH
24th November 2006, 03:13 AM
I should have told you Vouters had become a bitter person while two or three others was trying to get his software to work and that you really shouldn't try to connect him.

omidkamangar
24th November 2006, 10:08 AM
What should we do with our modem ?
Format our Hard Drive ?
Use windows (I hate this one) ?
Buy a new modem ?
:mad:

I do not know what to do. :(

DCOH
24th November 2006, 08:30 PM
I happened to have an external modem handy that was setup to work with my Linux but doesn't want to work with windows XP so when I use windows I use the Intel modem.

omidkamangar
24th November 2006, 09:50 PM
What kind of modem ? Can you name ?

DCOH
24th November 2006, 10:20 PM
U.S.Robotics 56k faxmodem