PDA

View Full Version : ipw2200 Set Bit Rate (8B20)



fun4stuff
29th June 2005, 02:39 AM
Does anyone know how I can fix this problem:

I can detect wireless signals (KWiFiManager) and ipwconfig works fine... but whenever I try and connect I get the error :

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not supported.

Determining IP information for eth1... failed; no link present. Check cable?

THANKS

jim
29th June 2005, 02:50 AM
as root ( use su - to switch to root )
chkconfig NetworkManager on
type exit
then type
NetworkManagerInfo ( if you use gnome but I think it works in KDE)
you should then see a sweeping radar in the system tray. click it and choose add network enter the network name and a wep key if you use one and thats it.

fun4stuff
29th June 2005, 05:03 AM
This is the output that I got:

NetworkManagerInfo

(NetworkManagerInfo:4033): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

simonsez
29th June 2005, 05:35 AM
I had a similar problem. I simply unplugged my router and ISP connection......waited about 1minute.......turned on the router.....then turned on the the ISP. Worked fine after that.

kg4cbk
1st July 2005, 07:41 PM
From what I have seen the set bitrate error can be ignored. Would be nice to get rid of it but appears to be benign.

Try removing the CHANNEL line (or comment it out) in the ifcg-* file for your interface. This appears to have fixed wireless for several users.

Pan007
6th July 2005, 09:34 AM
When I run NetworkManagerInfo, I don't get the scanning for wireless icon but the wired network connection.
Trying to switch to wireless networks, but nothing happends.

Any tips on this?

Is it because my wired network is running? Do you have to unplugg wired network?
If so...tried it an nothing happends.

fun4stuff
6th July 2005, 11:31 AM
i'm also having problems... NetworkManager works fine when at my home and friends (where there is only 1 close wireless network), but at work there are many routers and it continuously scans. It will not connect... but, it connects if i go through network device control :confused:

jdphelps
6th July 2005, 03:29 PM
From what I've seen with ipw2200, and I will preface by saying I'm no expert. You likely have your firmware in the wrong folder or it is the wrong version for the driver you are using. That will give you the "no link present" message.

To get rid of the bit rate error message check your eth1.conf file and change the rate line to something like Rate='' Basically, rate = blank.

kg4cbk
6th July 2005, 04:53 PM
When I run NetworkManagerInfo, I don't get the scanning for wireless icon but the wired network connection.
Trying to switch to wireless networks, but nothing happends.

Any tips on this?

Is it because my wired network is running? Do you have to unplugg wired network?
If so...tried it an nothing happends.

NetworkManager is there for laptop users to automatically switch to the best available network connection. A wired connection is prefered over a wireless connection. And it only wants to have one active connection at a time. So yes you must disconnect from your wired connection to get it to use a wireless connection.

Personally, I found NetworkManager to be a problem. I prefer to manage my network connections myself and not leave it up to a program that for odd reasons would connect sometimes and not at other times. Maybe someday this program will mature enough that it works reliably.

simonsez
6th July 2005, 05:00 PM
From what I've seen with ipw2200, and I will preface by saying I'm no expert. You likely have your firmware in the wrong folder or it is the wrong version for the driver you are using. That will give you the "no link present" message.

To get rid of the bit rate error message check your eth1.conf file and change the rate line to something like Rate='' Basically, rate = blank.

Where would the eth1.conf file be located?

kg4cbk
6th July 2005, 05:15 PM
I think he is talking about the /etc/sysconfig/networking/devices/ifcfg-eth0 file.

Pan007
6th July 2005, 08:08 PM
NetworkManager is there for laptop users to automatically switch to the best available network connection. A wired connection is prefered over a wireless connection. And it only wants to have one active connection at a time. So yes you must disconnect from your wired connection to get it to use a wireless connection.

Personally, I found NetworkManager to be a problem. I prefer to manage my network connections myself and not leave it up to a program that for odd reasons would connect sometimes and not at other times. Maybe someday this program will mature enough that it works reliably.

Thanks for clearing this for me. I thought it was like this.

Hopefully one day, I will get this Fu**ing Intel Pro/Wireless 2200BG to work under linux. I'm getting pretty :mad: when it comes to this. And can anyone here please tell me why there isn't any good howto when it comes to this. There are plenty laptops with this chip now, and many owners would like to see it work. (Let's all prey,,,,,,,,,,and NO Windows is not an option.)

jdphelps
7th July 2005, 03:19 AM
I think he is talking about the /etc/sysconfig/networking/devices/ifcfg-eth0 file.

Yeah, that's the one... except it's ifcfg-eth1 for wireless - usually. ;)

kg4cbk
7th July 2005, 03:47 AM
Thanks for clearing this for me. I thought it was like this.

Hopefully one day, I will get this Fu**ing Intel Pro/Wireless 2200BG to work under linux. I'm getting pretty :mad: when it comes to this. And can anyone here please tell me why there isn't any good howto when it comes to this. There are plenty laptops with this chip now, and many owners would like to see it work. (Let's all prey,,,,,,,,,,and NO Windows is not an option.)


Well I finally gave up trying to get the 2200BG chip working in my Tecra M2. I bought a WG511 card and used driverloader to get it working. I would have prefered to get the centrino chip working with native drivers but I could not get to reliably connect. Looking back on my attempts I might have gotten it to work if I had deleted the CHANNEL line in the config file. The systems I had were that I could see and list all the access points in the area but could not establish a connection. I think there is a basic problem in the network setup with wireless connections. If you try to specify the channel that should be used it seems to have problems establishing the connection. I believe a bug was reported on this problem but I have not been able to follow any results.

simonsez
7th July 2005, 05:08 AM
Awww man...that's too easy.

Pan007
7th July 2005, 08:30 AM
Nothing is to easy.

But do I really have to buy over 100 new wireless cards to newly bought laptops to get my wireless network to run. No way. I'll fight, I'll fight!

But I'm now trying Ubuntu......this dist. discover my ipw2200 on inst. So if it's working......then what shall I do?

jim
7th July 2005, 10:36 AM
The ipw2200 wireless card works in Fedora Core. It also works in Ubuntu as well. I have used both disrtos. I don't know what the exact issue you are having with your card in Fedora, But I work a How-to 7 months ago for Fedora Core 3 and the same applies for Fedora Core 4. The difference is in the Driver version. 1.0.0-23 version is the culprit. there is the 1.04 version but no kernel module available as of yet.
I had my wireless working in FC4 in a matter of a few minutes.
downloaded the 3 rpms from ATrpms
ipw2200-1.0.0-23.rhfc4.at.i386.rpm
ipw2200-kmdl-2.6.11-1.1369_FC4-1.0.0-23.rhfc4.at.i686.rpm
ipw2200-firmware-2.2-5.at.noarch.rpm
installed the 3 at once
in the dir where I saved them
rpm -ivh *.rpm
rebooted

went to Desktop --> System Settings--> Network
created a new Hardware piece
save the changes
rebooted
configured the wireless settings
chkconfig NetworkManager on
service NetworkManager start
logged out
logged in
NetworkManagerInfo
Clicked the sweeping radar ( yes the cable has been unplugged )
clicked Create new wireless Network
added my AP essid
clicked the use encryption box
Choose WEP key (HEX)
entered my Key and it connected.
added a mini command line thingy to my top panel and ran the following command
gnome-session-save (this saves the current set up of the desktop, e.g the applications running )
that s it

jdphelps
8th July 2005, 05:25 PM
I also had no problems connecting the ipw2200 on a dell 700m using FC4. I'm a totaly linux newb as well. I found that the INSTALL and README docs that come with the ipw2200 driver are more then enough information to get the card working.

Follow the steps from the beginning, including removing the ipw2200 driver that comes with FC4 out of the box.

Download the driver 1.0.4 and firmware 2.3 and follow the instructions. If you think a path is not correct or something isn't working you can probably find the right path by just "searching" for the intedned target file or directory.

As I said earlier, to get rid of the "bit rate error" message, just set RATE=''

Don't mess with the channel setting, your card should scan for any available network and try to connect to it, it will set the channel setting for you when it does that.

No need to give up, just have some patience and don't be afraid to start over by removing the driver and firmware and re-installing if needed.