PDA

View Full Version : FC4 and a clamshell G3 iBook


djd
28th June 2005, 09:26 AM
So I happened across FC4 the other day and thought I'd try it on an old IBM T21 laptop ..... and it worked 100% out of the CDs. Much encouraged by this I exhumed an old (?) blue clamshell iBook from under my desk, cleared off the dust, burned a PPC version of FC4, inserted the boot CD, pressed 'c' on the keyboard and powered on. The CD goes click,tic,tic,whirr....click,tic,tic,whirr forever! Faulty CD or CD-drive thinks I. Not a bit of it! CD reads on all my other PCs, and the CD drive in the iBook reads almost any other CD I've got (except any that are supposed to be iBook bootable!!). Tried >boot cd: from the firmware - same result. Given that I've no Apple CDs for this machine, is there anyone out there that can tell me how to get this thing to boot FC4 (or any Linux, for that matter) and allow me to re-partition the HDD to get rid of MacOS-X and finally be able to use this laptop?

Regards

Dave

rzoom
28th June 2005, 08:21 PM
Have you tried yellowdog linux? It is a PPC repackage of slightly older RedHat. Still relatively up to date though. I know that it is one of the most widely used linux distributions for the PPC platform. Works great on my powerbook. =) The latest release is 4.0.1.

Main Page: http://www.yellowdoglinux.com/

Free Download Mirrors: http://www.yellowdoglinux.com/resources/downloads.shtml

-rzoom

JLF_65
28th June 2005, 10:22 PM
Yellowdog isn't as good as FC in my opinion, despite being based on it. In fact, I felt YD 3 was much better than YD 4. I stayed with YD 3 until FC4 for PPC came out. Now I'm happy with FC4 on my iMac.

The problem might be the CD/DVD media or speed you wrote at. Old drives can have trouble reading certain new media (cheap), especially if written at a high speed. First, don't use RW media. Second, try writing at a lower speed. Finally, try a better brand of media. I only use RiData CDRs. I've never had trouble with them while I've read all kinds of things about other brands. With DVD-Rs, I use either RiData or ProDisc. Both are nice brands for DVD-R. Which reminds me, when writing DVDs for older systems, use DVD-R and write in TAO or DAO mode. This maximizes compatibilty. Most old DVDs won't read DVD+R.

djd
29th June 2005, 10:39 AM
Thanks for that information. I tried burning a TDK CD in a different, slower burner and did manage to create a bootable CD. The problem I've got now is different - I can't get the .iso checksums to agree with the published ones. I've tried downloading twice, each time from a different server using a different protocol. Once to a Windoze box and once to a Linux box. On each occasion the downloads have been identical with identical checksums but, sadly, different from the published ones. Also, on being invited to check the installation CDs they all report FAIL!!!.. I've just attempted an install with a FAIL set of CDs but it seems to have hung on the last preparation screen - the one that's entitled 'About to install'. Still, I'll wait 30 mins or so to see if anything happens ......

Has anyone else seen this 'bad checksum' problem or, indeed the 'FAIL' media check?

Regards,

Dave

JLF_65
29th June 2005, 10:26 PM
Download via torrent. I NEVER use ftp anymore as I've had to download four CDs a total of ten times to get proper checksums. FTP just doesn't have the reliability for large files. Sites using ftp really need to put up PAR files to go with the images - just in case. Bittorrent is nice because it checks the image as it's downloading. If a part doesn't check, it tosses it and downloads it again. I've never had a bad ISO from bittorrent.

http://torrent.fedoraproject.org/

djd
30th June 2005, 10:32 AM
Thanks for all your information. Just to add to the sum of knowledge ....

1. All the CDs needed to be remade on the slower burner (actually at 600Kb/s). I have a hunch that the TOTAL avoidance of buffer under-runs has something to do with the situation but I can't prove it.
2. I ignored the FAILs that checking the discs produced and went ahead with an installation anyway. It all worked OK and so I wonder if the wrong checksums have been published somewhere.
3. I waited 10 mins after 'About to install' was displayed, clicked on continue again and everything proceeded per plan. Something must have been going on but I've no idea what!
4. I'll try a torrent download sometime today and see if that produces different checksums (I shouldn't, but who knows?)
5. Installation takes a long time - be patient!
6. When adding software using the "add or remove applications" menu entry there's a problem when CDs need to be changed as the automounter gets to the CD first resulting in all sorts of interesting conflicts. Does anyone know how to stop CD automounts?

So ... another old iBook is resurrected. Even with the 128Mb (total) RAM it's got at the moment its performance is acceptable as a desktop machine.

Good ol' Linux - again!

Regards,

Dave

JLF_65
30th June 2005, 09:42 PM
That's strange about your burner... it sounds like you either don't have BurnProof, or you aren't burning with it activated.

Preferences -> Removeable Storage

djd
1st July 2005, 09:14 AM
I don't understand the burner bit either! For the first effort I used a PlexWriter 12/10/32A on a Dell box with WinXP-Pro and Nero 6.3.1.20, and for the second effort I used an Iomega Dual DVD DVDRW4216IND-A on a Compaq box with W2K and Nero 6.3.1.20. In both cases buffer under-run was active but in the second case I throttled the write speed back to the minimum. In the first case I got the message "Buffer underrun avoided N times" (usually about 20) whereas on the second setup I got no buffer underrun messages. I can read ALL the CDs on both of the Windows boxes on both the burner devices AND on attached CD-ROM devices.

I can only think that either the first writer is slightly misaligned yet in spec for most CD readers, or the burning intensity at high speed is not quite good enough to produce readable CDs for the iBook, or that the buffer underrun situation does something to the Cd that's important to the iBook but of no consequence to Windoze.

In any case the situation has been resolved and the sum of knowledge about making and reading CDs has been increased - if only by knowing how to work around a problem rather than solve it!

Thanks for all your contributions,

Dave

JLF_65
1st July 2005, 09:54 PM
No problem. That's why forums like this are so great - if you have a problem, someone may know exactly how to fix it, and if they don't, they can often make suggestions that lead to a solution. One reason I've stuck with Fedora is the great forum. Any time I have a problem, I come here and do a search. Most often, someone else has already had the same problem and figured out a fix, or posted a link to info on taking care of the problem. Then add the HowTo guides here on top of it all... :D