PDA

View Full Version : It all works Fine !



DrShasta
27th June 2005, 10:20 PM
Hello, to those of us who spent hours trying to configure Linux on their laptop, do not give up, it is worth it!

Now, the wifi, ATI, Synaptics, screen resolution, they all work perfectly. I will post my xorg.conf tomorrow.

Thanks to all of you who posted many tips :)

Matthieu

DrShasta
28th June 2005, 04:39 PM
Haaaa... Linux... Ever since I got my new laptop last year, a Gateway M505X, I tried to run Linux. I finally got everything to run perfectly, using the Fedora Core 3. Here is what I did:

First, I had trouble due to a badly made partition: it seems that Fedora Core 3 does not “cut” the hard disk properly, putting errors around there and then.

A few lines added in the /boot/grub/grub.conf would do the trick:
================================================== =====
default=0
timeout=5
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
hiddenmenu
title WinXP
rootnoverify (hd0,0)
chainloader +1
title Fedora Core (2.6.11-1.35_FC3)
root (hd0,1)
kernel /boot/vmlinuz-2.6.11-1.35_FC3 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.11-1.35_FC3.img
================================================== ====

Now, the second thing I had trouble configuring was the wifi. I followed the instructions displayed here http://forums.fedoraforum.org/showthread.php?t=18665 and it all worked perfectly fine, and from the first time. To find your kernel version, simply type:

uname -r

I also needed to set up the touchpad. I found several posts on "synaptics" explaining it all.

The thing that caused me the most trouble was the video card, and how to get the 3d acceleration to work properly.

Here is what I did.

First, go to the website ATI (http://www2.ati.com/drivers/linux/fglrx_6_8_0-8.12.10-1.i386.rpm) and download the RPM package.
Then, go here (http://ati.cchtml.com/show_bug.cgi?id=110) and download the two patches.
Make sure your gcc is up to date, otherwise, type:
yum install gcc*

make a copy of your xorg.conf:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

press ctrl+alt+f1 and in root mode, type:
init 3

This will make your X server to shutdown. You can now install the drivers:
rpm -Uvh ati-fglrx[blablabla].rpm
once it unpacks and install, apply the two patches:
patch -p0 <”path_to_patch_1.patch” (without the " symbol)
patch -p0 <”path_to_patch_2.patch” (without the " symbol)

now, everything should go smoothly.
type:
sh make.sh
and then type:
cd ..
finally, type:

sh make_install.sh
Once it all installs, launch fglrxconfig tool and follow the instructions. (type fglrxconfig)Once this is done, you need to open xorg.conf AND xorg.conf.bak and compare the two. Put all the old info from the .bak that is related to anything BUT the video card into the newly created xorg.conf. Go down to the part where you can see Section “Screen” and go down to the line that says “modes”. Add the resolution “1280x800”.
Now, save the whole thing, and type init 5. That should launch X.

Welcome to the fabulous world of 3d gaming under Linux :)
Here is a snapshot of my screen showing the glxgears and the resolution being 1280x800.

I also copy/paste my xorg.conf, just in case:
================================================== =
Section "dri"
# Access to OpenGL ICD is allowed for all users:
Mode 0666
# Access to OpenGL ICD is restricted to a specific user group:
# Group 100 # users
# Mode 0660
EndSection
Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "type1"
Load "freetype"
Load "glx" # libglx.a
Load "dri" # libdri.a
EndSection
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection
Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x800"
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection
# === ATI device section ===
Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "yes"
Option "FSAAScale" "6"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "no"
Option "ForceGenericCPU" "no"
BusID "PCI:1:0:0" # vendor=1002, device=4e50
Screen 0
EndSection
Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Section "ServerLayout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "AlwaysCore"
EndSection

### EOF ###
===================================

Good Day :)