PDA

View Full Version : problems with 2.6.11-1.35 kernel and external HDD



iamroot
27th June 2005, 12:10 PM
I'm intending to switch over to Fedora Core 4 from FC3 so I got an external hard disk to backup my 5 GB+ worth of files and documents. I was worried that my external HDD wouldn't work but was really relieved when I plugged it in yesterday and it auto-mounted like a flash drive. However, this morning I upgraded to the 2.6.11-1.35 kernel and now the external HDD won't auto-mount. When I tried to manual mount, I got a msg saying " fat32 is not supported by kernel" or something like that. I tried to us my old kernel but it wouldn't boot up. Got an error msg "kernel panic". Can anyone help me out here? I really need my external HDD to backup.

psb154
27th June 2005, 01:01 PM
iamroot,

In your /etc/fstab you should have a line that says something like:
/dev/sda1 /media/myExtHDD vfat users,rw,umask=0 0 0

do you have something like that?

Might also be worth checking for hotplug or usb updates.

iamroot
27th June 2005, 01:22 PM
I installed the 2.6.9 kernel and my external HDD WORKS!!!

psb154
27th June 2005, 02:02 PM
With the new kernel running check for usb or hotplug updates.

kdagnall
30th June 2005, 08:09 AM
Yo iamroot, I'm having a similar problem.
I had 2.6.9_FC3 2.6.11-1.27_FC3 and 2.6.11-1.35_FC3. Right after I installed 2.6.11-1.35 it caused
Kernel Panic! Tried to overwrite INIT!
I'm under the impression that my problems could be caused by conflicts in apt repositiory package dependancies. Anyone out there have a theory about why?

I'm running a t42 thinkpad dual booting w/ XP
I usually use ayo.freshrpms to get new packages
but this time I used livna.org.
Ringing any bells?

Kent Dagnall

iamroot
30th June 2005, 01:03 PM
I'm not too sure bout that. I think it's some package clash. I don't think the repository makes a difference. Anyway, the 2.6.9 kernel worked for me=)