PDA

View Full Version : cdrom mount unmount problem



gtrgy
27th June 2005, 06:12 AM
:) I am trying to resolve this problem I am having with my cdrom drive

--running FC2 Tettnang--

I want to install kde (and gcc plus a few other things) off the install disk so I open add/remove apps in system tools (package manager) and start the process...

after a few system updates and things a box comes up asking for the install disk to be put in, and then click ok...well I can sit there till the cows come home but that box wont go away and the process does not move forward...= me get tired of this

I click on the cd icon and there are the directories and files...sometimes...becoz sometimes I try to eject the cd and a box comes up saying "cant unmount the cd /mnt/cdrom not mounted according to mtab" and sometimes the directories and files are there...but a box comes up saying cant mount /mnt/cdrom becoz /dev/cdrom already mounted or cdrom busy...

now I have found other posts on the general support that mention this problem but to date nothing I have tried has worked...

please can someone shed some light on what is happening here...I am quite sure its a simple noobie thing but I cant for the life of me get a handle on it

thanx

gtrgy
27th June 2005, 07:14 AM
more information...so this time i mounted the cd this way...mount /dev/hdc /mnt/cdrom

and lo and behold, when I clicked on the ok for insert disk 2, it went away...temporarily...what happened was this...a new box came up with "unable to access disk" make sure the disk is inserted and try again...weee.eee..lll

so I clicked on the cd icon and got this reply...

MOUNT ERROR
unable to mount the selected volume

under show more details was this...
mount: /dev/cdrom already mounted or mnt/cdrom busy
mount: according to mtab, dev/hdc is already mounted on /mnt/cdrom

I dont know whats going on here...can someone please help

s_drac2
27th June 2005, 06:42 PM
I think I had the same problem under FC4. I think it may be access permissions as I could play an audio CD(without sound) as root, but got a DRIVE ERROR under normal user.

tejas
27th June 2005, 06:46 PM
You are not supposed to mount the CD when running add/remove programs
the add/remove programs auto mounts/unmounts the CD as needed, without your intervention

If you want to see the files in the CD, then mount it
rpm install files are found in /mnt/cdrom/Fedora/RPMS

gtrgy
27th June 2005, 09:30 PM
I am not mounting the drive to start with...I only did that after the package manager wasnt able to read the disk...

which is definitely the problem...I put another cdrom drive in the 'puter and tried again but its just the same thing...UNABLE TO ACCESS THE DISK try again

I now know the problem is not being able to read off either disk to install...

this seems to be a basic flaw in the linux OS - the fact that a simple operation like reading off the cdrom proves to be such a problem...its no wonder to me that people leave linux alone ... this has taken me over one week so far and I'm no closer to knowing anything about it...I have read mountains of information on websites and from books ...just wasting my time trying to understand what turns out to be poorly written software...

I waited 7 years to try this install of Linux (FC2 Tettnang) and I might as well wait another 7 years and see if by then its progressed to a user friendly OS that performs the way people expect without having to read 50,000 pages of inane and useless information just to perform a simple and basic operation like read and install off a cdrom...this is basic stuff from the mid-nineties and here we are 10 years later in the 21st century and this OS cant even do simple things without the user having to know stuff that any OS worth its salt performs in the background...geeez, I might as well write the bloody OS myself it feels like you have to know that much to use Linux

ieuuk
27th June 2005, 09:38 PM
the package manager doesnt work very well. its unable to get dependices resolved correctly and is a bit ugly. why dont you use yum and get it to download the newest version of kde? go to fedorafaq.org and use their yum.conf, put it in your /etc/ folder and then run a yum install kde and it should find it all.

gtrgy
28th June 2005, 06:52 AM
Ok ieuuk...thanx a lot, and I am trying it now...

ieuuk
28th June 2005, 09:51 AM
http://forums.fedoraforum.org/showthread.php?p=294082#post294082 someone explains how to do it a bit better there.

tuxdaemon
28th June 2005, 09:53 AM
lsof on the program supposidley hanging it to see what files it's reading. Force unmounting is also there in case of emergencies, although sometimes it won't work.

mauget
6th July 2005, 09:55 PM
For me, this problem is chronic. I've experiened the behavior of not finding the CD on both FC3 and FC4. My machine has a CD recorder and a DVD reader. The Add / Remove Applications package manager asks for a given CD, but never sees it in either drive. I have no trouble mounting and using CDs outside of this application.

I believe that the package manager is supposed to auto-mount the CD somewhere, but mine can never find it. I've tried some of the work-arounds listed earlier, to no avail. The predecessor Redhat utility used to work on the same machine. Maybe the dynamic DEV change broke it, but that's me, guessing. :confused:

Additionally, many of the menu items are dead in package manager for me. These include the About item and Edit | Preferences. I wouldn't show this behavior to a Windows XP fan. :eek:

I'd like to respectfully, quietly, say that diverting people to something else, such as yum, while helpful, does not address problems with package manager. The former is used with network repositories, while the latter is a utility for managing local RPMs where no connection is required. Since Add / Remove Applications -- the package manager -- appears in the start menu, it should either be usable or be removed to allow space for stuff that works on most configurations. This is the way to move forward in any kind of contest for the end-user's desktop. I'll shut up now. ;)

Lou Mauget, CrossLogic Corp.

ieuuk
8th July 2005, 10:18 PM
yes but the yum solution solved the problem quickly and got around the problem... you just have to learn with compromises, or if you really dont like the way the package manager works, open up a bugzilla account and log the problems that you have with it so that developers can look at the code and try and find the problem where is.
All we're trying to do is to help out users with problems in a friendly tone... not debug the os.

mauget
9th July 2005, 02:48 AM
Okay. I'll shut up.