PDA

View Full Version : [Q] Keyboard stops working after KDE login



TheEdge
26th June 2005, 11:11 PM
G'Day,

- I have a box with a fresh FC4 install
- All was working well
- I did a yum update to upgrade to the latest since the release of FC
- That is when the keyboard stopped working
- I see the following:

1. KDE Login screen comes up
2. I can type in my user name and password with no problem
3. However once KDE starts up the keyboard no longer works (The mouse is fine)

- All help and suggestions greatly appreciated.
- I can still SSH into the box so I can perform all maintenance from there

TIA

rayyes
26th June 2005, 11:45 PM
a few thoughts...
is it kde-specific? does the same thing occur if you log into gnome or fluxbox?
what about logging in KDE as root? same thing?
also try starting KDE from the terminal(/sbin/telinit 3 then login to the terminal and type startkde and look for any valuable error messages)

maybe someone else has more info

TheEdge
27th June 2005, 10:46 AM
G'Day,

- Cant figure out how to login via Gnome or fluxbox
- However logging in as root into KDE works. So it has to be user specific in some way
- Also cannot figure out how to login via telinit 3 etc.

So still looking for a solution here.

TIA

TheEdge
27th June 2005, 11:11 AM
G'Day,

- This keeps getting stranger
- If I login as another user (not root, not the broken normal user) then it all works as expected
- So the problem is specific to that user

rayyes
27th June 2005, 12:08 PM
you can log into gnome: ctrl+alt+backspace to reset X. then choose session > gnome and log in.
as for your problem..hmm...why not use another user? this one obviously has some configuration issues.

TheEdge
27th June 2005, 12:15 PM
I have further narrowed this down:

- The keyboard is non responsive for that particular user
- ie. Press letter "a" and nothing happens (in Kate) hold down letter "a" and eventually letter a appears and starts repeating
- I have checked the keyboard settings for that user and they are the same as the users for whom the keyboard works

PS. Don't particularly want to use another user as I will need to reconfigure all the settings I have already done / import mail etc. Painful and something I want to avoid if I can

TheEdge
28th June 2005, 10:30 AM
G'Day,

- Solved It!!!!
- *Somehow* the accessibility to use "slow keys" had been set for that user. Hence the long presses required
- Unset that and all is good

--D

rayyes
28th June 2005, 10:33 AM
glad you solved it

tuxdaemon
28th June 2005, 10:34 AM
Wow weird error. Guessing that you are using a wireless right?

brr872002
11th August 2007, 02:56 PM
hi,

I am linux adict since RH 7.0 to FC7 , if any one get problems X session of particular user, number of times i used face, wired problem of keyboard recent times.


- Just login Genome session View> Show hidden files > Delete/Move /.kde directory Trash do'nt delete fully as precaution.

Log out start GDM change session to KDE I succeeded very time!!!!!!! :eek: