PDA

View Full Version : Wordtrans woes in FC4 / wordtrans-kde in Gnome



tmr
26th June 2005, 05:17 PM
I'm running Fedora Core 4 and installed wordtrans-1.1pre13-10 via yum. I read the documentation, and it says that there should be an executable by the name of 'wordtrans' (man even shows an entry for it), but running it returns a 'command not found' error. I've tried looking for the binary/executable (using 'whereis', 'updatedb' + 'locate' and 'find -name'), but it doesn't seem to be present in the system at all. I'm not having much luck finding anything that would explain why this is happening.

I then installed wordtrans-kde because I read in its documentation that executing it as 'kwordtrans --nogui' is equivalent to running 'wordtrans' (the console version). It works, BUT when I run it without xwindows (which is how I'll ultimately end up using it) I get the following error before getting translations:


kdeinit: Aborting. $DISPLAY is not set.
There was an error setting up inter-process
communications for KDE. The message returned
by the system was:

Could not read network connection list.
/home/USER/.DCOPserver_HOSTNAME_NODISPLAY

Please check that the "dcopserver" program is running!
(Additional: I'm using gnome. I installed wordtrans-kde via yum, which took care of dependencies)

I don't have much Linux experience, and I'm pressed for time to make wordtrans work in a console. If anybody has had the same experiences, and was able to run 'wordtrans', or maybe 'kwordtrans-kde --nogui' without the errors, I would really, really appreciate the help.

Thanks in advance.