PDA

View Full Version : acpi-cpufreq, cpufreqd, cpuspeed, ... what do I really need ?



santo
24th June 2005, 08:06 PM
I'm trying to get speedstepping to work on my laptop, but I'm not sure what I need.

After having searched the FedoraForums and google, I'm not sure anymore what I need to run.

My laptop is an Acer TravelMate 8003LMi (intel centrino)
By default, speedstepping doesn't seem to be enabled.
Therefore, I did the following:

modified /etc/cpuspeed.conf like this:

VMAJOR=1
VMINOR=1
DRIVER="speedstep-centrino"
OPTS="-i 2 -t /proc/acpi/thermal_zone/THM/temperature 65 -a /proc/acpi/ac_adapter/AC/state -p 10 25"

then, I installed cpufreqd (v1.2.0)
But, /etc/init.d/cpufreqd start gives me the following error:

Starting CPU frequency scaling deamon (cpufreqd): [FAILED]
Without any further error messages

Next, I do:

modprobe acpi-cpufreq
modprobe cpufreq_ondemand

Again, I try to start cpufreqd, but still no luck

Now I run cpufreq-info and it gives me the following info:

cpufrequtils 0.2: cpufreq-info (C) Dominik Brodowski 2004
Report errors and bugs to linux@brodo.de, please.
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which need to switch frequency at the same time: 0
hardware limits: 600 MHz - 1.60 GHz
available frequency steps: 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 600 MHz
available cpufreq governors: ondemand, userspace, performance
current policy: frequency should be within 600 MHz and 1.60 GHz.
The governor "userspace" may decide which speed to use
within this range.
current CPU frequency is 600 MHz.


So, that looks really nice !
cpu seems to be running at the lowest speed now.

But:
- don't I need the cpufreqd daemon to run then ?
- don't I need the cpuspeed daemon to run then ?
- Why do I have to modprobe both modules again each time I reboot my laptop ?

Note:
when I initially tried to start the speedstep daemon, I got an error stating that the speedstep-centrino module cannot be found
But after having loaded both modules (acpi-cpufreq and cpufreq_ondemand), I can
start the speedstep daemon !


Starting cpuspeed: [ OK ]

But, when I check the status of the daemon after having started it, I get this:


cpuspeed dead but subsys locked


I really don't know what daemons should be running, what daemons should be loaded, ...