PDA

View Full Version : Wireless Card Problem



CICA
24th June 2005, 01:08 PM
Hello everyone... (1st post on FedoraForum!)

I was hoping some one could help me out with this one. I have recently installed FC4 on my Dell Inspiron 5150, and I have been trying hard to get my Proxim RangeLAN-DS 802.11b Wireless Card to work but to no avail... :(

Can anyone please advise me on what I should be doing in order to try and get this card communicating with my router? I am fairly new to Fedora, but I am keen to get my card working...

Any help or advice is much appreciated.

Thanx

CICA

CheezyArmpit
24th June 2005, 01:10 PM
Have you tried using the Internet Configuration Wizard?

Is the card detected? Does it just not find the router?

CICA
24th June 2005, 01:13 PM
Hi there...

The card doesn't seem to be detected becuase when I open a browser it will not connect to a web page.

I am thinking there may be settings with Fedora that I may have to change. Would I be right or should the card just be picked up automatically? If so how would I tell the card has been detected?

CheezyArmpit
24th June 2005, 01:16 PM
What does typing iwconfig as root in a terminal show?

CICA
24th June 2005, 01:18 PM
iwconfig =

lo no wireless extensions

eth0 no wireless extensions

sit0 no wireless extensions

CheezyArmpit
24th June 2005, 01:21 PM
Okay, I assume it's a PCMCIA card, what does cardctl ident show?

CICA
24th June 2005, 01:23 PM
cardctl ident =

Socket 0:
product info: "PROXIM", "RangeLAN-DS PC CARD", ""
manfid: 0x0126, 0x8000
function: 6 (network)

CheezyArmpit
24th June 2005, 01:28 PM
have you tried http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/?

remove your card, insert it again and type:

dmesg | less

go right to the end.. and paste any messages relevant.. i.e. anything from cardmgr or the like

CICA
24th June 2005, 01:39 PM
CheezyArmpit...

I've tried this but I couldn't find any relevant to cardmgr. But the only thing I did see that *may* be relevant is listed below...

About 2/3 of the way down dmesg...

b44: eth0: Link is down.
eth0: no IPv6 routers present

As I say I don't know if this is relevant as I am a newb to all this. Oh yeah and the card is definatly a PCMCIA card...

The help with this is much appreciated btw (",)

C

CICA
24th June 2005, 01:58 PM
I've also tried running the lspci -v command and it came back with the following (which I assume is in relation to the Wireless Card)

02:04.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus Controller (rev 02)
Subsystem: Dell: Unknown device 0196
Flags: bus master, medium devsel, latency 168, IRQ 11

02:04.1 FireWire (IEEE 1394): Texas Instruments PCI4510 IEEE-1394 Controller (prog-if 10 [OHCI])
Subsystem: Dell: Unknown device 0196
Flags: bus master, medium devsel, latency 168, IRQ 11

chili555
24th June 2005, 02:06 PM
Laptops usually set eth0 as the ethernet connection and wireless gets eth1 or wlan0 or something other than eth0.

I believe your particular card is supported by linux-wlan-ng. Search this forum for wlan-ng and see http://www.linux-wlan.com/linux-wlan/index.html#The%20linux-wlan%20Project.

If you get stuck, let us know.

CICA
24th June 2005, 02:09 PM
I'll have a look now chili555

Thanx

C

CICA
24th June 2005, 02:18 PM
Hi Chili555...

I have downloaded linux-wlan-ng-0.1.6 and I had a look at the read me file where it gives what seems to be installation instructions, but in the disclaimer is says

"This utility is used for loading firmware images onto prism2 cards. DO NOT USE IT! UNLESS YOU KNOW EXACTLY WHAT YOU ARE DOING."

(Which has made me slightly weary about it.)

Do you think I should go ahead and install this???

Thanx
C