PDA

View Full Version : Nvidia AGP problem



chrille
17th June 2005, 06:17 PM
I have a problem with the nvidia drivers and AGP. I have a FX5200 card with AGP 8X support, but I only get AGP 4XP. Does anyone know how to solve this?


$ glxinfo | grep rendering
direct rendering: Yes
$ cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000e1b:0x1f000301
$ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: PCI device 1106:3189
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000a1f:0x00000b01
$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Enabled

bitrain
17th June 2005, 07:08 PM
Does your motherboard support AGP 8x, I thinks so, but older motherboards might not support it.

chrille
17th June 2005, 07:20 PM
I does. I've checked. I don't think anything's really wrong, I only has to tell fedora to use AGP 8X somehow...

c4raku
17th June 2005, 09:04 PM
do you have agp set to 8x in the bios?

ghaefb
17th June 2005, 09:57 PM
I think there is an option to add in your xorg.conf in section Device

Option "AGPMode" "8"
But I'm not sure...

smudge
3rd August 2005, 02:05 PM
I have been reading these guides since my last post (which was some time ago!). I liked the guide on this (http://digital-conquest.ath.cx/wiki/index.php/Ubuntu#Optimizing_Nvidia_3D_driver) page but as it is about Gentoo the directory /etc/modules.d/nvidia does not exist in my system.

The problem is simply enabling fast-writes. I have nvidia installed and Fast-Writes and SBA are supported. I find no reference in xorg or any nvidia file I can edit as suggested in the wiki above. Reading this (http://www.fedoraforum.org/forum/showthread.php?t=56207&highlight=fast+writes) post in the FC forums makes me think I have to add the lines to my xorg.conf but just wanted to make sure as this isn't mentioned anywhere else I have read. Is there not a command I can type in just to enable fast writes? Thanks.

smudge
3rd August 2005, 09:05 PM
If I type:
$ glxinfo | grep rendering I get No!
Is this just because fast writes isn't enabled? As far as I can tell the nvidia driver is all installed ok. I just have to enable everything! Any tips.. anyone?

SuperNu
4th August 2005, 06:03 AM
There are two ways you can enable fast writes with the Nvidia drivers. First is to edit /etc/modprobe.conf and add the line options nvidia NVreg_EnableAGPFW=1. If you want side band addressing turned on, you also have to add NVreg_EnableAGPSBA=1. The second way is to edit os-registry.c within the Nvidia driver package. The best way to do this is to run sh NVIDIA-Linux-x86-1.0-7667-pkg1.run -x to extract the files, cd NVIDIA-Linux-x86-1.0-7667-pkg1/usr/src/nv/, copy os-registry.c in case a mistake is made, and then edit os-registry.c. You are looking for static int NVreg_EnableAGPSBA = 0; (side band addressing) and static int NVreg_EnableAGPFW = 0; (fast writes). Change the 0 to 1, save, cd ../../.. and ./nvidia-installer to install the kernel modules.

--SN