View Full Version : Blank screen when installing.

17th June 2005, 03:04 PM
hello folks,
i'm installing FC4 on Mac mini and it's so going so well.
after yaboot comes up, when i write "linux" in the command line, stuff happen and after 3-4 seconds the monitor just turns off!
i remember the same problem happened to me when trying to install FC4 Test3, but at that time i managed to fix it by adding an argument to the installer. it was something like "video=off" or "video-something" or "something-video=off" i really don't remember it.
anyway, if anybody knows how to fix this i'll really appreciate it.

17th June 2005, 08:23 PM

This is happening because you have to manually configure X Server AFTER you do the linux TEXT install. X doesn't work on the new mac mini or G5 automatically. I ran into the same problem.


Type: 'linux text video=ofonly' at yaboot prior to install.
After install is complete, you are automatically on run level 5. You must be on run level 3 for you to actually get yourself into the Linux shell in order to log in.


To fix this, after install, at yaboot type 'linux rescue' AFTER you have put your FC4 CD #1 in again. Follow the instructions on screen that tell you what you have to do to get to the shell (Don't set up your networking just yet, skip that part).


Once you are in the shell, type 'nano /etc/inittab' in order to make the proper edit. Once you are there, change the default runlevel to 3. You do this by replacing the number 5 with the number 3 in the line: 'id:5:initdefault' which is located just below the runlevel section of the file. SAVE YOUR MODIFICATION when you exit. After you saved, and exited, type 'reboot' at the shell prompt.

You can now boot into Fedora!...but only in text mode.


In order to get X to work (the graphical environment), log in as root and type 'locate Xorg' at the shell (You may have to type 'updatedb' before doing this, though). Once you have located it, 'cd' into the directory that contains the file 'Xorg'. Once there, type 'Xorg -config'. This will create a configuration file for 'Xorg' in the root directory. Go there, and run 'nano xorg.conf.new' (that's the name of the file)...

In order for X to work on Mac mini or G5, you MUST manually configure this file to ALL specifications! To test your edits, save, exit, and run 'X -config xorg.conf.new' at the command prompt. If X still doesn't work, you must reboot, log in as root again, and try editing the file until X DOES work! Try try try again...

Once it works, you're almost done! Just place that changed configuration file in the directory that contains the file 'X'. You can find it by typing 'locate X' at the shell prompt.

That's it! You're done! X WILL work! :)

~Marioman123 :)

18th June 2005, 08:28 AM
Thank you very much,
That solved my problem..
I appreciate it.