PDA

View Full Version : FC4 + laptop = no sound



Darkwax
15th June 2005, 08:06 PM
hello, in a newbie to the world of linux and open source trying to convert and leave the evil microsoft. I just installed FC4 in my Inspiron 700m but the sound doen't work. It does detect the sound card but during the sound test I hear nothing. It did work before with FC3. Is it that FC4 is too new and not all packages are available? or I do I need to do something special?

Thanks for your help.
Darkwax

milosilak
15th June 2005, 08:21 PM
I have the same problem with Inspiron 600m - can't hear any sounds, not even during sound test. And it did work before with FC3.

Manofmilk
15th June 2005, 08:50 PM
I just installed fedora core 4 as I wanted to teach myself the basics of linux. The sound is an on-board device which worked fine in windows (98 and xp). Fedora/Gnome detects it as a Cirrus logic, CrystalClear SoundFusion Audio Accelerator and the module is snd-cs46xx.
To the best of my memory this is correct. However no sounds play when try to play the test sound. (All the obvious things like do the speakers work etc etc have been checked)
As a complete linux virgin where do I go from here?

thesource
15th June 2005, 08:56 PM
NOOOOO!!!!!!!!!!!!!!!!!!!!!!!!!!!!! NOT IN FC4!!!!!!!!!!

I thought someone would have fixed this by now. But we had our chance to download and install pre-releases and send in bugs for our specific hardware.

This is how I fix it.

open up gnome-terminal or

log in root
type
#alsamixer

when alsamixer comes up use the < or > keyes to enable the master volume and the up arrow to adjust the level.

Make sure your have the following enabled and adjusted. MASTER and PCM I think the other ones are for stuff you may need like PHONE JACK or HEADPHONE for abvious reasons you might want those enabled and set to your prefrence.

thesource
15th June 2005, 08:57 PM
oh by the way. These settings may not "stay" after rebooting they may change back to default. If anyone knows how to fix this. let me know. THNKS

milosilak
15th June 2005, 09:03 PM
Thanks a lot, it works!I don't think I even touched anything in alsamixer, I just ran it and quit, and the sound now works.

Manofmilk
15th June 2005, 09:16 PM
did the mixer thing and enabled sound and now all is good (well nearly - I have to do it everytime i log on)

csfalcon
15th June 2005, 10:56 PM
when I first started reading this post, I was worried. thanks for the info, I'll need it when I install FC4 this weekend.

Darkwax
16th June 2005, 12:46 AM
THANK YOU ALL. Sound works now. Still, gotta run alsamixer in every boot. If anyone knows a permanent solution please let all of us know :) Thanks.

csfalcon
19th June 2005, 07:22 PM
okay, installed FC4 on Sat; to get the laptop speaker to work on my laptop:
go to volume control
edit -> preferences
check "external amplifier"
now check "enternal amplifier" in the "switches" tab.

the earphone jack worked since first boot for me.

raharris
29th June 2005, 10:15 PM
edit -> preferences
check "external amplifier"
now check "enternal amplifier" in the "switches" tab.


Thanks csfalcon! Worked for me!

RAH

blackguest
11th July 2005, 02:25 AM
Maybe this will help someone else:
My mic wasn't working until I started gnome-volume-control, then Edit->Preferences to check "Mic As Center/LFE" which allowed me to turn OFF/uncheck "Mic As Center/LFE:" and now it works.

Raafi
7th August 2005, 11:51 PM
NOOOOO!!!!!!!!!!!!!!!!!!!!!!!!!!!!! NOT IN FC4!!!!!!!!!!

I thought someone would have fixed this by now. But we had our chance to download and install pre-releases and send in bugs for our specific hardware.

This is how I fix it.

open up gnome-terminal or

log in root
type
#alsamixer

when alsamixer comes up use the < or > keyes to enable the master volume and the up arrow to adjust the level.

Make sure your have the following enabled and adjusted. MASTER and PCM I think the other ones are for stuff you may need like PHONE JACK or HEADPHONE for abvious reasons you might want those enabled and set to your prefrence.
HELP

My mic shows off in alsamixer, and I have hit arrows, buttons, keys, and I cant turn it on

also, during my gnomemeeting, it says I failed the STUN test. Does anyone know what a stun test is?

I am running FC4 on a Pavillion HP 500 (circa late 1999)

Raafi
7th August 2005, 11:52 PM
And while I am on the subject, since I have been on linux, I have lost all ability to webcam anyone in the outside world. And I can only use my webcam to see myself in CamStream

Are there any functions related to webcamming to the outside world in FC4?

So in summary, I have a webcam that I see myself, no voice and no way of contacting or communicating with the outside world. Any advice would be greatly appreciated.

Doug G
9th August 2005, 05:18 AM
okay, installed FC4 on Sat; to get the laptop speaker to work on my laptop:
go to volume control
edit -> preferences
check "external amplifier"
now check "enternal amplifier" in the "switches" tab.

the earphone jack worked since first boot for me.
Thanks, csfalcon, this made the sound come to life on my Dell Inspiron 1200 :)

EDIT: Oh yeah, fresh FC4 complete install brand new laptop.

Twey
3rd September 2005, 12:07 PM
To store alsamixer settings, run "alsactl store" as root.

unclefred
3rd September 2005, 07:57 PM
Well, this is similar. I have a SB Audigy card and FC4,updated. I have the sound operating but nothing from my audio CD. I've tried KMix and I tried the Alsamixer as root, suggested in previous posts. The volume sliders for the CD and the master are both up, as are most of the others for now. Even when I do get sounds, like for events, they are not at the volume I expected. All channels are marked. So I'm totally in the dark, or at least "CD deaf." Any help would be appreciated. The CD player worked well in WIN98 the last time I tried.

imdeemvp
3rd September 2005, 09:52 PM
NOOOOO!!!!!!!!!!!!!!!!!!!!!!!!!!!!! NOT IN FC4!!!!!!!!!!

I thought someone would have fixed this by now. But we had our chance to download and install pre-releases and send in bugs for our specific hardware.

This is how I fix it.

open up gnome-terminal or

log in root
type
#alsamixer

when alsamixer comes up use the < or > keyes to enable the master volume and the up arrow to adjust the level.

Make sure your have the following enabled and adjusted. MASTER and PCM I think the other ones are for stuff you may need like PHONE JACK or HEADPHONE for abvious reasons you might want those enabled and set to your prefrence.
For some add reason still happening......dont know why!

rathed9
4th September 2005, 11:58 AM
Those devious, naughty linux people get us all wrapped up in getting a simple sound card to work that when we go back to windows we forget why we're there, and then we notice how slow its running and how often management console crashes....hmnn.

My first Linux experience was on RH 9 and eventually I stumbled on getting sound to work. It seems a very redhat problem for whatever reason. Now on my laptop (which im ultra newb with) theres no sound on FC3 even though there was when I set the levels on a desktop, first try. I've heard that alsaconf can help but my system says no such file or directory and theres no alsaconf I can see on the DVD. I will try headphones and see if some sound works SOMEwhere...but if anyone finds a solution for the above? Run don't walk, and tell us........................:-0

imdeemvp
4th September 2005, 10:51 PM
I recently stumble into something wierd. I purchase a brand new laptop and the only way it would play the sound was by reversing the volume control settings from internal to external speakers.

kinghuan
8th September 2005, 09:59 AM
I can hear the sound with headphones, but the speaker……
I will try the methods you all suggest, hope it would work.
Thank you all!

willowist
11th September 2005, 04:02 PM
On my laptop i ran alsamixer and used the right arrow key to scoll through each setting and any that said off i used the m key to turn it on and the sound has always worked never had to set sound again.
Bill