View Full Version : Fedora Core 4 on a Power Mac G5

15th June 2005, 03:26 AM
How do I boot FC4 on my G5? Which boot.iso image should I use? :confused:

Please help! I have no idea what to do.

15th June 2005, 08:26 AM
hi ..

you can refere http://fedora.redhat.com/download/#download , from here you found FC4 for MaC

15th June 2005, 10:31 AM

Futher infomation you can found from http://fedora.redhat.com/docs/release-notes/fc4/errata/

15th June 2005, 10:58 PM
Thank you for the links; however, my screen still goes BLACK after yaboot does its job, seems like it doesn't matter what I enter at the initial command prompt. HELP!!!


15th June 2005, 11:45 PM
how do you mean your screen goes black?

when installing fc4 on my mini mac i had to tell linux not to ramp up the vertical refresh frequency

linux video=ofonly

Cheers ws

16th June 2005, 12:09 AM
Thank you!... that worked, but only in linux TEXT. Now how do I get the X window system (graphical installer) to load with its GUI?

Thanks again! :)

16th June 2005, 09:08 PM
does FC 4 work with MAC

17th June 2005, 12:29 AM
Yes it does, i've got it running on a mini mac, had some trouble installing it though but i think that's because i have a funny hard drive partitioning scheme.

Cheers ws

20th June 2005, 04:25 AM
FC4 is supposed to work really well with PPC.

26th June 2005, 05:37 AM
i ran into major cpu fan throttling problems and heat problems on a G4 PowerBook install
cpu fan spun up to where it made my laptop sound like a fighter jet getting ready to take off

5th July 2005, 02:37 PM
I tried FC4 on a iMac G5; all went well until login, then everything froze (mouse,cursor). I wasn't able to type my login-name and I didn't have any trouble installing!! I sincerely hope somebody will come across the same problem, as to find out what causes it??
Tried Alt+F2 and did a cat /var/log/messages but wasn't been able to read it all; same problem, everything froze!! Weird!! Fans running smooth, display 1600x1050, 16 bit color (just in case); even tried 640x480 and upwards, no luck. Not even with Ctrl+Command+Eject
Even made a single boot-cd from /images/macppc64; its loading the Elf64 kernel perfect.
It might be that the iMac G5 is just to new to get FC4 going.
Well if anyone comes across the same problem, please share, so we all know its not incidental.

29th August 2005, 09:44 PM
I had the same problem with the login/username screen freezing on a iMac G5. plus during install the fans sounded like a jet engine (but that's expected, Apple has complex cooling systems.) Anyway I just decided to not have Fedora on my iMac G5. So didn't really try to solve the problem.

29th August 2005, 10:53 PM
Well, I tried Ubuntu Live CD & SuSE Linux for PPC but no luck, but found a alternative.
Virtal PC is running very smooth and is doing FreeBSD & Solaris as well; still waiting tho' for progress on the PPC distribs