PDA

View Full Version : FC4 on iMac - crashes on install



Hexx
14th June 2005, 09:58 PM
It happens right as I am about to "finish" and the partitioning starts. I get this from the dump:

File "/usr/lib/anaconda/fsset.py", line 2066, in setupDevice
raise SystemError, "pvscreate failed for %s % (volume,)
SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0x3030c500>

then it exits...

During the install too, I get random errors, usually stating something about the filesystem...I can post these up tomorrow if needed.

Hexx
15th June 2005, 03:18 PM
So, there is a bug report on RH's site, with no "real" fix yet, although I found that hitting "cancel" instead of "ignore" on some of the errors I got before, worked. Sorry I dont have the exact error, but one of them said something about the partion and between sector 16-18 -- something to that extent.

easykill
15th June 2005, 10:32 PM
Could you point me to that bug report? I'm seeing the same thing. FYI, Disc 1 fails the preflight media check. I've downloaded 3 different copies of the ISO from 3 different mirrors. The SHA1 checksums all verify, but the media check fails. Had no trouble at all with Discs 2-5.

You are saying that you installed successfully by clicking "cancel" instead of "ignore"...? Sounds scary!

easykill
17th June 2005, 01:02 AM
Anyone else installing with CD's that can't get the media check to PASS on disc 1?

I am not sure if this is related to the crash-after-partition bug in Bugzilla.

Meanwhile I can't get FC4 installed.

:(

websavages
17th June 2005, 11:38 AM
Hex, i had the same problem as you on my mini mac, i solved it by creating an empty single partition using the mac disk utility. then i installed fed. core 4 test 3. once that was up and running (didn't bother with any updates). I then ugraded to fed. core 4 via anaconda upgrade. it now works.

hope this helps

Cheers ws

JLF_65
27th June 2005, 01:32 AM
I used the OSX disc utility to create the partitions I needed - my Mac partition, the FC4 partition, and the swap partition. Then while installing FC4, choose "Partition manually using DiskDruid". Then click on the partition you wish to use for FC4 and click "edit". Set the mountpoint to "/" and set it to format as ext3. Click on the partition you wish to use as swap and click "edit". Set it to format as swap. Then just do the rest of the install as normal. Worked like a charm on my iMac DV+ (450MHz G3 slot loader).