PDA

View Full Version : Fed. core on a mini mac


websavages
28th May 2005, 01:35 AM
Anyone tried this? I am space is at a premium in my home. If anyone has tried this, pointers tips etc would be usefull. I'll certainly post my trials and tribulations for others

Cheers WS

Dog-One
28th May 2005, 05:01 AM
I would say there are a few doing it:

http://www.google.com/search?q=Fedora+on+Mini+Mac

Nels664868
28th May 2005, 05:05 AM
Hi websavages,
I have installed FC4 test 3 (3.92) on my Mac Mini from the dvd image. This works well.
Xwindows and sound work from the basic install with no ajustments needed.
The mac mini's firmware cannot read the FC 3.92 dvd (the dvd is not blessed) so a boot cd needs to be burned from /images/mac/boot.iso .
Before the install of FC the harddrive needs to be repartitioned and OSX reinstalled
The only problem I had was with Up2date, it just froze. I used 'yum update ' instead.

nels

ewdi
28th May 2005, 05:08 AM
the only thing i couldnt get to work is the bluetooth modules and airport, the rest works fine

websavages
28th May 2005, 06:00 AM
gents thanks for the input,

Dog one, will go and read the link
nels, i'm thinking of using the whole partition for fc
ewdi, not worried about the extras all it needs to do is use the ethernet

Cheers once again ws

websavages
1st June 2005, 12:45 PM
Well managed to install fc 4t3 with only two minor issues, well three actually

1. when booting from cd to start the whole process the refresh rates used as defaults were to high for my monitor (cheap) this was solved by appending video=ofonly to the boot prompt in yaboot

linux video=ofonly resolution=1024x768

2. system beep makes a horrible sound,
3. kde thinks the mini mac is running off batteries with a large negative percentage for charge!!

points two and three don't bother me as the box is now running minus a monitor, keyboard and mouse. all happy!

Cheers ws

Nels664868
12th June 2005, 06:23 PM
FC4 works on the mac mini

Fedora Core release 4 (Stentz)
Kernel 2.6.11-1.1381_FC5 on an ppc

like the FC5 kernel? the regular FC4 repos aren't avalable till monday so tryed the development repos
had to disable the FC4 repos and enable development ones
only one problem the update erased throbber.png from /usr/share/gdm/themes/Bluecurve and the gdm login
complained about it so could not login to X
found throbber.png on my x86 box and copyed it over

websavages
14th June 2005, 08:48 AM
always good to know that fc4 runs on a mini. am bt'ing as i type. does anyone know if the sound card works automatically?

Cheers ws

websavages
15th June 2005, 01:08 PM
have finally donwloaded fc4 and put the cd in the appropriate hole. only to find anacondo falls over with the following message:

The partition's data region doesn't occupy the entire
partition

i then checked the disk partition with the mac disk utility to find two partitions, so i merged these into one empty one. fc4 final still complains but fc4t3 doesn't

so am now installing fc4t3 and then trying either a yum upgrade or letting the cd's do an upgrade

anyone have any ideas?

Cheers ws

Paul Rose
21st June 2005, 02:26 PM
Installed FC4 (release) on my mini last night (used the DVD image).
Beforehand I created a single empty partition using the Apple disk utility.
Graphical install worked fine, but X windows did not work upon startup (looked like incorrect timings, I could see the screen image but it had sever flicker and tearing).

I tried the video=ofonly and resolution=1024x768. For some reason it made no difference for me.

I could ssh in from another machine and everything works.

After several hours of poking around with different video= and resolution= lines I finally unplugged my 1600x1200 DVI LCD display and plugged in my CRT using the VGA dongle. Everything worked after this!

Running this way I set my resolution and refresh to really conservative settings using the GUI tools, shut down, reconnected the DVI LCD and still no dice. The LCD works fine under Panther.

Ultimately I'm going to use this as a server anyway, so I guess it doesn't matter, but it is a bit frustrating.

Any ideas?

Any chance Ubuntu or Yellow Dog would not have the same problem? (they probably use the same drivers, right?).

websavages
22nd June 2005, 11:19 AM
all my experiences are with a crt in the vga dongle, having said that, as soon as i can ssh in, i return the monitor to work.

as for which distro, choose the one you are most comfortable with and then play

Cheers ws

neeux
23rd June 2005, 09:08 AM
Hi,

I successfull installed FC4 on my MacMini.
Bur I have a little problem:
The fan turn all the time....

However the processor dont work...

Do you know the problem?

Thanks

websavages
23rd June 2005, 11:26 AM
what do you mean by running? full blast or just quietly turning over

mine runs as well constantly, i guess that's the price you pay for such a small form factor

Cheers ws

neeux
23rd June 2005, 01:57 PM
Full blast....
I installed Gentoo on mac mini one month ago. And the fan turned without noise...
But with FC4 the fan make much noise...
I don't uderstand... The fan is not break because under MacOSX it turn quietly...

Perhaps I must install somthing???

hackerotaku
26th June 2005, 05:32 AM
i got the same thing on a PowerBook G4 with a FC4 install
there is a bug track out on the thermal module in the kernel not being turned on or not working
i found a hack to get the fan to turn off
but my laptop gets very very hot
basically you increase the temperature threshold for when the cpu fan turns on

hack is this

echo 5 > /sys/devices/temperatures/limit_adjust

this increases the cpu temp limit to 55C from 50C

currently i am running Ubuntu ppc {Debian ppc Linux} and there are no heat or fan issues like there are with FC4

the limits are set to this on Ubuntu Linux

root@littlegreenmen:/sys/devices/temperatures # pwd
/sys/devices/temperatures
root@littlegreenmen:/sys/devices/temperatures # ls
cpu_fan_speed cpu_temperature devspec gpu_limit limit_adjust specified_fan_speed
cpu_limit detach_state gpu_fan_speed gpu_temperature power
root@littlegreenmen:/sys/devices/temperatures # cat cpu_fan_speed
0 (0 rpm)
root@littlegreenmen:/sys/devices/temperatures # cat cpu_limit
50
root@littlegreenmen:/sys/devices/temperatures # cat cpu_temperature
46
root@littlegreenmen:/sys/devices/temperatures # cat detach_state
0
root@littlegreenmen:/sys/devices/temperatures # cat devspec
/uni-n@f8000000/i2c@f8001000/fan@15croot@littlegreenmen:/sys/devices/temperatures #
root@littlegreenmen:/sys/devices/temperatures # cat gpu_fan_speed
0 (0 rpm)
root@littlegreenmen:/sys/devices/temperatures # cat gpu_limit
70
root@littlegreenmen:/sys/devices/temperatures # cat gpu_temperature
63
root@littlegreenmen:/sys/devices/temperatures # cat limit_adjust
0
root@littlegreenmen:/sys/devices/temperatures # cat specified_fan_speed
64
root@littlegreenmen:/sys/devices/temperatures #

wawa
27th June 2005, 04:31 PM
Hello

I've a problem on my mac mini
I can't get bluetooth module working, so I can't use bluetooth keyboard and mouse
Does anyone have this problem too ? I tried ubuntu and bluetooth worked fine...

neeux
27th June 2005, 06:01 PM
Thanks for your response Hakerotaku,

But unfortunely I dont have the folder /sys/devices/temperatures.....
I have the impression I'm only with this problem on Mac Mini... It's despairing...

websavages
29th June 2005, 08:58 AM
neeux, i don't have the /sys/devices folder either, have however noticed over the last few days that the fan does kick in quickly, hmm will keep you posted if i come across anything

Cheers ws

neeux
29th June 2005, 11:09 AM
Thanks you Websavages. I go on to search an soltion. If I found somethings I'll say you.
I think its a kernel's bug.....
highly a new kernel....

aristobrat
9th July 2005, 07:01 PM
I have the impression I'm only with this problem on Mac Mini... It's despairing...
Nope, add me to the list too. :D

neeux
11th July 2005, 08:40 AM
Ok I'm not alone now ;-)
If I found the solution I'll say you
:-D