PDA

View Full Version : nvidia problem



Zero-Override
23rd May 2005, 08:14 PM
i am trying to install the nvidia drivers but it tells me to quit xwindow but the heck do i do that?

havenoclu
23rd May 2005, 08:19 PM
There is a quick way to do it with ctrl-shift Fsomething I believe, but I would just edit your /etc/inittab file. You need to change the default run-level to "3" instead of "5". Then reboot. To get back to X when you're ready to, just type "startx". You can then re-edit you /etc/inittab file back to 5. Hope this helps.

Zero-Override
23rd May 2005, 08:21 PM
:cool: thx a lot ill try right now ;)

comsparks
23rd May 2005, 08:24 PM
Also make sure you have the latest driver. There was a kernel update today and I had to go get the latest Nvidia driver which was 7174 for me. There is a step by step guide on how to install and configure your computer to accept the Nvidia card and when I find it I will post it. I have a printout of it here that I use when a new kernel comes out.

Zero-Override
23rd May 2005, 08:32 PM
euhh what should i edit exactly?

comsparks
23rd May 2005, 08:33 PM
Check out this page and follow it and it will install the Nvidia Graphics card.

http://www.linuxquestions.org/questions/answers/378

Zero-Override
23rd May 2005, 08:46 PM
thx a lot ;) :cool:

sway
23rd May 2005, 08:51 PM
Solution is simple: in any of the Ctrl-Alt-F* shell type init 3 and install, then type startx and you are OK

drpt
23rd May 2005, 08:57 PM
the easy way to quit x is to change the driver in the x-org.conf, from "nv" to "nvidia".
when you restart X it will give you choices to see the log or fallback to a default config, Answer no to all and it will disable X.
cd to your "Nvidia...run" file. and let it fly, reboot and you should be done.
on my FC4 test box I made a script to do this, and "make and load other drivers for me.
#!/bin/bash
cd /z
echo -e "\033[34m Lazy snake"
sh NVIDIA-Linux-x86-1.0-7174-pkg1.run -s
echo -e "\033[31m reboot now"
reboot
I will write a script that will update and make new drivers, if x fails from a kernel update, but havent yet.

Zero-Override
24th May 2005, 07:56 AM
yeah i think thats my problem now cuz it said it couldn't make the kernel thingy because i didn't have the source kernel or kernel source :S

Finalzone
24th May 2005, 09:01 AM
Take a look at the alternate method to install Nvidia driver (http://forums.fedoraforum.org/showthread.php?t=54738). With that method, you won't have to touch xorg.conf. Another thing is an included script that will set back to nv if there is no kernel-module-nvidia that matchs a new kernel after update.

Zero-Override
24th May 2005, 05:10 PM
okay so i did that but im stuck at "yum localinstall $home/rpmbuild/RPMS/$arch/kernel-module-nvidia $home/rpmbuild/RPMS/$arch/nvidia-glx" i cant seem to translate it to my system :S it says:

[root@big-bill nvidia]# yum localinstall $home/rpmbuild/RPMS/i686/kernel-module-nvidia $home/rpmbuild/RPMS/i686/nvidia-glx
Setting up Local Package Process
Cannot open file: /rpmbuild/RPMS/i686/kernel-module-nvidia. Skipping.
Cannot open file: /rpmbuild/RPMS/i686/nvidia-glx. Skipping.
Nothing to do

now what?

Finalzone
24th May 2005, 05:33 PM
Look where are both kernel-module-nvidia and nvidia-glx. Then use yum localinstall from the path your packages are located. I will update the How-To to address that issue.

Zero-Override
26th May 2005, 08:49 AM
am i supposed to have those then :S oops

well doesn't really matter cuz i used a slightly different way, i got into init 3 did pretty much all i was supposed but i forgot one entry in xorg.conf (the glx command) but now i have a problem cuz everytime i boot into anything that uses startx it gives me a huge nvidia screen and stops in its tracks :( i doesn't respond to anything :S and i already put the inittab back to init 5 :(

so now what can i do?

Zero-Override
26th May 2005, 09:23 PM
does anyone have an idea?