View Full Version : Cannot install from CD after system update

5th May 2005, 10:40 PM
I'm running FC3.

Last week, I ran "yum update", and let it run its course. I used synaptic to install two games. Worked great. Now I want to install a tarball, but I realize I opted out of the Development group in FC3 setup.
I run "Add/Remove Applications" and choose Development Tools from the list and click "Update", but then I get the following dialog:

Packages Not Found

The following packages could not be found on your system.
Installation cannot continue until they are installed.

Unlocatable package - Required by - version - RPM version
libselinux - system-config-securitylevel - 1.4.18 - 2
dbus - dbus-glib - 0.22 - 10.FC3.2
dbus - dbus-python - 0.22 - 10.FC3.2
dbus - dbus-x11 - 0.22 - 10.FC3.2
krb5-libs - krb5-workstation - 1.3.6 - 5
pam - sane-backends - 1.0.15 - 1.4
libxml2 - libxml2-python - 2.6.16 - 3

When I check with Synaptic, these exact versions of the unlocatable packages are already installed on my system.

Clearly "Package Management" and synaptic disagree as to what is installed on my system.

1) Should I report this as a bug, and if so, where?

2) How do I get around this? Can't I install Fedora Package Groups from CD anymore, once I upgraded from the Internet?
I wanted to save time and bandwidth.

3) What packages should I manually install to compile tarballs, other than gcc?

Thanks for Your time!


5th May 2005, 11:19 PM
tyou'll have to download them noew the add/remove app only works with a fresh install BEFORE updating
this is a develop package that I use
Start installing away
yum install gcc

6th May 2005, 09:04 AM
tyou'll have to download them noew the add/remove app only works with a fresh install BEFORE updating
yum install gcc

That clears it up for me, thanks.
I picked a few of the packages you suggested in synaptic and the tarball installed fine.


BTW, did You ever get Samba working relilably in FC3? I once did, many moons ago, under Mandrake 9.1 using webmin. Now I'm totally confused because I can't get it working consistently in FC3.