PDA

View Full Version : ssh errors



linkku
11th April 2005, 07:50 AM
Hi! I got a question concerning ssh. When I connect to my FC3 box with my WinXp box using a Tectia ssh client, I get two different error messages after logging in, depending on the client settings.

1. "Error while reading Indicator status". This is the message when I have X11 tunneling enabled.

2. "Error opening display", when X11 tunneling is disabled.

Any ideas on what is wrong? I guess the latter could be logical, but whats with the first error message?

Linkku

ghenry
11th April 2005, 12:15 PM
I would says it's your client app. Have you tried Putty (search google for it)?

paul_dundee
11th April 2005, 01:14 PM
putty is definitely a good idea. You can download here. (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html)

linkku
11th April 2005, 01:47 PM
Thanks for the tips!

My question still continues as I noticed if I during a FC3 session login as a different user with ssh I get an "Error opening display"-message? What is this about then? Could I possible have a problem with my ssh server? Or should I just ignore it?

paul_dundee
11th April 2005, 01:55 PM
Check your passwd file (con't post it here!)

cat /etc/passwd.

Check the line for the user that you are trying to login as, if you have something like "/sbin/nologin" attached you will need to fix that.

Or try using root to login, see if there is a difference.

linkku
11th April 2005, 02:34 PM
Sorry I don't follow, the bit about my passwd file? How do I fix, what? There are a few lines with /sbin/nologin???

I get the same error message when I login as root.

AndyGreen
11th April 2005, 02:42 PM
the /sbin/nologin thing means that the associated account can never log in. It's a safety feature for accounts that are not meant to have a user, but just be used to run a particular program, for example, if you installed mysql there will be a mysql account to run it under. So it's normal to have accounts in there with /sbin/nologin as their shell. I think the suggestion was that by accident, your normal user has this instead of /bin/bash that it would normally be. But I doubt that's the problem.

linkku
12th April 2005, 12:40 PM
I got rid of #2 error, it was rather easy - tunneling has to be enabled in both the server and the client.

BUT #1 still really bugs me: I still get "Error while reading Indicator status" after login, even with PuTTY. It supposedly is a ssh server problem? Any ideas?

paul_dundee
12th April 2005, 11:03 PM
when you say login, are you only logging onto a terminal prompt or are you opening a display through vnc?

linkku
13th April 2005, 07:03 AM
I use ssh or PuTTY for loggin onto my FC3 box from another computer (WinXP).

Here's the output from PuTTY (I've modified the actual account and ip's):

login as: me
me@svante.runqvist.se's password:
Last login: Wed Apr 13 08:53:16 2005 from hinaaja.svennsson.se
Error while reading Indicator status
[me@svante ~]$

It would be nice to know what the actual error implies to? I don't have a clue...

VNC (with ssh) works fine using Winaxe, apart from full screen mode where the remote keyboard does not work. In multiple windows mode the keyboard works...are these two things related?

AndyGreen
13th April 2005, 07:40 AM
Yeah... could it be *keyboard indicator*, ie, keyboard LED status that it can't read?
In that case it sounds pretty nonfatal except for your fullscreen issue.

linkku
13th April 2005, 08:15 AM
Hey!

Thanks AndyGreen for setting me in the right direction! It certainly was LED issue...a while back I had installed a numlock rpm (http://fedoranews.org/tchung/numlock/numlock-2.0-9.fdr.i386.rpm). After removing it, the error ceased to exist.

tchung
30th April 2005, 09:22 PM
Hey!

Thanks AndyGreen for setting me in the right direction! It certainly was LED issue...a while back I had installed a numlock rpm (http://fedoranews.org/tchung/numlock/numlock-2.0-9.fdr.i386.rpm). After removing it, the error ceased to exist.

Hello,

Please try numlock-2.0-10.fdr.i386.rpm which I fixed ssh login issue.

http://fedoranews.org/tchung/numlock/

Thomas Chung