PDA

View Full Version : configure problem



Bluetint
22nd March 2005, 02:22 PM
I am a noob as far as linux goes so I'm still not sure about all the tricks to configuring/making programs. When i try to configure anything I get this:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for mative Win32... no
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH

I read somehwere that I need to set gcc or cc in my environment. Is this the solution? If so how do I do it?

Razorblade
22nd March 2005, 02:45 PM
You'll have to install the gcc compiler.
If you have kde or Gnome installed and have the FEdora CDs go to System Settings --> Add/Remove Programs --> Development Tools. There should be the desired compiler. Install it and then try again.

jim
22nd March 2005, 02:45 PM
Step 1

rpm-q gcc
If you have nothing returned then Switch to root

yum install gcc

Bluetint
22nd March 2005, 03:16 PM
Thanks fedorajim that worked but I still have a problem. When I try to configure atk and pango I get this error:

checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check

Any ideas?

tashirosgt
22nd March 2005, 04:16 PM
You might not have the C++ compiler installed ( /usr/bin/g++ ). But look in the configure.log file to find the exact error.