PDA

View Full Version : DVDstyler install probs



4ebees
22nd March 2005, 05:11 AM
Hi,

I have FC3 on a p4 3.0G.

I have a stock standard kernel.

Attached is the config file from DVDStyler when I've tried to install it:

As far as I'm aware I've installed all the necessary software - which just goes to show what I know :)

Any assistance would be most appreciated.

tashirosgt
22nd March 2005, 03:46 PM
The log file shows that the configuration script found the gnu C-compiler but failed to find the gnu C++ compiler (g++).
Do you have the file /usr/bin/g++ on your system?

4ebees
23rd March 2005, 09:16 AM
Hi tashirosgt,

Thanks for the post.

I've looked and found only the following:

/usr/lib/libg++.so.2.7.2.8

AND

/usr/lib/libg++.so.2.7.2

Should I install g++? - will YUM do this?

I use KDE. Does this make a difference (ie. can I still use DVDStyler)?

4ebees
25th March 2005, 03:50 AM
Okay,

found out how to do that. Now I get the following error - this is only the last bit:

Making all in wxVillaLib
make[1]: Entering directory `/home/patrick/programs/DVDStyler-1.31/DVDStyler-1.31/wxVillaLib'
source='ImageBox.cpp' object='ImageBox.o' libtool=no \
depfile='.deps/ImageBox.Po' tmpdepfile='.deps/ImageBox.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
g++ -DPACKAGE_NAME=\"DVDStyler\" -DPACKAGE_TARNAME=\"dvdstyler\" -DPACKAGE_VERSION=\"1.0\" -DPACKAGE_STRING=\"DVDStyler\ 1.0\" -DPACKAGE_BUGREPORT=\"dvdstyler-users@lists.sourceforge.net\" -DPACKAGE=\"dvdstyler\" -DVERSION=\"1.0\" -I. -I. -g -O2 -I/usr/lib/wx/include/gtk-2.4 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DDATADIR=\"/usr/local/share/dvdstyler\" -c -o ImageBox.o `test -f 'ImageBox.cpp' || echo './'`ImageBox.cpp
ImageBox.cpp:264: fatal error: opening dependency file .deps/ImageBox.TPo: Permission denied
compilation terminated.
make[1]: *** [ImageBox.o] Error 1
make[1]: Leaving directory `/home/patrick/programs/DVDStyler-1.31/DVDStyler-1.31/wxVillaLib'
make: *** [all-recursive] Error 1

'fraid I'm stuck again.

tashirosgt
26th March 2005, 05:59 PM
See if you can find the file .deps/Imagebox on you machine by doing
locate .deps/Imagebox
and look at its permissions. My interpretation of the error is that the account which is running the make can't open that file.

4ebees
30th March 2005, 02:06 PM
Urm... embarrassing really...

Everything seemed to be where it should be (after the help I'd received here and from my local LUG), but it still wouldn't install..

I was going 'sudo...blah. Once I'd su'd to root, it installed. Quite interested in now getting a disk burnt.

Thanks very much for your help.