PDA

View Full Version : Can not burn DVD's



ruffieux
21st March 2005, 10:40 PM
Hi,

I've got a strange problem with my DVD recorder and hope, that somebody can help me:

Installation:
- Fedora core 2
- Kernel: 2.6.9-1.11_FC2smp
- cdroast-0.98a15-6.FC2.1
- xcdrecord-ProDVD-2.01a27-1


I can burn CD ROM's of any kind from my Fedora Core 2 installation and I can burn any kind of DVD's and CD ROM's from my Windows XP installation on the same PC without any problems.

However, when I want to burn DVD's from my Fedory Core 2 installation I have the problem, that the burn process starts and finishes withing seconds without any error messages.

For the installation of xcdroast I followed 1:1 the following description:
http://www.fedoranews.org/tchung/xcdroast/

Please find the output of xcdroast at the end of this post.

Can anybody explain this problem?

Thanks a lot

Heinz


Output of xcdroast:

Calling: /usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORDPRODVD dev= "/dev/cdrom1" gracetime=10 fs=4096k driveropts=burnfree -v -useinfo speed=4 -dao -eject -pad -data "/tmp/csr-avia-dscr.img" ...

scsidev: '/dev/cdrom1'
devname: '/dev/cdrom1'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
SCSI buffer size: 64512
Cdrecord-ProDVD-Clone 2.01a27 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J÷rg Schilling
Unlocked features: ProDVD Clone
Limited features:
This copy of cdrecord is licensed for: private/research/educational_non-commercial_use
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'
Driveropts: 'burnfree'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'PIONEER '
Identifikation : 'DVD RW DVR-106D'
Revision : '1.05'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: DVD-R sequential recording
Profile: DVD+R
Profile: DVD+RW
Profile: DVD-RW sequential overwrite
Profile: DVD-RW restricted overwrite
Profile: DVD-R sequential recording (current)
Profile: DVD-ROM
Profile: CD-RW
Profile: CD-R
Profile: CD-ROM
Using generic SCSI-3/mmc-2 DVD-R/DVD-RW driver (mmc_dvd).
Driver flags : DVD MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1605632 = 1568 KB
FIFO size : 4194304 = 4096 KB
pregap1: -1
Track 01: data 4353 MB padsize: 30 KB
Total size: 4353 MB = 2228841 sectors
Current Secsize: 2048
Total power on hours: 317511
Blocks total: 2298496 Blocks current: 2298496 Blocks remaining: 69655
Starting to write CD/DVD at speed 4 in real SAO mode for single session.

mungoose
22nd March 2005, 11:33 PM
When you read the first 5 lines of your cd-record protocol it seems that line number 5 shows were your problem is. Cdrecord wants to talk to the device directly.
As user root get xcdroast to scan your drives again. It will most probably not show an entry like /dev/cdrom1. It will show the real device addresses it finds and uses.
In a terminal window as user root you can run 'cdrecord dev=ATA -scanbus'.
Add the entry it shows for the drive in question to /etc/cdrecord.conf. It might look as following:

pioneer= ATA:1,0,0 -1 -1 burnfree

Comment out all the other drive entries by placing the # sign in front of it.
After making the changes cdrecord should work as expected.

ruffieux
23rd March 2005, 10:41 PM
Hi mungoose,

Thank you very much for your help. I really appreciate it.

The rescan came back with /dev/cdrom1 again. So I assumed that this has to bee correct. Then I found out that in the cdrecord.conf file the recorder points to /dev/cdrom (not cdrom1).

I changed it the file no looks as follows:

#ident @(#)cdrecord.dfl 1.4 02/07/07 Copyr 1998 J. Schilling
#
# This file is /etc/cdrecord.conf
# It contains defaults that are used if no command line option
# or environment is present.
#
# The default device, if not specified elswhere
#
CDR_DEVICE=pioneer

#
# The default speed, if not specified elswhere
#
# Note that newer cdrecord versions do not default
# to speed=1. For MMC compliant drives, the default
# is to write at maximum speed, so it in general does
# not make sense to set up a default speed in /etc/cdrecord.conf
#
#CDR_SPEED=40

#
# The default FIFO size if, not specified elswhere
#
CDR_FIFOSIZE=4m

#
# The following definitions allow abstract device names.
# They are used if the device name does not contain the
# the characters ',', ':', '/' and '@'
#
# Unless you have a good reason, use speed == -1 and let
# cdrecord use it's intercal drive specific defaults.
#
# drive name device speed fifosize driveropts
#
pioneer=/dev/cdrom1 -1 -1 burnfree

The command cdrecord dev=ATA -scanbus brought the following output:

Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 J├Ârg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
0,0,0 0) *
0,1,0 1) 'SONY ' 'DVD-ROM DDU1612 ' 'DYS3' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
scsibus1:
1,0,0 100) 'PIONEER ' 'DVD RW DVR-106D' '1.05' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *

Unfortunetely I still have the same problem. Does anybody knows what's wrong with my DVD configuration? Please remember: Burning CD-ROMS works fine.

Thanks

Heinz

mungoose
23rd March 2005, 11:57 PM
As I said before change the cdrecord.conf line to read ATA:1,0,0.
And I don't know why the cdrecord line in the first list specified -dao even if your seems not to support this mode.
I just recognized that you have FDC2. I remember my DVD/DVD-RAM did only work with one version of the 2.6.10 kernels supplied by FDC2 update tree.

However, the cdrecord tools you have are not the original. They are modified versions as you can see in the output. So I don't know if the problem is in the patched cdrecord and/or in the patched kernel. More or less I suspect a problem in the patched cdr-tools.

But you might want to try to go the 'old' way. Add the parameter hdc=ide-scsi to your grub.conf line for the kernel you start. But do not forget that cdrecord -scanbus afterwards and to adjust your cdrecord.conf accordingly. After that cdrecord uses the 'old' scsi scheme again.

golding
24th March 2005, 08:27 AM
Have you tried using Xcdroast as root? If it works then, you may have some file, or device, permissions problems.

Also, is your ProDVD key (ftp://ftp.berlios.de/pub/cdrecord/ProDVD/README) up to date?, last change was on Feb 16th this year.

ruffieux
24th March 2005, 11:53 PM
Have you tried using Xcdroast as root? If it works then, you may have some file, or device, permissions problems.

Also, is your ProDVD key (ftp://ftp.berlios.de/pub/cdrecord/ProDVD/README) up to date?, last change was on Feb 16th this year.

Yes, i am always running it as root and yes, I do use the newest key. Unfortunately it still does not work.

But many thanks for your help anyway.

Heinz

ruffieux
24th March 2005, 11:57 PM
As I said before change the cdrecord.conf line to read ATA:1,0,0.
And I don't know why the cdrecord line in the first list specified -dao even if your seems not to support this mode.
I just recognized that you have FDC2. I remember my DVD/DVD-RAM did only work with one version of the 2.6.10 kernels supplied by FDC2 update tree.

However, the cdrecord tools you have are not the original. They are modified versions as you can see in the output. So I don't know if the problem is in the patched cdrecord and/or in the patched kernel. More or less I suspect a problem in the patched cdr-tools.

But you might want to try to go the 'old' way. Add the parameter hdc=ide-scsi to your grub.conf line for the kernel you start. But do not forget that cdrecord -scanbus afterwards and to adjust your cdrecord.conf accordingly. After that cdrecord uses the 'old' scsi scheme again.


I tried everything but hdc=ide-scsi and it still does not work. I am using lilo. Do I have to state "append=hdc=ide-scsi ?
In what way should I ajdust the cdrecord.conf file? Like pioneer=ide-scsi:1,0,0 -1 -1 burnfree?

Thanks again for your help

Heinz

golding
25th March 2005, 01:46 AM
Yes, i am always running it as root and yes, I do use the newest key. Unfortunately it still does not work.

But many thanks for your help anyway.

Heinz
Long shot, but try to burn from the command line, if it works then it is a problem with the frontend, if not, then a problem with the cdr-tools package.

As stated above, the cdrtools package is not original. The same is for Xcdroast as well. Perhaps you may want to remove all the RPM packages of these and install/compile from the source. It is very easy for these apps. I did it once, and I am not exactly a shining light of expertise :-)

The only other alternative I can think of is K3B.