PDA

View Full Version : What the font ???



gerwazy
21st March 2005, 09:59 PM
Hello,

On www.themedepot.org I have found a screenshot with very nice and very clean font (look at firefox menu):
http://www.themedepot.org/showzoomedframe.php4?id=1645

Anyone knows what is the name of this font and where it can be found?
For sure it is not Luxi sans or bitstream and I don't think it is any of ms core fonts.

thanks.

PeTzZz
22nd March 2005, 06:32 PM
For sure it is not Luxi sans or bitstream
Actually it does look so similar to Luxi Sans. I use it with enabled bytecode hinting (http://www.fedoraforum.org/forum/showpost.php?p=158988&postcount=7).

gerwazy
22nd March 2005, 10:28 PM
Yes it is similar but for example the "i" letter is different.

I have tried bytecode hinting and i'm still not sure if it looks better than full hinting.
Letters seem to be stronger but I think that the shape is worse. Maybe it just needs to grow on me.

Thank You for the tip.

P.S. I have attached small pictures of full hinting and bytcode for comparison if anyone is interested.

gerwazy
23rd March 2005, 07:27 PM
I think I'm missing something here. I have prepered freetype with BCI enabled according to instructions and installed it on my machine. I have restarted the computer and than fonts were very ugly. I went to Preferences->Fonts and disabled hinting at all. After this fonts became much better (second picture) and i thought that this is how freetype with BCI works. I was not very happy with the result I gained so I have switched back to freetype without BCI.

I have restarted the computer and ... freetype (without BCI and hinting turned off) rendered the font almost in the same way. So what's the deal here? Could someone post some screenshots for comparison? Font on mine is Tahoma 9.

Thank You for your patience :).

P.S. I have attached a screenshot of freetype without BCI and hinting turned off.

PeTzZz
23rd March 2005, 07:56 PM
I have restarted the computer and ... freetype (without BCI and hinting turned off) rendered the font almost in the same way. So what's the deal here?
I don't understand the problem so exactly. You mean that it didn't revert changes? How did you switch back?

gerwazy
25th March 2005, 03:31 PM
Sorry, maybe I wasn't so clear about this.
Here are the steps that I have performed:
1. Prepared and installed freetype package with BCI on.
2. Because I wasn't happy with the result (fonts were really ugly) I messed a little with font configuration. I went to Preferences->Fonts and changed hinting configuration. Finally I turned off hinting at all. I have presented the results on the second screenshot in my first post with screenshots :).
3. Since I simply didn't like the way my desktop looked I have compiled freetype without BCI. I have installed the library, turned on the hinting again. The result is on the first screenshot. I made a small experiment and turned off the hinting, just the way I did when I had a freetype library with BCi installed. The last screenshot presents the result I have gained.

My conclusion is that either somehow I did not manage to benefit from BCI or BCI is not so much better then default freetype configuration.

When I get home from work I will post a screenshot of a freetype library with BCI on and hinting on.

PeTzZz
26th March 2005, 12:32 PM
My conclusion is that either somehow I did not manage to benefit from BCI or BCI is not so much better then default freetype configuration.
It is all about the taste. I use BCI, Luxi Sans 8 as application font, Luxi Sans 9 as desktop and window title font and I am very satisfied. At first it looked a little bit strange, because I had used default font configuration for a long time, but I got used to it.

I have tried these hacks (http://gnome-hacks.jodrell.net/hacks.html?id=54) also with small font size, but I didn't like the result so much. You cannot use many (Linux) fonts if it is enabled, because many fonts are not built to be good without being antialiased. You can use for example Tahoma, Verdana ... Secondly I am not so used to it any more too - the fonts are too narrow then, like in windows. :p

Threads that you may find useful:
http://www.fedoraforum.org/forum/showthread.php?t=21172
http://www.fedoraforum.org/forum/showthread.php?t=2231

meijer.o
26th March 2005, 03:25 PM
Fonts in fedora can de perfect with the bci enabled and tahoma (microsoft) You must disable the graphical boot.

See my fonts, i could sent you an RPM

Kind regards,

Otto Meijer :)